mailto: URL always chooses the default account, instead of correct identity

VERIFIED INVALID

Status

SeaMonkey
MailNews: Account Configuration
P2
normal
VERIFIED INVALID
16 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
All
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Branch build 2001-10-08-05: WinMe
Branch build 2001-10-09-04: Linux RH 7.1
Branch build 2001-10-09-03: Mac 9.1

As reported by Bob Lord and mentioned in bug # 79053.

Overview: "I found another case where a mail compose window does not correctly
inherit the mail account selected in the mail window.  The case is in mailto:
links."

Steps to reproduce:  
1. Open a profile with multiple Mail accounts (i.e. Home account, Work account)
2. Select the Work account
3. Change focus to a window with a mailto: URL (like this bug :-) )

Actual Results: The new message/compose window has the Home account's email
address in the From field.

Expected Results: It should have the Work account in the From field.

Comment 1

16 years ago
reassigning to varada.
Assignee: racham → varada
Keywords: nsbeta1

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+

Updated

16 years ago
Priority: -- → P2

Updated

16 years ago
Blocks: 122274
Status: NEW → ASSIGNED
Keywords: nsbeta1+ → nsbeta1-
No longer blocks: 122274

Comment 2

16 years ago
Bug 123244 seems to be the opposite of this one, except for that 123244 is about
pressing Ctrl+M while this one is about clicking a mailto: link. I guess one of
them has to be WONTFIXed, but which one?

Comment 3

16 years ago
Defaulting "From:" to a different email account is particularly surprising when
the mailto "link" is an email address in a MESSAGE, either in the headers pane
of the message or in the body of the message.  At least when the link is from a
message being viewed in MailNews, it should use the current selected account as
the "From:".

To Reproduce:  
1. Select a non-default email account in MailNews
2. View an email message
3. Click on an email address in the message (headers or body) to compose new mail

Expected Result:  Compose window From: field defaults to *current* account

Actual result:    Compose window From: field defaults to *default* account

(Build 2002020406 0.9.8 on w2k)

Comment 4

16 years ago
*** Bug 126388 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

15 years ago
Marking nsbeta1. After selecting a message and selecting a mailto link from the
header or body of the message, the "From" field should use the currently
selected account to determine the "From" field instead of the default account.
Keywords: nsbeta1- → nsbeta1

Comment 6

15 years ago
See also bug 99363.

Comment 7

15 years ago
*** Bug 176834 has been marked as a duplicate of this bug. ***
taking all of varada's bugs.
Assignee: varada → sspitzer
Status: ASSIGNED → NEW
this might turn into a wontfix.

see bug #99363
Depends on: 99363
marking invalid.  this is the desired behavior.

#79053 has been backed out.  see #99363.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

15 years ago
Verified Invalid.
Status: RESOLVED → VERIFIED

Comment 12

14 years ago
*** Bug 210136 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
Why no explanation of why this is the "desired behavior" vs. an RFE?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.