A nightly GUI bug that causes the add tab button image to 'stick' on the tab bar

VERIFIED FIXED in Firefox 33

Status

()

VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: mainboard71, Assigned: bas.schouten)

Tracking

(Blocks: 1 bug, {regression})

34 Branch
mozilla34
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox32 unaffected, firefox33+ verified, firefox34+ verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8458109 [details]
an image of the bug

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

opened a new tab then closed it in the most recent Nightly 64 bit version


Actual results:

the add tab button seems to 'stick' where it was on the second tab.


Expected results:

it should not stick there as it does in the screenshot.
(Reporter)

Updated

5 years ago
Component: Untriaged → Tabbed Browser
Keywords: 64bit

Comment 1

4 years ago
Can you provide the graphics section of about:support ?
Flags: needinfo?(mainboard71)
Component: Tabbed Browser → Layout
Product: Firefox → Core

Updated

4 years ago
Duplicate of this bug: 1043348

Comment 3

4 years ago
pypcier, can you provide the graphics portion of about:support  (Help > Troubleshooting information) ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(rurkuu)
Keywords: regression, regressionwindow-wanted

Comment 4

4 years ago
(In reply to :Gijs Kruitbosch (Gone July 26 - August 3) from comment #3)
> pypcier, can you provide the graphics portion of about:support  (Help >
> Troubleshooting information) ?

Graphics
--------

Adapter Description: ATI Radeon HD 4300/4500 Series
Adapter Drivers: aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Adapter RAM: 512
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 100
Device ID: 0x954f
Direct2D Enabled: Blocked for your graphics driver version.
DirectWrite Enabled: false (6.2.9200.16581)
Driver Date: 4-24-2013
Driver Version: 8.970.100.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Flags: needinfo?(rurkuu)

Comment 5

4 years ago
Milan, this looks like a recent graphics regression... can you have a look? Note in particular that bug 1043348 comment #0 (from the dupe) noted that this goes away in safe mode, but not when disabling add-ons, which means I suspect this is fixed by turning off hardware accelerated rendering...
Component: Layout → Graphics
Flags: needinfo?(milan)
Version: 30 Branch → 34 Branch

Comment 6

4 years ago
(In reply to :Gijs Kruitbosch (Gone July 26 - August 3) from comment #5)
> Milan, this looks like a recent graphics regression... can you have a look?
> Note in particular that bug 1043348 comment #0 (from the dupe) noted that
> this goes away in safe mode, but not when disabling add-ons, which means I
> suspect this is fixed by turning off hardware accelerated rendering...

You are right, disabling hardware acceleration in settings fixed this issue for me.

Comment 7

4 years ago
(In reply to pypcier from comment #6)
> (In reply to :Gijs Kruitbosch (Gone July 26 - August 3) from comment #5)
> > Milan, this looks like a recent graphics regression... can you have a look?
> > Note in particular that bug 1043348 comment #0 (from the dupe) noted that
> > this goes away in safe mode, but not when disabling add-ons, which means I
> > suspect this is fixed by turning off hardware accelerated rendering...
> 
> You are right, disabling hardware acceleration in settings fixed this issue
> for me.

Thanks for the confirmation! Do you think you would be comfortable trying to look for a regression window on recent nightly, ie figuring out when this broke? If you know it happened recently, you could look manually, but we also have an automated python tool that can help: http://mozilla.github.io/mozregression/ .

Ideally we'd want to know what dates and/or revisions this last worked and first broke.
Flags: needinfo?(rurkuu)

Comment 8

4 years ago
I can reproduce the problem only if I set gfx.direct2d.disabled = false;

Regression window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/cd6457486d15
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140709123540
Bad:
https://hg.mozilla.org/mozilla-central/rev/6db315bcdb6a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140709124632
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cd6457486d15&tochange=6db315bcdb6a

Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b37955bdf1b6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140709071430
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/99690880e8f5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140709072429
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b37955bdf1b6&tochange=99690880e8f5

Triggered by:
	99690880e8f5	Bas Schouten ? Bug 1035227: Upload partial surfaces when an upload region is specified. r=nical

Comment 9

4 years ago
After trying many Nightly builds It turns out the problem was in fact caused by one of my addons (FireGestures) which is weird because disabling, or even removing it doesn't fix this issue. I feel pretty stupid for wasting your time.
Flags: needinfo?(rurkuu)

Comment 10

4 years ago
Disregard my previous comment. I don't have any idea what's causing it but it's back after installing a few addons.
HTTPS-Everywhere 3.5.3
Nightly Tester Tools 3.7
NoScript 2.6.8.33
Self-Destructing Cookies 0.4.4
YouTube ALL HTML5 2.1.3
It looks like it's not caused by one of my addons but rather by installing an addon. I have a lot of free time today so I can test anything you want, just ask.

Comment 11

4 years ago
(In reply to pypcier from comment #10)
> Disregard my previous comment. I don't have any idea what's causing it but
> it's back after installing a few addons.
> HTTPS-Everywhere 3.5.3
> Nightly Tester Tools 3.7
> NoScript 2.6.8.33
> Self-Destructing Cookies 0.4.4
> YouTube ALL HTML5 2.1.3
> It looks like it's not caused by one of my addons but rather by installing
> an addon. I have a lot of free time today so I can test anything you want,
> just ask.

Per comment 8, I think this is a real regression, and we can use the bug that was found to cause it there to move forward. Not sure what else, if anything, needs testing until/unless we find a fix... :-)
Blocks: 1035227
Keywords: regressionwindow-wanted
Assignee: nobody → bas
Flags: needinfo?(milan)

Comment 12

4 years ago
(In reply to Alice0775 White from comment #8)
> I can reproduce the problem only if I set gfx.direct2d.disabled = false;
> 

Err
gfx.direct2d.disabled = true
(Assignee)

Comment 13

4 years ago
(In reply to Alice0775 White from comment #12)
> (In reply to Alice0775 White from comment #8)
> > I can reproduce the problem only if I set gfx.direct2d.disabled = false;
> > 
> 
> Err
> gfx.direct2d.disabled = true

That makes sense. I'll fix this.
(Assignee)

Comment 14

4 years ago
I cannot reproduce this bug, is this strictly on 64-bit?
Duplicate of this bug: 1054729
As seen per Bug 1054729 this likely affects every already and about-to-be D2D-blocked GPU.
D3D is active then and thus safemode does not expose this.

(In reply to Elbart from Bug 1054729 comment 0)
> STR:
> - Open Nightly
> - Middle-click on the "Get your NIghtly User badge"-link

... on http://www.mozilla.org/en-US/firefox/nightly/firstrun/
status-firefox34: --- → affected
tracking-firefox34: --- → ?
Flags: needinfo?(mainboard71)
Keywords: 64bit
(In reply to Bas Schouten (:bas.schouten) from comment #14)
> I cannot reproduce this bug, is this strictly on 64-bit?

Do you have thoughts on tracking?
Flags: needinfo?(bas)
(Assignee)

Comment 18

4 years ago
(In reply to Benjamin Kerensa [:bkerensa] from comment #17)
> (In reply to Bas Schouten (:bas.schouten) from comment #14)
> > I cannot reproduce this bug, is this strictly on 64-bit?
> 
> Do you have thoughts on tracking?

It's still not clear to be whether this is 64-bit only? I still have never seen this bug.
Flags: needinfo?(bas)
Easily reproducible with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140820030202 CSet: ffdd1a398105, i.e. x86 Firefox running on Windows 7 x64 with gfx.direct2d.disabled;true set.

Comment 20

4 years ago
What do you mean with "64-bit only"? All reports here are from Firefox 32bit ("WOW64").
Tracking per comment 5.
tracking-firefox34: ? → +
(Assignee)

Comment 22

4 years ago
(In reply to Elbart from comment #20)
> What do you mean with "64-bit only"? All reports here are from Firefox 32bit
> ("WOW64").

The initial report said: 'opened a new tab then closed it in the most recent Nightly 64 bit version'

I'll try to reproduce this again, but now that I know this is easily reproducible for some people, I actually have an idea of what might cause this. XtC4UaLL, could you post your about graphics section? Can you confirm you're on an NVidia card?
(Assignee)

Comment 23

4 years ago
(In reply to Bas Schouten (:bas.schouten) from comment #22)
> (In reply to Elbart from comment #20)
> > What do you mean with "64-bit only"? All reports here are from Firefox 32bit
> > ("WOW64").
> 
> The initial report said: 'opened a new tab then closed it in the most recent
> Nightly 64 bit version'
> 
> I'll try to reproduce this again, but now that I know this is easily
> reproducible for some people, I actually have an idea of what might cause
> this. XtC4UaLL, could you post your about graphics section? Can you confirm
> you're on an NVidia card?

Yes, I've confirmed I -can- reproduce this on an NVidia machine. I'll have a fix up here soon which we will be able to uplift.
Blocks: 1036457
(Assignee)

Comment 24

4 years ago
Sadly my initial hunch was incorrect. I'll continue working on debugging this.
(Assignee)

Comment 25

4 years ago
Created attachment 8478868 [details] [diff] [review]
Combine update regions when upload hasn't been executed yet

So this turns out to be a tricky timing issue, which is why it's so device/compositor independent. This has everything to do with the compositor not compositing in time, and since we overwrite the previous update region when we receive a new one, a subsequent composition will only upload the new region not the old one.

I've chosen a fairly hacky, but simple approach to fix this, so we can test it and easily uplift with little to no risk.

It's somewhat worrying this bug occurs, since it means when opening and closing tabs our D3D11 compositor is having a particularly hard time. At the same time it's sort of surprising we haven't seen this bug anywhere else!
Attachment #8478868 - Flags: review?(nical.bugzilla)
Comment on attachment 8478868 [details] [diff] [review]
Combine update regions when upload hasn't been executed yet

Review of attachment 8478868 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch
Attachment #8478868 - Flags: review?(nical.bugzilla) → review+
https://hg.mozilla.org/mozilla-central/rev/57a02fe884d9
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox34: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Depends on: 1060114
QA Whiteboard: [good first verify]
(Assignee)

Comment 29

4 years ago
Comment on attachment 8478868 [details] [diff] [review]
Combine update regions when upload hasn't been executed yet

Approval Request Comment
[Feature/regressing bug #]: OMTC
[User impact if declined]: Drawing artifacts
[Describe test coverage new/current, TBPL]: Nightly & Aurora
[Risks and why]: -Must- be combined with 1060114. Relatively low risk, extensively tested.
[String/UUID change made/needed]: None
Attachment #8478868 - Flags: approval-mozilla-beta?
status-firefox32: --- → unaffected
status-firefox33: --- → affected
tracking-firefox33: --- → +
Comment on attachment 8478868 [details] [diff] [review]
Combine update regions when upload hasn't been executed yet

beta+. Approval coming for bug 1060114. These changes will ship in beta2.
Attachment #8478868 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Duplicate of this bug: 1062311
Reproduced with gfx.direct2d.disabled = true using Nightly 33.0a1 2014-07-17.

Verified as fixed using Firefox 33 beta 2 (20140908190852) and latest Aurora 34.0a2 (20140907004002).
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify]
status-firefox33: fixed → verified
status-firefox34: fixed → verified
QA Contact: petruta.rasa

Updated

4 years ago
Duplicate of this bug: 1065095

Updated

4 years ago
Duplicate of this bug: 1095134
You need to log in before you can comment on or make changes to this bug.