Closed Bug 1047924 Opened 5 years ago Closed 5 years ago

When building with ac_add_options --enable-extensions extensions are put expanded into the wrong location in dist/bin

Categories

(Firefox Build System :: General, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED
mozilla34

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

(Keywords: dogfood, regression)

Attachments

(1 file)

In the old build system extensions would be expanded under dist/bin/distribution/extensions but they currently being put under dist/bin/extensions
This means that when a new user starts the application they do not have the extensions and they do not show up under Extensions in the Add-ons Manager.
The code that does the expansion starts at:
http://mxr.mozilla.org/comm-central/source/mozilla/config/rules.mk#1361
Blocks: 1044460
Severity: normal → critical
Keywords: dogfood, regression
I did look at potentially using DIST_SUBDIR but that also changes FINAL_TARGET in config.mk and I think it is not the intended use of DIST_SUBDIR.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #8466763 - Flags: review?(mh+mozilla)
No longer blocks: 1044460
Depends on: 1044460
Comment on attachment 8466763 [details] [diff] [review]
Proposed fix [Checked into m-i: Comment 3]

Review of attachment 8466763 [details] [diff] [review]:
-----------------------------------------------------------------

meh
Attachment #8466763 - Flags: review?(mh+mozilla) → review+
Comment on attachment 8466763 [details] [diff] [review]
Proposed fix [Checked into m-i: Comment 3]

https://hg.mozilla.org/integration/mozilla-inbound/rev/ae747b1cc524
Attachment #8466763 - Attachment description: Proposed fix → Proposed fix [Checked into m-i: Comment 3]
Attachment #8466763 - Flags: checkin+
Blocks: 1047981
Blocks: 1049800
What used to happen was that extensions were built into dist/bin/extensions and then in omnijar builds suite/app/Makefile.in would zip them up into XPIs into dist/bin/extensions or dist/bin/distribution/extensions as appropriate, but if you used --enable-chrome-format=flat then the extensions would remain flat in dist/bin/extensions so that you could easily develop them. Is there any way we can maintain this developer option?
https://hg.mozilla.org/mozilla-central/rev/ae747b1cc524
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Blocks: 1051642
Flags: qe-verify+
This is probably not worth spending the time to verify since it does not affect standard builds.
Flags: qe-verify+ → qe-verify-
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.