Port relevant changes from Bug 1043344 for moving libraries and programs build to the compile tier

RESOLVED FIXED

Status

--
blocker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Tracking

({dogfood, regression})

Trunk
dogfood, regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
Currently c-c is broken following the landing of Bug 1043344.
The errors you get are similar to:
make: Entering an unknown directory
make: *** mailnews/import/src: No such file or directory.  Stop.
make: Leaving an unknown directory
make[4]: *** [mailnews/import/src/target] Error 2
Severity: normal → blocker
Keywords: dogfood, regression
(Assignee)

Updated

4 years ago
Depends on: 1045329
(Assignee)

Comment 1

4 years ago
Created attachment 8464419 [details] [diff] [review]
Port lots of changes from m-c build system (WIP)

I did try and keep the patch as small as possible, but as I fixed each issue the size grew.
This includes the fix to bug 1045484 as well.
It isn't finished yet as it falls over because it does not pick up mailnews/intl as needing to be an export_dir

My .mozconfig is:
export CC=clang
export CXX=clang++
mk_add_options MOZ_CO_PROJECT=suite
ac_add_options --enable-application=suite
ac_add_options --enable-calendar
ac_add_options --enable-debugger-info-modules="yes"
mk_add_options MOZ_OBJDIR=/home/gizmo/central/c-c/obj-sm
ac_add_options --enable-optimizer="-O2 -gstabs+"
mk_add_options MOZ_MAKE_FLAGS="-j4"
ac_add_options --with-ccache=/usr/bin/ccache
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Comment on attachment 8464419 [details] [diff] [review]
Port lots of changes from m-c build system (WIP)

keeping joshua in the loop and a chance to provide *early* feedback
Attachment #8464419 - Flags: feedback?(Pidgeot18)
(Assignee)

Updated

4 years ago
Depends on: 1045969
Comment on attachment 8464419 [details] [diff] [review]
Port lots of changes from m-c build system (WIP)

I'm already in the loop, but I'm in no position to do any patch reviews.
Attachment #8464419 - Flags: feedback?(Pidgeot18)
(Assignee)

Updated

4 years ago
Depends on: 1046468
(Assignee)

Comment 4

4 years ago
Created attachment 8465149 [details] [diff] [review]
Unbitrotted working patch [Checked in: Comment 10]

This patch, along with the fixes on bug 1045969 and bug 1046468, does generate a working SeaMonkey and Thunderbird build for me.
I've not tested other c-c based applications or L10n at this point.

Potentially there is stuff that is not needed or other stuff that is needed, but at least it is a working starting point :)
Attachment #8464419 - Attachment is obsolete: true
Attachment #8465149 - Flags: review?(standard8)
(Assignee)

Comment 6

4 years ago
(In reply to Ian Neal from comment #5)
> Pushed to try -
> https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=24233e5b4987

Okay, bustage is due to landing of bug 1044162
I'll look at sorting that out tomorrow.

Updated

4 years ago
Duplicate of this bug: 1045484
Comment on attachment 8465149 [details] [diff] [review]
Unbitrotted working patch [Checked in: Comment 10]

Review of attachment 8465149 [details] [diff] [review]:
-----------------------------------------------------------------

This looks reasonable, I haven't done an indepth review, but assumed you've ported things across nicely.
Attachment #8465149 - Flags: review?(standard8) → review+
(Assignee)

Updated

4 years ago
Blocks: 1046638
(Assignee)

Comment 9

4 years ago
Pushed again to try with fix to bug 1046638 as well:
https://hg.mozilla.org/try-comm-central/rev/a919fb83f070
(Assignee)

Comment 10

4 years ago
Comment on attachment 8465149 [details] [diff] [review]
Unbitrotted working patch [Checked in: Comment 10]

https://hg.mozilla.org/comm-central/rev/f200e20f0ea9
Attachment #8465149 - Attachment description: Unbitrotted working patch → Unbitrotted working patch [Checked in: Comment 10]

Comment 11

4 years ago
<RattyAway>	Error: c:\t1\hg\objdir-sm\suite\installer\package-manifest:378: Missing file(s): bin/extensions/modern@themes.mozilla.org.xpi
Error: c:\t1\hg\objdir-sm\suite\installer\package-manifest:569: Missing file(s): bin/distribution/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
etc
IanN: make package failed
extensions in bin\extensions\ are unpacked.
<RattyAway>	there is no bin\distributions\
...
<NeilAway>	RattyAway: extensions are supposed to be unpacked in a regular build
RattyAway: make -C $objdir/suite/app pack-ext packages them
<IanN>	the build i have recently created from a patched c-c, has both chatzilla and inspector xpis but not a lightning one :(
...
(RattyAway runs: make -C $objdir/suite/app pack-ext ... generates packed XPI's)

NeilAway: ok now I've only got one error on make package:
Error: c:\t1\hg\objdir-sm\suite\installer\package-manifest:575: Missing file(s): bin/distribution/extensions/debugQA@mozilla.org.xpi
NeilAway: Makefile says:
  ifdef MOZ_OMNIJAR
  # Make extensions end up as XPIs instead of flat chrome when doing omni.jar.

(RattyAway runs: mozmake -j6 -C ../objdir-sm/suite/debugQA/)
This generates an unpacked bin/distribution/extensions/debugQA@mozilla.org
...
OK running make -C $objdir/suite/app again generates a packed debugQA@mozilla.org.xpi
...
tools::
	@$(MAKE) pack-ext STAGEDIST="$(DIST)/bin"
<RattyAway> NeilAway: didn't glandium do away with tools? aha Bug 1043802 - Remove TOOLS_DIRS and TEST_TOOLS_DIRS
Duplicate of this bug: 1045762
(Assignee)

Updated

4 years ago
Depends on: 1047702
(Assignee)

Comment 13

4 years ago
So Bug 1047702 covers the build system not searching comm-central for tools, XPI_PKGNAME, etc
and Bug 1047924 covers the build system not putting extensions in the right places under dist/bin
Depends on: 1047924
(Assignee)

Updated

4 years ago
Depends on: 1047981
(Assignee)

Updated

4 years ago
Blocks: 1047924, 1047981
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 1047924, 1047981
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.