[B2G][Dialer][Call Screen] Notification Bar icons are drawn on screen twice while in a call

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Marty, Assigned: gmarty)

Tracking

({regression})

unspecified
2.1 S3 (29aug)
ARM
Gonk (Firefox OS)
regression
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8476001 [details]
logcat-Call_Notifications.txt

Description:
Notification Bar icons (Clock, Battery, WiFi, SIM, etc.) are displayed twice when the user is in the call screen.  Discrepancies in icon priority between the call screen and the homescreen can cause icons to have different placements, leading to icon overlap.

Bug #1052333 greatly exacerbates this issue.

Repro Steps:
1) Update a Flame to 20140820040203
2) Connect the device to a WiFi network
3) Make or receive a call
4) Note the Notification Bar icons displayed at the top of the screen.


Actual:
Notification Bar icons are displayed twice.


Expected:
Notification Bar icons are only displayed once.

Environmental Variables:
Device: Flame Master
Build ID: 20140820040203
Gaia: df39c463259d348396ef7f143c2c780eeb8f02d8
Gecko: ffdd1a398105
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Note: I am unsure if this occurs on 2.0, because there don't appear to be any differences in icon order and priority between the Call Screen and the Homescreen.

Keywords: Notification Bar, Icon, Overlap, Paint, Redraw, Call Screen, Dialer


Repro frequency: 100%
See attached: screenshot, logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8476002 [details]
Notification_Icon_Call_Screenshot.png
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
We don't display those icons in the callscreen app so it's not a Dialer issue.
Component: Gaia::Dialer → Gaia::System::Window Mgmt
[Blocking Requested - why for this release]:
Bad visual bug during a common normal user path (receiving a call)
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Guillaume, Etienne, any idea where this comes from?
Flags: needinfo?(gmarty)
Flags: needinfo?(etienne)
(Assignee)

Comment 5

4 years ago
It looks like both minimised and maximised status bars are displayed at the same time. I'll have a look at the CSS.
Flags: needinfo?(gmarty)
Clearing since Guillaume in on it and we're talking on IRC.
Flags: needinfo?(etienne)
(Assignee)

Updated

4 years ago
Blocks: 1042105
Assignee: nobody → gmarty
Whiteboard: [systemsfe]
(Assignee)

Comment 7

4 years ago
Created attachment 8477429 [details] [review]
Github PR

Just a CSS change.
Attachment #8477429 - Flags: review?(21)
QA Wanted for branch checks.
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #8)
> QA Wanted for branch checks.

This issue is reproducible on Flame 2.1 and Open C 2.1. Icons on notification bar overlap during a call.

Device: Flame
BuildID: 20140822010750
Gaia: afcdd36f13e75adcdebe57d842a277fd587faf28
Gecko: 0b9dd32d1e16
Version: 34.0a1 (2.1 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Open_C
BuildID: 20140822010750
Gaia: afcdd36f13e75adcdebe57d842a277fd587faf28
Gecko: 0b9dd32d1e16
Version: 34.0a1 (2.1 Master)
Firmware: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

---------

This issue is NOT reproducible on Flame 2.0. Icons on notification bar stay intact during a call.

Device: Flame
BuildID: 20140822100753
Gaia: 06edd086387c2150017b549e6318a61cd7e4fd02
Gecko: d946233724d5
Version: 32.0 (2.0)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
Flags: needinfo?(jmitchell)
Keywords: qawanted → regression
comment 6.5 and comment 7 indicate the cause is already known and a fix is in the pipeline - not adding regression window at this time.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
See Also: → bug 1057501
Comment on attachment 8477429 [details] [review]
Github PR

Looks good but can you move this rule to app_titlebar.css in order to not spread the special cases too much ?
Attachment #8477429 - Flags: review?(21) → review+
(Assignee)

Comment 12

4 years ago
Landed in https://github.com/mozilla-b2g/gaia/commit/69f1d9e0d77b8adac1cf6193b59f8b6c4848abe5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Duplicate of this bug: 1059819
Duplicate of this bug: 1059003
Duplicate of this bug: 1059103
Triage: blocking for regression and correct flag.
blocking-b2g: 2.1? → 2.1+
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.1 S3 (29aug)
The issue is verified fixed on Flame 2.2 Master  KK (319mb) (Full Flash) and Flame 2.1 KK (319mb) (Full Flash)

Environmental Variables:
Device: Flame 2.2 Master  KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Environmental Variables:
Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result: While on a call, Notification Bar icons do NOT appear on screen twice
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: --- → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(ktucker)
(Assignee)

Updated

4 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.