[OMTC] [Direct3D9] Minimize, maximize, close buttons are not visible with theme

VERIFIED WONTFIX

Status

()

--
major
VERIFIED WONTFIX
4 years ago
3 years ago

People

(Reporter: jimbo90210us, Unassigned)

Tracking

({regression})

33 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8511601 [details]
Maximize.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141023194920

Steps to reproduce:

Open Firefox in maximized window. Close, maximize and minimize buttons on the top right do not show.


Actual results:

Open Firefox, maximize, close etc buttons are not visible. When hover over a link they appear but disappear when mouse off link. Buttons do show when not in full screen mode.


Expected results:

Buttons should be visible all the time.
(Reporter)

Comment 1

4 years ago
Disabled Furfox Tail Blazer (Appearance add on) and enable default theme appearance and buttons reappear as normal, re-enable Furfox Tail Blazer and the buttons disappear again.

Comment 2

4 years ago
I tried to install the teme https://addons.mozilla.org/en-US/firefox/addon/furfox-tail-blazer/ but I failed to reproduce the issue with FF33 on Win 7. I suspect it's a dupe of bug 1085690.

Could you type about:support in the location bar and paste the section "graphics".

In addition, make these 2 tests (one by one):
1) try with HWA disabled (https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration restart FF to apply)
2) try with only OMTC disabled (about:config > layers.offmainthreadcomposition.enabled=false, retsart FF to apply)
Flags: needinfo?(jimbo90210us)

Updated

4 years ago
Summary: close button → Minimize, maximize, close buttons are not visible with theme
(Reporter)

Comment 3

4 years ago
Graphics
Adapter Description	Mobile Intel(R) 965 Express Chipset Family
Adapter Drivers	        igdumd64 igd10umd64 igdumdx32 igd10umd32
Adapter RAM	        Unknown
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
Device ID	        0x2a02
Direct2D Enabled	Blocked for your graphics driver version.
DirectWrite Enabled	false (6.2.9200.16571)
Driver Date	        9-23-2009
Driver Version	        8.15.10.1930
GPU #2 Active	        false
GPU Accelerated Windows	1/1 Direct3D 9 (OMTC)
Vendor ID	        0x8086
WebGL Renderer	        Google Inc. -- ANGLE (Mobile Intel(R) 965 Express Chipset Family Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	        skia
AzureContentBackend	        cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	        0
(Reporter)

Comment 4

4 years ago
Re-enabled the theme and turned off hardware acceleration.

Buttons worked as they should and were visible in both full screen and smaller modes.

Comment 5

4 years ago
Thanks, could you test with HWA enabled and OMTC disabled. It could be an issue with OMTC but not HWA.
(Reporter)

Comment 6

4 years ago
Tested with HWA enabled and OMTC disabled and buttons work again.

Seeing wierd behaviour in login to buzilla as typing in e-mail address and password. Both changed to black background as typing went past end of box.
Flags: needinfo?(jimbo90210us)
(Reporter)

Comment 7

4 years ago
Also seeing the same behaviour with LiteFox theme by c.cheng, (just installed).

Not showing buttons when full screen but do show when in smaller window.

Mouse over link and they show again, mouse off and they disappear.

Updated

4 years ago
Duplicate of this bug: 1085690

Comment 9

4 years ago
Milan, can you or someone else investigate this? There's quite a number of users that seem to be hitting this since OMTC was turned on by default, where lightweight themes obscure the window controls. :-(
Component: Untriaged → Graphics: Layers
Flags: needinfo?(milan)
Product: Firefox → Core

Updated

4 years ago
Duplicate of this bug: 1092548

Comment 11

4 years ago
Hrannar, could type about:support in the location bar and paste the "graphics" section. Maybe only some GPU drivers are affected by this issue.
Flags: needinfo?(hrannarms)
If this is on a system from comment 3, the driver is from 2009, it should be updated before we proceed...
Flags: needinfo?(milan)

Updated

4 years ago
Duplicate of this bug: 1095448

Comment 14

4 years ago
With regard to my bug, I found that disabling addon "flash OnOff" solved the problem. In other words, I get the buttons back, but can't turn bloody flash on and off...

Updated

4 years ago
See Also: → bug 1059804

Comment 15

4 years ago
I just updated to 33.1, problem persists. If i disable the flash onoff addon, or if i take off the persona (anarchie), the problem seems to go away. But other than that, it is still there...

The problem occurs whether the window is maximised or in its normal (not maximised) state...

Running on a laptop (Windoze Vista) with a wide aspect (as the in the above link)

Comment 16

4 years ago
Hi all!

Same issues here.

This is my Essential & Graphics info:

  Esenciales de la aplicación

    Nombre: Thunderbird
    Versión: 34.0
    Agente de usuario: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Thunderbird/34.0
    Carpeta de perfil: Mostrar carpeta

              (Disco local)
    Application Build ID: 20141113050937
    Plugins habilitados: about:plugins
    Configuración de compilación: about:buildconfig
    Uso de memoria: about:memory

  Gráficos

      Descripción del adaptador: NVIDIA GeForce 7300 SE/7200 GS
      ID de fabricante: 0x10de
      ID de dispositivo: 0x01d3
      RAM del adaptador: 256
      Drivers del adaptador: nvd3dumx,nvd3dum
      Versión del driver: 9.18.13.783
      Fecha del driver: 1-31-2013
      Direct2D habilitado: false
      DirectWrite habilitado: false (6.2.9200.16571)
      Parámetros de ClearType: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 400
      Procesador WebGL: false
      Ventanas con aceleración gráfica: 1/1 Direct3D 9

      AzureCanvasBackend: skia
      AzureSkiaAccelerated: 0
      AzureFallbackCanvasBackend: cairo
      AzureContentBackend: cairo

I think that's the latest version of the driver for my old, basic graphic card.

I tried step "2" of comment 2: it works, I mean I am able to see the Minimize/Restore/Close buttons again, but Thunderbird crashes in a sudden. Already sent the report through its internal bug reporter.

Best!

Updated

4 years ago
Duplicate of this bug: 1115470

Updated

4 years ago
Flags: needinfo?(hrannarms)

Comment 18

4 years ago
I think I've found a workaround for this unsolved yet bug. :|

I have to display the menubar in Mozilla Thunderbird in order to make appear the minimize, maximize and close buttons.

Weird, but it works at least.
affected:
OMTC + Direct3D 9

not affected:
OMTC + Direct3D 11 + Direct2D 1.1
OMTC + Direct3D 11 + Direct2D
OMTC + OpengGL + Direct2D 1.1
OMTC + OpengGL + Direct2D
OMTC + HW Acc disabled
OMTC disabled + any configuration



Detailed info:
================================================

GPU Accelerated Windows - Direct3D 11 (OMTC)

windowLayerManagerRemote - true
AzureCanvasBackend - direct2d 1.1
AzureContentBackend - direct2d 1.1
AzureFallbackCanvasBackend	 - cairo
AzureSkiaAccelerated - 0

more info: minimize, maximize and close buttons are visible

================================================

GPU Accelerated Windows - Direct3D 11 (OMTC)

windowLayerManagerRemote - true
AzureCanvasBackend - direct2d
AzureContentBackend - direct2d
AzureFallbackCanvasBackend	 - cairo
AzureSkiaAccelerated - 0

gfx.direct2d.use1_1 = false

more info: minimize, maximize and close buttons are visible

================================================

GPU Accelerated Windows - Direct3D 9 (OMTC)

windowLayerManagerRemote - true
AzureCanvasBackend - skia
AzureContentBackend - cairo
AzureFallbackCanvasBackend	 - cairo
AzureSkiaAccelerated - 1

layers.prefer-d3d9 = true

more info: minimize, maximize and close buttons aren't visible

================================================

GPU Accelerated Windows - OpenGL (OMTC)

windowLayerManagerRemote - true
AzureCanvasBackend - direct2d 1.1
AzureContentBackend - direct2d 1.1
AzureFallbackCanvasBackend - cairo
AzureSkiaAccelerated - 0

layers.prefer-opengl = true

more info: minimize, maximize and close buttons are visible

================================================

GPU Accelerated Windows - OpenGL (OMTC)

windowLayerManagerRemote - true
AzureCanvasBackend - direct2d
AzureContentBackend - direct2d
AzureFallbackCanvasBackend - cairo
AzureSkiaAccelerated - 0

gfx.direct2d.use1_1 = false
layers.prefer-opengl = true

more info: minimize, maximize and close buttons are visible

================================================

GPU Accelerated Windows - Basic (OMTC)
windowLayerManagerRemote - true
AzureCanvasBackend - skia
AzureContentBackend - cairo
AzureFallbackCanvasBackend	 - cairo
AzureSkiaAccelerated - 0

gfx.direct2d.disabled = true
layers.acceleration.disabled = true

more info: minimize, maximize and close buttons are visible

================================================

GPU Accelerated Windows - Basic 
windowLayerManagerRemote - false
AzureCanvasBackend - direct2d 1.1
AzureContentBackend - direct2d 1.1
AzureFallbackCanvasBackend - cairo
AzureSkiaAccelerated - 0

layers.offmainthreadcomposition.enabled = false

more info: minimize, maximize and close buttons are visible

================================================

GPU Accelerated Windows - Basic 
windowLayerManagerRemote - false
AzureCanvasBackend - direct2d
AzureContentBackend - direct2d
AzureFallbackCanvasBackend - cairo
AzureSkiaAccelerated - 0

layers.offmainthreadcomposition.enabled = false
gfx.direct2d.use1_1 = false

more info: minimize, maximize and close buttons are visible

================================================

GPU Accelerated Windows - Basic 
windowLayerManagerRemote - false
AzureCanvasBackend - skia
AzureContentBackend - cairo
AzureFallbackCanvasBackend - cairo
AzureSkiaAccelerated - 0

layers.offmainthreadcomposition.enabled = false
layers.prefer-d3d9 = true

more info: minimize, maximize and close buttons are visible

================================================

layers.offmainthreadcomposition.enabled = false
layers.prefer-opengl = true - is not respected and fall off to Direct2D 1.1

================================================

layers.offmainthreadcomposition.enabled = false
gfx.direct2d.use1_1 = false
layers.prefer-opengl = true - is not respected and fall off to Direct2D

================================================

GPU Accelerated Windows - Basic
windowLayerManagerRemote - false
AzureCanvasBackend - skia
AzureContentBackend - cairo
AzureFallbackCanvasBackend - cairo
AzureSkiaAccelerated - 0

gfx.direct2d.disabled = true
layers.acceleration.disabled = true
layers.offmainthreadcomposition.enabled = false

more info: minimize, maximize and close buttons are visible
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: Minimize, maximize, close buttons are not visible with theme → [OMTC] [Direct3D9] Minimize, maximize, close buttons are not visible with theme
@ Bas Schouten (:bas.schouten) - Is this issue also WONTFIX per bug #1059804 Comment #16 ?
Flags: needinfo?(bas)
(In reply to Virtual_ManPL [:Virtual] from comment #21)
> @ Bas Schouten (:bas.schouten) - Is this issue also WONTFIX per bug #1059804
> Comment #16 ?

Meh, at the very least it's not a serious concern, prefer-d3d9 is a diagnostic only pref. The D3D9 compositor situation, as mentioned in the comment that you're referring to, should in practice never get hit on Windows 7+.
Flags: needinfo?(bas)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1125097
You need to log in before you can comment on or make changes to this bug.