Thunderbird crashing on start in HTMLInputElement.cpp:193

RESOLVED FIXED in Thunderbird 36.0

Status

Thunderbird
Build Config
--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Frederic Bezies, Assigned: jcranmer)

Tracking

({crash, regression})

Trunk
Thunderbird 36.0
x86_64
Linux
crash, regression
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird36 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

3 years ago
Got a crash on every single start since I upgraded my thunderbird "nightly" today :

Last working build :

20141030030207
https://hg.mozilla.org/mozilla-central/rev/80e18ff7c7b2
https://hg.mozilla.org/comm-central/rev/273bcc4d6e9b

First busted build :

20141031030201
https://hg.mozilla.org/mozilla-central/rev/e0b505a37b1c
https://hg.mozilla.org/comm-central/rev/5df0a26967c8

Thunderbird simply crashes on start, core dumping without any bug report tool launched.

There is only 3 patches on comm-central for bugs 1085151, 1091884, 1070984.

Could it be a mozilla-central patch which make thunderbird crash on start ?
(Reporter)

Updated

3 years ago
Severity: normal → blocker

Comment 1

3 years ago
Did you submit a crash report?
see https://support.mozilla.org/en-US/kb/mozilla-crash-reporter#w_viewing-crash-reports
Severity: blocker → critical
Keywords: crash
(Reporter)

Comment 2

3 years ago
I cannot get a crash report : even thunderbird crashes before I can attach it to gdb. Isn't that annoying ?
(Reporter)

Comment 3

3 years ago
Well, here is what I get :

(gdb) run
Starting program: /home/fred/thunderbird/thunderbird 
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0x0000000000000000 in ?? ()
(gdb) bt
#0  0x0000000000000000 in ?? ()
#1  0x00007ffff1326710 in ?? () from /home/fred/thunderbird/libxul.so
#2  0x00007ffff291c616 in ?? () from /home/fred/thunderbird/libxul.so
#3  0x0000000000000000 in ?? ()

Using this debug build :

20141030222854
https://hg.mozilla.org/mozilla-central/rev/e0b505a37b1c
https://hg.mozilla.org/comm-central/rev/5df0a26967c8

Not really useful, but as I can see, a really quick crash. Should I have to build a debug build in order to get something more useful ?
(Reporter)

Comment 4

3 years ago
Here is a more complete log :

(gdb) bt
#0  0x0000000000000000 in ?? ()
#1  0x00007ffff019f956 in __static_initialization_and_destruction_0 (
    __initialize_p=1, __priority=65535)
    at /home/fred/logs/mail/src/mozilla/dom/html/HTMLInputElement.cpp:193
#2  _GLOBAL__sub_I_Unified_cpp_dom_html1.cpp(void) ()
    at /home/fred/logs/mail/src/mozilla/dom/html/HTMLMenuItemElement.cpp:494
#3  0x00007ffff7dea21a in call_init.part () from /lib64/ld-linux-x86-64.so.2
#4  0x00007ffff7dea32b in _dl_init_internal () from /lib64/ld-linux-x86-64.so.2
#5  0x00007ffff7dee7b7 in dl_open_worker () from /lib64/ld-linux-x86-64.so.2
#6  0x00007ffff7dea0c4 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#7  0x00007ffff7dede63 in _dl_open () from /lib64/ld-linux-x86-64.so.2
#8  0x00007ffff79bc03b in ?? () from /usr/lib/libdl.so.2
#9  0x00007ffff7dea0c4 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#10 0x00007ffff79bc619 in ?? () from /usr/lib/libdl.so.2
#11 0x00007ffff79bc0e1 in dlopen () from /usr/lib/libdl.so.2
#12 0x00000000004022ff in GetLibHandle (
    aDependentLib=0x7fffffffb5d0 "/home/fred/logs/mail/objdir-tb/dist/bin/libxul.so")
    at /home/fred/logs/mail/src/mozilla/xpcom/glue/standalone/nsXPCOMGlue.cpp:227
#13 ReadDependentCB (aDoPreload=<optimized out>, 
    aDependentLib=0x7fffffffb5d0 "/home/fred/logs/mail/objdir-tb/dist/bin/libxul.so")
    at /home/fred/logs/mail/src/mozilla/xpcom/glue/standalone/nsXPCOMGlue.cpp:276
#14 XPCOMGlueLoad (aXPCOMFile=<optimized out>)
    at /home/fred/logs/mail/src/mozilla/xpcom/glue/standalone/nsXPCOMGlue.cpp:456
#15 0x0000000000402454 in XPCOMGlueStartup (aXPCOMFile=<optimized out>)
    at /home/fred/logs/mail/src/mozilla/xpcom/glue/standalone/nsXPCOMGlue.cpp:521
#16 0x00000000004012ba in InitXPCOMGlue (argv0=<optimized out>, 
    xreDirectory=xreDirectory@entry=0x7fffffffe678)
    at /home/fred/logs/mail/src/mail/app/nsMailApp.cpp:286
#17 0x0000000000400ef6 in main (argc=1, argv=0x7fffffffe8a8)
    at /home/fred/logs/mail/src/mail/app/nsMailApp.cpp:351
(Reporter)

Updated

3 years ago
Summary: Thunderbird crashing on start since 31st october 2014 nightly. → Thunderbird crashing in nsXPCOMGlue.cpp while starting.
(Reporter)

Updated

3 years ago
Summary: Thunderbird crashing in nsXPCOMGlue.cpp while starting. → Thunderbird crashing on start since 31st october 2014 nightly.
(Reporter)

Updated

3 years ago
Summary: Thunderbird crashing on start since 31st october 2014 nightly. → Thunderbird crashing on start in HTMLInputElement.cpp:193
(Reporter)

Updated

3 years ago
Component: General → DOM: Core & HTML
Product: Thunderbird → Core
(Reporter)

Comment 5

3 years ago
Modified component after a small search on HTMLInputElement on bugzilla.
Bisecting the m-c/inbound bits here would probably be useful.
(Reporter)

Comment 7

3 years ago
(In reply to Boris Zbarsky [:bz] from comment #6)
> Bisecting the m-c/inbound bits here would probably be useful.

Of course. Will do this asap and report last working build and first broken one.
(Reporter)

Comment 8

3 years ago
(In reply to Boris Zbarsky [:bz] from comment #6)
> Bisecting the m-c/inbound bits here would probably be useful.

Where are inbound build for mozilla thunderbird ? As it is only crashing Thunderbird, firefox is working well !

Comment 9

3 years ago
My SM_Trunk build on Linux x86_64 crashes immediately after the start. Only message given in a terminal is Segmentation fault

Comment 10

3 years ago
I was suspicious about http://hg.mozilla.org/mozilla-central/rev/55d15b285436. Backout failed for
patching file media/gmp-clearkey/0.1/Makefile.in
Hunk #1 FAILED at 4.
so i rrecklessly emoved the part for media/gmp-clearkey from the backout. For testing only. *g* Now the backout succeeded and the crash was gone. I am writing this comment with the new build.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
> Where are inbound build for mozilla thunderbird ? 

I assume you'd have to make your own....

Mike, given comment 10, could you take a look please?
Flags: needinfo?(mh+mozilla)
(Assignee)

Comment 16

3 years ago
(In reply to Boris Zbarsky [:bz] from comment #6)
> Bisecting the m-c/inbound bits here would probably be useful.

I ran a lengthy manual bisection myself. Bug 1077148 is directly implicated, more specifically, part 4 (http://hg.mozilla.org/mozilla-central/55d15b285436).
(Assignee)

Updated

3 years ago
Depends on: 1077148
Created attachment 8515435 [details] [diff] [review]
bug1091077.patch

This enables to boot Thunderbird again on linux.
I am not 100% sure there is no other place needs to be fixed.
Is that the right patch?
Created attachment 8515436 [details] [diff] [review]
bug109220.diff

That was wrong.
Attachment #8515435 - Attachment is obsolete: true
cf. https://lists.mozilla.org/pipermail/dev-platform/2014-October/007413.html
Flags: needinfo?(mh+mozilla)
Comment on attachment 8515436 [details] [diff] [review]
bug109220.diff

Review of attachment 8515436 [details] [diff] [review]:
-----------------------------------------------------------------

::: mailnews/mapi/mapiDll/moz.build
@@ +7,1 @@
>  

This is unnecessary change.
(Assignee)

Comment 22

3 years ago
Created attachment 8515541 [details] [diff] [review]
Port bug 1077148

I'm not sure I'm handling the MAPI DLL generation properly.
Assignee: nobody → Pidgeot18
Attachment #8515436 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8515541 - Flags: review?(mh+mozilla)
Component: DOM: Core & HTML → Build Config
Product: Core → Thunderbird
Comment on attachment 8515541 [details] [diff] [review]
Port bug 1077148

Review of attachment 8515541 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8515541 - Flags: review?(mh+mozilla) → review+

Comment 24

3 years ago
(In reply to Joshua Cranmer [:jcranmer] from comment #22)
> Created attachment 8515541 [details] [diff] [review]
> Port bug 1077148

Works for my SM Linux x86_64.

> I'm not sure I'm handling the MAPI DLL generation properly.

Dont't know about that.
Comment on attachment 8515541 [details] [diff] [review]
Port bug 1077148

Review of attachment 8515541 [details] [diff] [review]:
-----------------------------------------------------------------

::: mailnews/mapi/mapiDll/moz.build
@@ +4,5 @@
>  # file, You can obtain one at http://mozilla.org/MPL/2.0/.
>  
> +# Statically link against the CRT, so that we don't go hunting around for it
> +# and not find it when we're loaded into explorer.exe or similar
> +GeckoSharedLibrary('mozMapi32', msvcrt='static')

Actually, you want linkage=None, too.
Blocks: 1092815
(Assignee)

Comment 26

3 years ago
https://hg.mozilla.org/comm-central/rev/84b1d9656728
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0
See Also: → bug 1092553

Updated

3 years ago
Depends on: 1096086
status-thunderbird36: --- → fixed

Updated

3 years ago
Keywords: regression
You need to log in before you can comment on or make changes to this bug.