content doesn't paint in win7 vm with e10s

RESOLVED DUPLICATE of bug 1147728

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1147728
4 years ago
3 years ago

People

(Reporter: rillian, Assigned: gw280)

Tracking

(Blocks: 1 bug)

38 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm6+)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

Created attachment 8556179 [details]
Screenshot comparing e10s and non-e10s windows

Running today's nightly on windows 7 x84 in a libvirt vm on Linux, I get no content painted in e10s windows.
Can you dump your about:support?
Flags: needinfo?(giles)
This sounds very similar to the problem I have where content often doesn't paint when accessing Firefox over RDP (See bug 1096834 comment 15)
(Reporter)

Comment 3

4 years ago
Host is Fedora Linux 21 x86_64. About support:

Application Basics
------------------

Name: Firefox
Version: 38.0a1
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Multiprocess Windows: 1/1

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Graphics
--------

Adapter Description: Standard VGA Graphics Adapter
Adapter Drivers: vga framebuf vga256 vga64k
Adapter RAM: Unknown
Device ID: 0x0100
Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues.
DirectWrite Enabled: false (6.2.9200.16571)
Driver Date: 6-21-2006
Driver Version: 6.1.7600.16385
GPU #2 Active: false
GPU Accelerated Windows: 0/1 Basic (OMTC) Blocked for your graphics card because of unresolved driver issues.
Subsys ID: 11001af4
Vendor ID: 0x1b36
WebGL Renderer: Blocked for your graphics card because of unresolved driver issues.
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 235520
browser.cache.disk.smart_size_cached_value: 245760
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20150129030202
browser.startup.homepage_override.buildID: 20150129030202
browser.startup.homepage_override.mstone: 38.0a1
dom.mozApps.used: true
extensions.lastAppVersion: 38.0a1
media.gmp-gmpopenh264.lastUpdate: 1422490113
media.gmp-gmpopenh264.version: 1.3
media.gmp-manager.lastCheck: 1422490112
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1422490719
places.history.expiration.transient_current_max_pages: 16840
plugin.disable_full_page_plugin_for_types: application/pdf
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1422490719

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.8
Version in use: 4.10.8

NSS
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSSMIME
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSSSL
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSUTIL
Expected minimum version: 3.17.4
Version in use: 3.17.4

Experimental Features
---------------------
Flags: needinfo?(giles)
OS: Linux → Windows 7
Version: 36 Branch → 38 Branch
(Assignee)

Updated

4 years ago
Flags: needinfo?(gwright)
Whiteboard: [gfx-noted]
possibly related to bug 1135247
Flags: needinfo?(gwright)
Assignee: nobody → gwright
tracking-e10s: --- → m6+
It would be great if it turns out to be related to bug 1135247, because fixing that allows for more people to test on virtual Win7 machines.
There are at least three bugs I've seen with this exact rendering issue with all of them being on win 7 VMs. I suspect they're all related, based on the similarities between the about:supports for gfx stuff.

Updated

3 years ago
Blocks: 1111396
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1147728

Updated

3 years ago
Blocks: 993639

Updated

3 years ago
No longer blocks: 1111396
You need to log in before you can comment on or make changes to this bug.