Add MOZ_SAFE_BROWSING to confvars.sh and minor updates

RESOLVED FIXED in seamonkey2.36

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: philip.chee, Assigned: philip.chee)

Tracking

Trunk
seamonkey2.36
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.35 fixed, seamonkey2.36 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

4 years ago
(In Bug 653605 comment #5)
> We now build SeaMonkey with safe-browsing unconditionally. => WONTFIX.
I was wrong. We do need to add MOZ_SAFE_BROWSING=1 because stuff in toolkit and gecko test for this.
Assignee

Updated

4 years ago
Duplicate of this bug: 653605
Assignee

Comment 2

4 years ago
While testing my patch for Bug 1124503 discovered MOZ_SAFE_BROWSING wasn't defined.
> +MOZ_SAFE_BROWSING=1
MOZ_SAFE_BROWSING has been in browser/confvars.sh since creation
Note: MOZ_SAFE_BROWSING implicitly turns on MOZ_URL_CLASSIFIER
We explicitly define MOZ_URL_CLASSIFIER=1 in our confvars.sh unlike all other toolkit applications.

> +MOZ_SERVICES_CLOUDSYNC=1
Bug 1052009 - Enable CloudSync in Nightly.

> -JSGC_GENERATIONAL=1
Bug 1107349 - Always build in generational GC support
Attachment #8567985 - Flags: review?(iann_bugzilla)

Updated

4 years ago
Attachment #8567985 - Flags: review?(iann_bugzilla) → review+
Assignee

Comment 3

4 years ago
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/a7bc583a6720
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.36
Assignee

Updated

4 years ago
Assignee

Updated

4 years ago
Flags: needinfo?(iann_bugzilla)

Comment 4

4 years ago
Comment on attachment 8567985 [details] [diff] [review]
Patch V1 add MOZ_SAFE_BROWSING etc

[Triage Comment]
a=me for 2.35
Flags: needinfo?(iann_bugzilla)
Attachment #8567985 - Flags: approval-comm-release+
You need to log in before you can comment on or make changes to this bug.