We need more than 10 votes in browser product

VERIFIED FIXED

Status

()

bugzilla.mozilla.org
Administration
--
enhancement
VERIFIED FIXED
16 years ago
7 years ago

People

(Reporter: Brian 'netdragon' Bober, Assigned: asa)

Tracking

Details

(Reporter)

Description

16 years ago
Remember bug 64237? We are getting to the point now where 10 is too few. I have
way over 10 bugs I consider equally important. How about raising this number to 25?

Some stats:

Number of unfixed bugs (UNCOMFIRMED, NEW, ASSIGNED, REOPENED): 21039
Number of unfixed bugs with at least 1 vote:  3463
Number of unfixed bugs with at least 5 votes: 687
Number of unfixed bugs with at least 15 votes: 152
Number of unfixed bugs with at least 30 votes: 55
Number of unfixed bugs with at least 30 votes: 20

So out of this whole community, there is only 55 bugs that deservers 30 or more
votes? Most of the votes are solitary votes in bugs because people just don't
have enough votes to go around. Also, notice how few of the unfixed bugs are
votes for - less than 20%. 3% Have at least 5 votes.

more than 17000 open bugs have 0 votes!
->moz.org specific not browser

Confirming RFE.
Assignee: asa → endico
Status: UNCONFIRMED → NEW
Component: Browser-General → Bugzilla: Other moz.org Issues
Ever confirmed: true
Product: Browser → mozilla.org
QA Contact: doronr → myk

Comment 2

16 years ago
since Asa would probably be the one to make the decision, i'm moving this ...
Assignee: endico → asa
Component: Bugzilla: Other moz.org Issues → Bugzilla: Keyword & Component Changes
QA Contact: myk → timeless
(Assignee)

Comment 3

16 years ago
>Most of the votes are solitary votes in bugs because people just don't
have enough votes to go around.

No. Most (all) of the votes are solitary because you're only allowed to put one
vote on a bug.

There are 16,000 bugzilla accounts that have filed a bug. Each of those accounts
has 10 browser and 10 mailnews votes available. That's slightly more than
300,000 potential votes. Only a tiny fraction of those are being used so to
suggest that people have all run out of votes is silly. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 4

16 years ago
rs verify
Status: RESOLVED → VERIFIED
*** Bug 127329 has been marked as a duplicate of this bug. ***
*** Bug 133380 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
*** Bug 176598 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
i agree that this bug should be taken off the wontfix list, because mozilla has
grown so much bigger and has so many different rfe/bugs that 10 is now as
limiting as 5 was previously.

just to point this out, the original bug (for more than 5) was opened on
2001-01-03.  this bug (for more than 10) was opened on 2001-12-11.  now it's
2003-08-20, over 2.5 years after the original bug and 1.5 since this bug was
submitted.  it's chronologically time to double the votes again, imho.  :)
(Reporter)

Comment 9

15 years ago
Hi CJ :-)

That's why I created the bug. I knew eventually it would be reopened, so I
wasn't concerned about it being WONTFIXed at that time.

I think that 20-30 would be a good number.
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---

Comment 10

15 years ago
well, speaking of votes, now that this bug has been reopened, shouldn't we be
allowed to vote for it?  i see no voting link.
(Reporter)

Comment 11

15 years ago
That's cause it wasn't accepted yet :-)

Comment 12

15 years ago
Asa said this is WONTFIX.  Why did you reopen it?  
(Reporter)

Comment 13

15 years ago
That was 2 years ago, almost.

Comment 14

14 years ago
So we have to vote in comments.

I give this rfe my 11th vote.

But make this rfe component independent. I need more votes in Mail than in 
Browser. So may others...

Comment 15

14 years ago
Agreed - it's MailNews where my votes are always all used up too.

Re: comment 10

We really need bug 74507 fixed, so that we can vote for both that and this.

Comment 16

14 years ago
in case it isn't obvious, votes are per product.

what we don't have is a way to vote against bugs.
i'd probably vote against this one.

Comment 17

14 years ago
Comment 16: Don't worry, we know that.

There could be even another way around this problem. The semantics of voting
could be changed from "I vote for this bug, because it is one of 10 highest
priority bugs to me" to "I have also seen this bug and it is worth my time
marking it in bugzilla". Then the number of allowed "votes" wouldn't be restricted.

Currently, we find a bug with 10 votes. What does it mean? 10 people find this
bug very important for them - more important than other bugs. Ok. Now, are these
10 people real powerusers who have found some serious problem hidden in the most
advanced but hidden corner of mozilla functionality? But noone else uses this
stuff. Or, do 100000 people around the world see this bug every day, but it
isn't that important to use 1 precious vote out of 10 for it. Which case would
be more important to the fixers? This is what the reported meant. 17000 bugs
with no votes. Because nobody felt those bugs are THAT important. But they exist
if they weren't INVALIDated.

I don't know if this would change the number of votes dramatically, thus ruining
the purpose of them. But from my experience, I have seen about 20 bugs in
Mozilla myself (some of them already reported), which I would like see fixed. 
Browsing bugzilla, I found some more RFEs I liked. But I have only 10 votes (per
component). I voted just for the most important bugs. Now the problem -
subjective opinion of various people: If other people voted the same bug, fine,
it may get many votes and get fixed. If they voted other bugs, the votes per bug
get very sparse. The bugs I couldn't vote for may never ever get any votes,
because everybody acted like me - that bugs aren't the top priority. But
everybody may encounter them when using Mozilla. Anyway, I would personally give
only about 50 votes instead of 10. I don't know how other people behave, or how
much time they have for looking through bugzilla and voting for almost any bug.

Comment 3: You got the point. There are still many votes left. But they are
allocated to people who don't care voting here. The people who see real bugs and
could put some weight on emphasizing them are already out of votes.

Just my opinion.

Comment 18

14 years ago
voting for the browser (mozilla) component allows only 10 votes.
firefox allows 100 votes, it would be good if the browser allowed for at least
50 bugs.

Comment 19

14 years ago
As I see it, the real reason for the existence of the voting system is to allow
users to say "me too" without adding useless comments. Upping the number of
votes (perhaps even to unlimited) will help keep bug discussions technical.

BTW, 

Comment 20

14 years ago
If we made them unlimited, people could just vote for everything, which would
severely dilute their value.

Comment 21

14 years ago
I find it highly unlikely that anyone would vote for "everything". What would
their motive be? This would just cancel the effectiveness of either of their
votes, not to mention the pain of going through such mass voting sessions.

Furthermore, I bet that only a very small minority of b.m.o users is even CCed
to more than 1000 bugs out of the 260,000 that we have in the database at this
stage. Out of the 773 bugs I'm personally CCed to, I might have bothered to vote
for half of them.

By voting to a lot of bugs, users don't break the authenticity of the votes,
they actually do the opposite - they help this system provide much more accurate
results. Currently, the low limit prevents users from voting to many bugs they
deem important, this won't happen with unlimited amount of votes (or 500 per
product, to be on the safe side).

Prog.

Comment 22

14 years ago
*** Bug 258458 has been marked as a duplicate of this bug. ***

Comment 23

13 years ago
First of all, let me say that I think it's ironic that I can't vote for this bug.

Because I can't vote for it, I'll add my two cents here.  A limit of 10 votes is
just too small.  Mozilla has grown so large and has so many bugs, you can
consider it to be a kind of inflation, and therefore the vote limit needs to
keep up with inflation.  Instead of hard-coding the number, how about just
saying the limit is 0.1% of the total number of bugs?

Comment 24

13 years ago
i agree with previous post. 0.001 (0.1%) is a good figure.
make the count for number of allowed votes be based on bugs marked as ASSIGNED,
NEW, REOPENED, UNCONFIRMED.
(Reporter)

Comment 25

13 years ago
Or any custom states such as NEEDINFO, that might also refer to an open bug.
Sounds like an excellent idea.

Comment 26

13 years ago
Imho bugs.kde.org has the most functional voting system of any OSS project. 
 
You get a certain number of votes and can apportion them among bugs however you 
see fit, like the Condorcet method.  There are also limits to the number of 
votes you can assign to a particular bug and to a particular subproject. 
 
Personally, I like to be able to put a smaller priority vote on a bug that I 
just want to keep an eye on, but perhaps can't reproduce reliably or don't 
really care about. 
(Reporter)

Comment 27

13 years ago
What about weighted votes with the lowest weight votes having no limitations?
Example:

Weight   |   Allowed votes
--------------------------
  5      |        1
  4      |        2
  3      |        4
  2      |        8
  1      |        16
  .5    |      No limit

Therefore, people could make all the .5 votes they want, but it'd take 2 of them
in a bug to equal one normal vote.

Comment 28

13 years ago
Browser's been replaced (as I understand it) with Core, and my Core allowed
voted are currently standing at 12 used out of 10000. Temporary glitch?

Comment 29

13 years ago
New product "Mozilla Application Suite" has 10000 votes too.

Comment 30

13 years ago
Most of my Browser votes have moved into Core, and most of my MailNews votes
have moved into Mozilla Application Suite.

But whatever happens to different people's distribution of votes, or even if
bugs are still in the process of being moved between products, it seems that
this would make having more than 10 votes even more essential.
(Assignee)

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → VERIFIED
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.