Closed Bug 115088 Opened 19 years ago Closed 19 years ago

Saving "Web Page, HTML only" or "Text File" still creates directory for images & stuff

Categories

(Core Graveyard :: File Handling, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 116418

People

(Reporter: bzbarsky, Assigned: bugs)

References

Details

(Keywords: platform-parity)

BUILD: 2001-12-13-08

STEPS TO REPRODUCE:

1) Hit Ctrl-s
2) Select "Web Page, HTML Only" from the dropdown
3) Click OK

EXPECTED RESULTS:

HTML is saved to the file name in the textbox (foo.html)

ACTUAL RESULTS:

HTML is saved to foo.html and a directory called foo_files is created.  The
directory is empty.
would this be the same as bug 115132?
Keywords: pp
Summary: Saving "Web Page, HTML only" still creates directory for images & stuff → Saving "Web Page, HTML only" or "Text File" still creates directory for images & stuff
also see this happening when i save using the "Text File" option.
Adam's comment from bug 115132:

If you want to save HTML only, you should pass a nsnull data path into
nsIWebBrowserPersist::SaveDocument. Otherwise it creates that directory to save
any files that may be linked to the document.

Blocks: 115634
If you choose "HTML only" I'd expect that it mozilla would leave the source the
way it is. But at the moment, all image links get changed to local files (which
don't get downloaded) too. That's a bit annoying if you're just fixing a typo in
your webpage via saving it with mozilla, correcting it and loading it up again.
This is the JS source code for the saving HTML:

http://lxr.mozilla.org/seamonkey/source/xpfe/components/ucth/resources/helperAppDldProgress.js#403
I have a couple of points to make:

1. Pass null instead of filesFolder if you don't want the document "fixed up".
2. There is no need for the code to create this folder - webbrowserpersist will
create it for you. Currently webbrowserpersist always creates it, but it could
be changed to be on demand at some later stage.

On build 2001122108 bug 115132 does not show up anymore, but when I save HTML
only the directory gets created and populated with images.  There is no
difference between "Web page, complete" and "Web page, HTML only".
Worksforme on Windows 98, Mozilla 0.9.7 milestone build.
Depends on: 116418
ack, no longer have the "text file" option --see bug 117491.

anyhow, marking a dup of bug 116418, per bz's comments over there.

*** This bug has been marked as a duplicate of 116418 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
No longer depends on: 116418
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.