Closed Bug 116055 Opened 18 years ago Closed 8 years ago

Arrow icon in URLbar is placed to the left after a theme switch.

Categories

(Core Graveyard :: Skinability, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Future

People

(Reporter: andre.bugs2, Unassigned)

References

Details

Attachments

(2 files)

[Build-ID: 2001-12-19-18]

The arrow icon that you click on to pull down the url history is placed to the
very right of the URLbar if you first name the history dropdown appear once, and
then switch themes. This was probably introduced after the dynamic
theme-switching was re-enabled.

Steps to reproduce:

1) Get a build with dynamic theme-switching enabled.
2) Get the url history dropdown to appear by entering for an example 'www' into
the URLbar.
3) Discard the dropdown by clicking on the browser window.
4) Switch theme with View->Apply Theme

Result: The arrow icon that is normally placed to the right in the URLbar is now
on the left.

I will attach a screenshot that shows how it looks.
By the way, after it has been displaced like this the url dropdown will drop
down from there if you click on it.
Uhh, in my first comment I of course ment "...to the very left". Otherwise it
wouldn't have been a bug:-)
ah yes, this used to happen with me too, quite a few months ago.

When i used to change window size (not theme switching) very often while testing
sites. But I haven't seen this problem for quite sometime now.
Hyatt, you know you want it.
Assignee: hewitt → hyatt
*** Bug 117221 has been marked as a duplicate of this bug. ***
This seems to be a generic problem with the url bar (not with theming).  See bug 
117692.
I think this is a generic problem with XBL bindings, for some the children
insertion points seem to get lost or something.
If you wrap all insertion points in their own boxes you never see the problem.
*** Bug 118001 has been marked as a duplicate of this bug. ***
Confirmed, Linux build 2002010708.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Component: Themes → Skinability
In some cases the Dropdown-Button in the URLbar was moving to the very left
after closing the Print Preview. 

I have tried to reproduce the crash from Bug 270286 with the newest Trunk
Nightly-Build (does not crash) but after closing the Print Preview from
http://www.hrcalifornia.com/cid.cfm?cid=exemptcomparison_chart&skipsearch=1&print=yes

the Dropdown-Arrow has moved left. Have noticed the same behaviour after closing
the Print Preview from about:plugins some time. Add Screenshot. 

Using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20041116
Mnenhy/0.6.1.10020

Add this here before file an Duplicate, please correct me if i am wrong and this
one is new. 
The checkin for Bug 268780 has fixed this for me using Seamonkey Tnderbox-Build
2004111718. 
Product: Core → Core Graveyard
Assignee: hyatt → nobody
QA Contact: pmac → skinability
This is a mass change. Every comment has "assigned-to-new" in it.

I didn't look through the bugs, so I'm sorry if I change a bug which shouldn't be changed. But I guess these bugs are just bugs that were once assigned and people forgot to change the Status back when unassigning.
Status: ASSIGNED → NEW
> The checkin for Bug 268780 has fixed this for me using Seamonkey Tnderbox-Build
> 2004111718.
Closing
Status: NEW → RESOLVED
Closed: 8 years ago
Depends on: 268780
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.