Closed Bug 1168847 (gecko-carets) Opened 5 years ago Closed 4 years ago

[meta] Enable gecko text selection carets by default

Categories

(Firefox for Android :: Text Selection, defect)

35 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Margaret, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

Let's use this bug to track the dependencies we need to fix in order to get the gecko text selection carets riding the trains.

Once we think enough of these issues are fixed, we can first enable them by default on Nightly only, in order to get more bug reports.
^ I'd like to see if it's possible for us to use our own visuals rather than FFOS here
Alias: gecko-carets
Depends on: 1168891
Depends on: 1188529
Depends on: GeckoCaret2
We should triage this bug to figure out what's required to ship this.

Previously we said that we wanted to wait for APZ to land before we would move forward with this, but that change is imminent. What are our next steps?
Flags: needinfo?(snorp)
Flags: needinfo?(markcapella)
I've been observing feedback / worst case bugs filed by early adopters of original bug 988143, and roughing a plan for TextSelection component in general [0]. Briefly, we can go-live in nightly anytime with what we have.

In general:
   I'm poking at bug 1215959 - Switch from GeckoCaret -> AccessibleCaret and expect to finish (code, test, review, etc) by published 12/4 date. This may impact TouchCaret/SelectionCaret visibility from the current experimental version, (trying to solve for Bug 1166807 while we're here).

   We may delay flipping the pref in m-c until this piece gets completed. Handles/Caret visibility may be affected.

Unassigned and possible show-stopper:
   Bug 1168891 - New Gecko selection carets cannot reverse their positions

Unassigned enhancements for parallel track:
   Bug 1171110 - Floating text selection action bar for Android M
   Bug 1097398 - Match Android L text selection handles

Valid bug needs attention:
   Bug 1199967 - Text selection in subdocuments may be broken, valid bug

Related, but probably irrelevant:
   Bug 1213644 - Failure of TextSelection using the new GeckoCarets ...
                 (verify mitigated by bug 1211443).
   Bug 1166807 - Text carets overlay screen and don't stay with selection when scrolling
                 (verify mitigated by bug 1215959).


Broken down, I don't think this presents much work. I've currently assuming bug 1215959 for myself, but that piece and the 12/4 completion are the only planned hard-deliverables.

If you see a different prioritization, or want to pass-off any/all bits to move things along, I'm happy to share whatever I have that's useful.


[0] https://www.dropbox.com/s/2qq7fqw1be73qfo/TextSelection.ods?dl=0
Flags: needinfo?(markcapella)
Assignee: nobody → markcapella
Attached patch bug1168847.diff (obsolete) — Splinter Review
Final patch before allowing on escape m-c to m-a and the world should be pretty much this.
Depends on: 1199967
We're working on doing this after APZ lands with bug 1215959 (using the newer caret impl)
Flags: needinfo?(snorp)
Depends on: 1235510
Depends on: 1235513
Duplicate of this bug: 1226202
Assignee: markcapella → nobody
Depends on: 1246918
Depends on: 1255555
No longer depends on: 1255555
Depends on: 1257364
Updating more current path from local queue
Attachment #8687625 - Attachment is obsolete: true
@snorp: Does this go hand in hand with APZ? And are we still targeting 48? The floating text selection (bug 1171110) depends on this and I'm keeping it behind a Nightly flag for now.
Flags: needinfo?(snorp)
No longer depends on: 1199967
No longer depends on: 1235513
No longer depends on: 1249201
No longer depends on: 1257364
I'm closing this meta bug out in favor of bug 1230609, which is tracking the other half of this outstanding work.

Sebsatian, I'll move your NI over there.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(snorp)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.