Closed Bug 1199967 Opened 4 years ago Closed 3 days ago

Dual Selections / AccessibleCaret pairs visible in same document

Categories

(Firefox for Android :: Text Selection, defect)

42 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1306634
Tracking Status
firefox40 --- affected
firefox41 --- affected
firefox42 --- affected
firefox43 --- affected

People

(Reporter: kats, Unassigned)

References

(Blocks 2 open bugs)

Details

STR:
1. Go to e.g. https://bugzilla.mozilla.org/attachment.cgi?id=8654270&action=edit
2. Long press inside the frame containing the patch

Expected:
Text under the long press is highlighted and the selection carets appear

Actual:
Text in the root document near the top of the page is highlighted, sometimes in black, and no selection carets appear.
Affects all current channels too so it's been like this for a while.
iir there's an issue in SelectionHandler._getHandlePositions() in that case (original selection carets)... that never got enough attention (Bug 837615 - Wrong position of text selection handle inside iframe).

This is better using the new Gecko-based carets and your STR, but it's broken different. Not sure I've seen a bug for this yet, so I'm thinking we can morph this, and WONTFIX bug 837615 later.

experimental Gecko carets issue: 
https://www.dropbox.com/s/pejjakqnu9g93uk/bug1199967.png?dl=0

Also, tracking this during Gecko II/Accessible carets updates, bug 1215959
Confirming this is an issue still with AccessibleCarets, and blocking on release to the trains: 

Bug 1168847 - (gecko-carets) [meta] Enable gecko text selection carets by default
Blocks: gecko-carets
Updating the bug description and cc: TYLin as an fyi.
Summary: Text selection in subdocuments may be broken → Dual Selections / AccessibleCaret pairs visible in same document
Blocks: text-selection-mvp
No longer blocks: gecko-carets
May be a dup of Bug 1257273 (?) ... "When selecting text in an iframe that does not have focus, the selection handles appear outside of the iframe"

May also be related to Bug 1265550 ... "Trying to focus on text field sometimes selects it instead"

This bug is about selecting a word in an iframe. I have patches in bug 1306634 that can fix this.

Status: NEW → RESOLVED
Closed: 3 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1306634
You need to log in before you can comment on or make changes to this bug.