Several actions in one mail filter, multiple action support.

RESOLVED FIXED

Status

enhancement
P3
normal
RESOLVED FIXED
20 years ago
5 years ago

People

(Reporter: henrik, Assigned: naving)

Tracking

(Blocks 4 bugs, {helpwanted})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

20 years ago
Quite simple in concept actually

Instead of having just one action per filter. people could assign several action
s to a filter like

if (sender.contains(mozilla.org)
{
 move to folder("Mozilla)
 and set Priority(high)
}

Updated

20 years ago
Assignee: phil → nobody
Summary: several actions in one mail filter. → [HELP WANTED] several actions in one mail filter.
Whiteboard: HELP WANTED
Target Milestone: M20

Comment 1

20 years ago
Moving this to the HELP WANTED list, and cc'ing bienvenu, in case there's
overlap with his work to allow filters to put things in the flash panel.

Comment 2

20 years ago
*** Bug 16749 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Keywords: helpwanted

Updated

20 years ago
Summary: [HELP WANTED] several actions in one mail filter. → Several actions in one mail filter.
Whiteboard: HELP WANTED
Target Milestone: M20

Comment 3

19 years ago
*** Bug 59369 has been marked as a duplicate of this bug. ***
alecf and I have been talking about criteria. We decided that a down arrow 
should be provided on the left hand side of the criteria so that one can choose 
other criteria formats. I think this should also be the case for choosing 
different actions. One would click add, and then hit the down arrow, and a set 
of choices would appear. Then after choosing the format, one could set the 
options such as the priority status (low, medium, or high). Please look at bug 
59368 for information.

I believe you should make this a tracking bug and create dependents of this bug 
that are what your ideas of additional actions are (such as I did for macros).
Blocks: 59341
Adding myself as CC.
Blocks: 66425

Comment 6

18 years ago
*** Bug 80440 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
-> Filters
Assignee: nobody → naving
Component: Mail Back End → Filters
QA Contact: lchiang → laurel
Summary: Several actions in one mail filter. → Several actions in one mail filter, multiple action support.

Comment 8

18 years ago
*** Bug 107555 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Is any work proceeding on this (or subparts of this bug?) I see the helpwanted
tag ... I'm in the process of getting Moz built on my native platform (OS X) -
once that's done, hopefully I'll be in a position to contribute.
brice: OK. I would email the bug owner and ask him what needs to be done in
order to contribute for this bug and then you can decide if its something you
can complete in a reasonable amount of time.

Comment 11

17 years ago
*** Bug 138078 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
*** Bug 147202 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
*** Bug 146249 has been marked as a duplicate of this bug. ***
Blocks: 151925

Comment 14

17 years ago
*** Bug 125420 has been marked as a duplicate of this bug. ***
Blocks: 151622

Comment 15

17 years ago
*** Bug 174937 has been marked as a duplicate of this bug. ***

Comment 16

17 years ago
laurel: is this one of the bugs you mean in bug 174441 comment 1?

Comment 17

17 years ago

*** This bug has been marked as a duplicate of 17441 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 18

17 years ago
Oops, wrong bug number (left out a 4) and didn't notice this bug is marked as
blocking others... will leave it open and when bug 174441 is fixed, will deal with.
sorry for confusion
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

17 years ago
Blocks: 117037

Updated

17 years ago
Depends on: 174441

Updated

17 years ago
Blocks: 11037
The other way to handle this would be to introduce flow control into the
filter sets, like Pegasus Mail has; that would have the additional benefit
of also solving bug 59821.  It lacks the full benefits of complete 
scriptability (a la Gnus), but bug 11057 is going in that direction, so
doing it here would be redundant.

Comment 20

17 years ago
So now that bug 174441 is fixed, should this be marked fixed as well? Laurel?

Updated

17 years ago
No longer blocks: 117037

Comment 21

17 years ago
Now we can use more that one action in one rule. But, as previous, we cannot :
a) copy message to another folder
b) forward message to anybody. 
It's bad :)

Then, look to the my attached screenshot - we lost place to set more that one
condition in filter. Place only for one rule, no scrollers to scrom to another
that first.

Comment 22

17 years ago
Igor: that's bug 180144.
There are also seperate bugs for forwarding (bug 11034) and copying email (bug
61635) with filters.

Updated

17 years ago
Blocks: 11034, 61635

Comment 23

16 years ago
I believe that this bug is fixed by bug 174441 (if you disagree, say what's left
to do in _this_ bug). It should really be resolved as duplicate, but marking
fixed because of the dependencies.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.