Address book window: Initial view defaults to "All Address Books", need way of defaulting to specific AB (let user define initial default AB and/or remember last selected AB)

RESOLVED DUPLICATE of bug 1308776

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 1308776
3 years ago
9 months ago

People

(Reporter: Anje, Assigned: sshagarwal)

Tracking

(Blocks: 1 bug, {regression})

38 Branch
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Click on  'Address Book'

New tb 38 version has 'All Address Books' as auto selected.
Select 'Personal Address Book'
Close 'Address Book' window
Click on  'Address Book'






Actual results:

The 'All Address Books' is still selected.


Expected results:

'Personal Address Book' should be selected.

Currently, it does not remember the selected address book, if 'Address Book' is closed, so it obviously will not remember if Thunderbird is closed either.

I use 'MorefunctionsFor AddressBook', so I tested in Thunderbird Safe Mode and got the same results, so the addon is not effecting this issue.


Whilst I can see the need to 'search' all address books, there is no value in actually showing it all the time permanently. The point of a search is that you do not need to visually see a complete list of absolutely everything in order to search. 

This is OK if you are wanting to perform a manual search, but otherwise totally useless.  So, I presume the only reason for displaying absolutely every contact in  'All address Books' is to allow a manual search to show up duplicates etc.

I would have prefered the 'All Address Books' to have been something someone could select if they really needed it.

Often, I may have the same contact in more than one address book, so the 'All address Books' list looks like it is littered with various duplicates. Not easy to use.

So, I fail to see why you need to have an 'All address Book' set it as a permanent default which does not respect user selection.

Please, at the very least, allow the selected address book to be remembered, so that upon opening 'Address Book', the selected address book is selected and the 'All Address Books' is never selected unless the user specifies it.

Please advise if there a config editor entry / preference that can be set in order to stop this inability to select and remember the address book OR even better how to completely remove the 'All address Books' altogether. After all I do have a search function. 

I believe the bug 1142705 that also permantly defaults 'All Address books' in the contacts Sidebar is going to be fixed.  Can this bug of similar nature be done as well?

Updated

3 years ago
Blocks: 170270
Component: Untriaged → Address Book
See Also: → bug 1142705
Summary: All Address Books → Does not remember the selected address book, because of Search All Address Books
Whiteboard: [dupeme?]

Comment 1

3 years ago
As per bug 1142705, if the choice of address books is made in the contacts sidebar of a composition window, it will persist in subsequent composition windows during that session, but will be lost (defaulting to "All Addresses") if TB is quit and relaunched. Thus, the initial selection must be made in the contacts bar for each session.

As per this bug, however, if a selection is made in the "Address Book" window, it doesn't persist at all. Each time the address book window is opened (even during the same session), it will default to "All Addresses."
Summary: Does not remember the selected address book, because of Search All Address Books → Address book window does not remember the last selected address book, defaults to "All Address Books"
Anje, before TB 38, did TB Address book window remember *any* last selected AB or it just always defaulted to the first AB which happened to be "Personal Address Book"?

I think there might be different types of users. Some users will prefer remembering the last used AB, while others might prefer a clean start each time with the default AB, and get annoyed if TB starts off deep down somewhere where they happened to look around yesterday. Which leads to the question if we could just allow the user to chose the preferred behaviour himself:

When opening Address book, show:
[All Address Books | v]
|Last used address book |
|Personal AB            |
|Custom AB              |
|Collected Addresses    |

That's a single option (low-cost UI) providing maximum efficiency for all types of users. Problem solved once and for all. For comparison: Would everyone want Windows Explorer to always start off in the same folder you last used in the previous session?

Imho, TB exists to excel in workflow efficiency, but different users have different needs, so we should be more generous to allow customization in such important and efficiency-relevant areas.

Comments welcome.
Whiteboard: [dupeme?]
(Reporter)

Comment 3

3 years ago
re: did TB Address book window remember *any* last selected AB or it just always defaulted to the first AB which happened to be "Personal Address Book"?

Good point. I do not recall it remembering. But it was never required nor necessary to remember. 
I think it just always defaulted to the first AB which happened to be "Personal Address Book"

In creating a Search result showing all contacts called 'All Address books' and setting it as default means for normal useage - not needing to search absolutely everything on every occassion - you cannot simply add contacts or creates lists by using the toolbar as you have to select a 'real' address books first.  Toolbars that appear unuseable are confusing and not intuitive and do not assist in workflow efficiency.
Some support issues have arisen such as unnecessary additional clicking; confusion over why Adding a Contact is disabled when you open the 'Address Book' or why the default is set on displaying every contact but then disabling everything except Write.

I'm sure there are some people who have a need to search absolutely everything every time they open 'Address Book', so the 'All Address Books' will suit those occassions.

To fix this situation, I see  a few options and you may think of more, but which option is the easiest to apply.

If the search 'All address books' is set as default (current situation):
then there needs to be additional requirement to select:
Either a real address book as default - so user needs ability to choose and set the default. 

Or have the last address book accessed as 'remembered' by TB, 
else if no address book was selected then user was using the search 'All Address Books' option.

Or just auto set the 'Personal Address Book' as default, so everything works as before, no additional clicking, no disabled toolbar buttons. Nothing remembered and no option to set default. 'All Address Books' is still available but not set as default.

Personally, I would go with the latter.
(In reply to Anje from comment #3)
> re: did TB Address book window remember *any* last selected AB or it just
> always defaulted to the first AB which happened to be "Personal Address
> Book"?
> 
> you cannot simply add contacts or
> creates lists by using the toolbar as you have to select a 'real' address
> books first.  Toolbars that appear unuseable are confusing and not intuitive
> and do not assist in workflow efficiency.
> Some support issues have arisen such as unnecessary additional clicking;

+1. We're fixing that problem in bug 1143812: Indeed buttons for creating new contacts or mailing lists are swiss knife tools that should ALWAYS be available independent of context.

> so user needs ability to choose and set the default. 
> Or have the last address book accessed as 'remembered' by TB, 
> else if no address book was selected then user was using the search 'All
> Address Books' option.

+1. Please look at my comment 2 where I'm suggesting a simple option to cater for all types of users:
- allow user to define the AB shown when opening AB:
  - All ABs
  - Last used AB
  - Any speficic AB

So that provides maximum customization and workflow efficiency for everyone at little cost.
We still need to agree on which of these options should be default; I tend towards making All ABs the default because in the long run, duplication of contacts is undesired so All ABs has the best chance of finding any contact without returning duplicates, and it's an intuitive default from where you can drill down if you need smaller datasets. Likewise, file explorers tend to start from some top location like desktop because it's not easy to guess what other specific location is user's favourite. For that reason, I would NOT make "personal AB" the default.

> Or just auto set the 'Personal Address Book' as default, so everything works
> as before, no additional clicking, no disabled toolbar buttons. Nothing
> remembered and no option to set default.

No, that's trying to work around bug 1143812 but we'll fix that so that buttons are never disabled.
Offering a customizable default is superiour as it's more flexible for different users with different needs.

Comment 5

3 years ago
"So that provides maximum customization and workflow efficiency for everyone at little cost.
We still need to agree on which of these options should be default; I tend towards making All ABs the default because in the long run, duplication of contacts is undesired so All ABs has the best chance of finding any contact without returning duplicates, and it's an intuitive default from where you can drill down if you need smaller datasets. Likewise, file explorers tend to start from some top location like desktop because it's not easy to guess what other specific location is user's favourite. For that reason, I would NOT make "personal AB" the default."

I have been using TB for a long time now - and it has always defaulted to the Personal Address Book - After updating to 38 - it now lists ALL addresses....which means everyone I have ever emailed whether they were a client I contact daily, a one off response to someone I will never email again, or a request to stop spamming me are now listed in with all my good addresses. I would rather it didn't grab all the addresses from "Collected Addresses" and mix them in with my useful ones! Having it Remember the last Address Book - or letting us pick which one would be awesome....I may have to delete my collected address book just to shorten the list for now..
(Reporter)

Comment 6

3 years ago
re :I tend towards making All ABs the default because in the long run, duplication of contacts is undesired

In my case, the 'All Address books' is the only address book with duplicates.
I may have the same contact in more than one address book to facilate easy selection and organisation.
It also shows all Collected addresses mixed with in which is undesirable, so making the 'All address books only useful if I cannot remember where I stored something, which in my case is also unnecessary.
As the All address Books is extremely lengthy, you might not use it for general purposes

Whilst I'm sure there are some people who have a need to see every contact before they search, surely this is not the case for most people.

I'm still rather perplexed by why we need to see 'All Address books'.

After all, it is not a real address book. 
People needed to search all address books not see every contact, every duplicate etc before they search.
So, forgive me for being curious as to why this was not added to the search facility instead. Had that approach been taken, this situation would not have arisen.

Comment 7

3 years ago
The problem here might merely be the confusing use of the word "default."

My understanding is that Thomas was suggesting that the user should be able to set a preference for which address book should open (by default) -- and that "All Address Books" should be the default setting only until that preference has been otherwise set. (This is a relatively minor issue, since the setting would be customizable either way -- and even then, a pop-up bar would be available to navigate between address books.)

It's also my hope that this customized setting would also then apply to the contacts sidebar in the composition window.

QUESTION: If this customization option is implemented, would the setting be available directly via the preference panel interface, or would it require going to the config editor?
Flags: needinfo?(bugzilla2007)
(In reply to Miri from comment #5)
> I would rather it didn't grab all the addresses from "Collected
> Addresses" and mix them in with my useful ones! Having it Remember the last
> Address Book - or letting us pick which one would be awesome....I may have
> to delete my collected address book just to shorten the list for now...

Miri, I'm glad to see that you support the idea of this bug (especially when extended per my customization proposal), which is to provide a better user experience and more efficiency by allowing the user to chose which address book he wants to see when opening the main AB window. So that's work in progress. There's absolutely no need for you to delete your collected AB because what's stopping you from just selecting your favorite, say "Personal AB" from the list of ABs on the left (directory pane)? Then you'll see exactly the same limited dataset as before the introduction of "All ABs".

(In reply to Anje from comment #6)
> re :I tend towards making All ABs the default because in the long run,
> duplication of contacts is undesired
> 
> In my case, the 'All Address books' is the only address book with duplicates.
> I may have the same contact in more than one address book to facilate easy
> selection and organisation.

Anje, I think we can agree that having actual duplicate data is bad for the quality of any database. Admittedly, depending on your needs, the design shortcomings of the current AB infrastructure might force you into creating duplicate contacts, especially for the "multiple emails per person" or "mailing list" scenarios. Even so, duplicates should be avoided as much as possible.

> It also shows all Collected addresses mixed with in which is undesirable, so
> making the 'All address books only useful if I cannot remember where I
> stored something, which in my case is also unnecessary.

I'd think for many private users, there may not be much difference between collected addresses and personal AB. I'm sure many of us let Thunderbird collect new addresses on the fly and then just continue to use those. Historical errors like misusing collected addresses for "show remote content" have been fixed and unfortunately it's up to users to clean that out; we can't and we won't base our design on the errors of the past.

> As the All address Books is extremely lengthy, you might not use it for
> general purposes

That really depends on your level of duplication. Even with lots of duplicated contacts, it might be especially interesting to update all duplicate contacts at once.

> Whilst I'm sure there are some people who have a need to see every contact
> before they search, surely this is not the case for most people.

That's hard to predict, that's why I've suggested to make it customizable.

> I'm still rather perplexed by why we need to see 'All Address books'.
> After all, it is not a real address book. 
> People needed to search all address books not see every contact, every
> duplicate etc before they search.

Seeing every duplicate is a powerful usecase for address management...
We decided to implement "All ABs" view in bug 170270 because it enables powerful features for local ABs like cross-ab full listing/sorting, de-duplication, cross-AB moving/copying etc.

> So, forgive me for being curious as to why this was not added to the search
> facility instead. Had that approach been taken, this situation would not
> have arisen.

Yes we considered that approach in bug 170270 (see e.g. attachment 8560983 [details]), and it's one possible approach with advantages and disadvantages, but we ultimately went for the "All ABs" view instead.

(In reply to Mitch in Oakland from comment #7)
> The problem here might merely be the confusing use of the word "default."
> 
> My understanding is that Thomas was suggesting that the user should be able
> to set a preference for which address book should open (by default) -- and
> that "All Address Books" should be the default setting only until that
> preference has been otherwise set. (This is a relatively minor issue, since
> the setting would be customizable either way -- and even then, a pop-up bar
> would be available to navigate between address books.)

Exactly.

> It's also my hope that this customized setting would also then apply to the
> contacts sidebar in the composition window.

I wonder how helpful that would really be.
Functionalities differ: Contacts side bar is mainly for choosing recipients; whereas main AB is mainly for general address management.

For contacts side bar, we have bug 1142705 and we're just exploring to have an even more fine-grained control over the initial AB shown when starting a new composition. E.g., when I'm using my business email account, I'll want to see my business AB when starting a new composition, but for my private account, I'll want to start out with my private AB. Perhaps even distinguish identities. So it depends on the sender identity.

I doubt we'll want the same degree of control for the main AB because of the different functionalities mentioned. Plus it would be very difficult if not structurally impossible to figure out the right sender identity from the main AB. So currently I suspect we'll be better off to keep the 'initial-AB' settings separate between main AB and contacts side bar, which grants more control to the user.

It's very possible you'd want to initially see "All ABs" for contacts side bar when composing, but in main AB, you mostly manage your business contacts so you'd prefer "business AB" for starting out there.

> QUESTION: If this customization option is implemented, would the setting be
> available directly via the preference panel interface, or would it require
> going to the config editor?

I'm strongly in favor of making this accessible in the preferences UI, because it's relevant for everyday efficiency of workflows. However, I'm not the only one to decide.
Flags: needinfo?(bugzilla2007)

Comment 9

3 years ago
Thomas D, your responses are quite encouraging, and I'll be very interested to see how the customization is actually implemented.

You did, however, hit one sour note, in writing, "Historical errors like misusing collected addresses for 'show remote content' have been fixed and unfortunately it's up to users to clean that out; we can't and we won't base our design on the errors of the past."


I've been using TB since the days when it was Netscape Mail; thus, before the recent development of the new "whiteboard" interface for alloowing remote content, I'd accumulated at least ten years' worth of addresses in a special address book I named "Remote Permissions." (Since there's no way to transfer this information to the new interface as a batch, the tedious nature of "cleaning it out" can't be so easily dismissed.) "Collected Addresses," incidentally, is empty.

Now, when I open a composition window with "All Addresses" as the default contacts sidebar, all those addresses show up in the list (some as double or triple entries). If I change the pop-up to "Personal Addresses," everything seems to work exactly as I want -- including, if I'm not mistaken, the display of remote content I authorized on that "Remote Permissions" list (along with anything I've added via the new interface), without those entries cluttering the sidebar.

With the new customization (as I understand it), I should be able to display Personal Addresses by default, so that everything works the way it did before the advent of "All Addresses" (plus the functionality of the new whiteboard). Ditto, as per this bug discussion, for the address book window itself.

As best you can tell at this point, is that so? If not, what are my options?
Flags: needinfo?(bugzilla2007)
(In reply to Mitch in Oakland from comment #9)
> Thomas D, your responses are quite encouraging, and I'll be very interested
> to see how the customization is actually implemented.

:)

> You did, however, hit one sour note, in writing, "Historical errors like
> misusing collected addresses for 'show remote content' have been fixed and
> unfortunately it's up to users to clean that out; we can't and we won't base
> our design on the errors of the past."
> 
> 
> I've been using TB since the days when it was Netscape Mail; thus, before
> the recent development of the new "whiteboard" interface for alloowing
> remote content, I'd accumulated at least ten years' worth of addresses in a
> special address book I named "Remote Permissions." (Since there's no way to
> transfer this information to the new interface as a batch, the tedious
> nature of "cleaning it out" can't be so easily dismissed.) "Collected
> Addresses," incidentally, is empty.

So you managed to outsmart the messiness of the old design but now TB is giving you a hard time to migrate your existing permissions to a the new interface of the "Exceptions - Remote Content" dialog located in Tools > Options > Privacy > Mail Content. Life is unfair! :|
Batch permissions via csv export/import would actually be a cool feature, we could file a RFE for that but our developers may not have the free cycles for that...

> Now, when I open a composition window with "All Addresses" as the default
> contacts sidebar, all those addresses show up in the list (some as double or
> triple entries). If I change the pop-up to "Personal Addresses," everything
> seems to work exactly as I want -- including, if I'm not mistaken, the
> display of remote content I authorized on that "Remote Permissions" list

I'm not sure what happens to existing permissions after bug 457296; if they are migrated automatically to the new list or not (think not); how the old "remote permission on contact properties" worked (contact property?); if it's still read or not (guess not). I suspect that our migration experience wasn't too good but I'm still happy we made the design change at all to stop further data messup.

> (along with anything I've added via the new interface), without those
> entries cluttering the sidebar.
> 
> With the new customization (as I understand it), I should be able to display
> Personal Addresses by default, so that everything works the way it did
> before the advent of "All Addresses" (plus the functionality of the new
> whiteboard). Ditto, as per this bug discussion, for the address book window
> itself. As best you can tell at this point, is that so? If not, what are my options?

Yes, if my proposals get realized, you can set any out of the following as a default AB to be shown upon opening the main AB window: {All ABs} | {Last used AB} | {Personal AB} | {User AB} |... 
By analogy, but independently, the same for contacts side bar, ideally one global user-configurable default setting plus per-account and/or per-identity setting of the initial AB shown when starting a new composition from that account or possibly when changing sender identity (we'll discuss that in bug 1142705).

So with those customization options, your setup can work exactly as before, apart from the caveats about the likely lack of auto-migration for your old remote permissions. Definitely after filling out the new remote permissions dialogue, things will work exactly as before.

Perhaps in the interest of landing a fast fix, we might have to settle for "Remember last used" as an interim solution.

Until those customization options arrive, you can always select "Personal AB" manually where TB defaults to "All ABs".

Further enquiries if not related to or of interest for this bug, pls email me privately.
Flags: needinfo?(bugzilla2007)

Comment 11

3 years ago
It seems this bug is a duplicate of bug 1142705.

Comment 12

2 years ago
Agreed, this is a dupe of bug 1142705

Comment 13

2 years ago
indeed, hopefully will be fixed by bug 1142705
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Depends on: 1142705
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1142705

Comment 14

2 years ago
(In reply to Charles from comment #12)
> Agreed, this is a dupe of bug 1142705

I don't think so. Only if you can prove this bug didn't exist before TB38 (bug 170270).
I think the Ab list in the AB window is a different beast than the Contacts sidebar. Suyash, what do you think?

But I can at least confirm this bug. It does exist, however unless it is really a regression, it should be considered a feature request.

Comment 15

2 years ago
The patch in bug 1142705 does not fix this bug (for me). Suyash can you see if this bug is related?
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(syshagarwal)
Resolution: DUPLICATE → ---
(Assignee)

Comment 16

2 years ago
(In reply to :aceman from comment #15)
> The patch in bug 1142705 does not fix this bug (for me). Suyash can you see
> if this bug is related?

Hi, ya the patch on bug 1142705 didn't fix this bug for me too. We can address this when we fix this code properly.
Flags: needinfo?(syshagarwal)
(Reporter)

Comment 17

2 years ago
I'm constantly seeing complaints and questions in the forums regarding this 'All Address Books' issue.
Will this be fixed for the version 45.0 ?
What version can we expect to see this fixed?

re : We can address this when we fix this code properly.
What does that mean ?

re : Assigned To: Nobody; OK to take it and work on it 
Is someone fixing / working on this issue?



Acceptable solutions would be:
Ideally. completely remove the current 'All Address Books' and make it a proper search facility available under Search - you do not need to see all search items before searching. It is completely illogical.
This is not how a search should work. 

Could you imagine seeing every email in every folder in every account - The Global Database, ("Gloda" for short), the indexing system that enables Thunderbird to search messages. What would be the purpose of showing the entire contents of the Global database prior to asking search/filter criteria because that is the logic being applied to the Address Book at the moment and it needs some serious rethinking.


As a basic level urgent need:
To be able to select a default address book and regardless of whether you close and reopen the  'Address Book' during a session or close and reopen Thunderbird. That default address book should remain as selected.
This would need to be done asap, even if the proper fixing of not displaying an entire search prior to searching is resolved.

Comment 18

2 years ago
(In reply to Suyash Agarwal (:sshagarwal) from comment #16)
> Hi, ya the patch on bug 1142705 didn't fix this bug for me too. We can
> address this when we fix this code properly.
Where are we trying to fix it properly? In which bug? Or can you look at it here?
Flags: needinfo?(syshagarwal)
OS: Unspecified → All
Hardware: Unspecified → All
(Assignee)

Comment 19

2 years ago
(In reply to :aceman from comment #18)
> (In reply to Suyash Agarwal (:sshagarwal) from comment #16)
> > Hi, ya the patch on bug 1142705 didn't fix this bug for me too. We can
> > address this when we fix this code properly.
> Where are we trying to fix it properly? In which bug? Or can you look at it
> here?

Hi, we will fix it here :)
Do we have plans on implementing the customization pref?


(In reply to Anje from comment #17)
> Will this be fixed for the version 45.0 ?
> What version can we expect to see this fixed?
> 
> re : We can address this when we fix this code properly.
> What does that mean ?
> 
> re : Assigned To: Nobody; OK to take it and work on it 
> Is someone fixing / working on this issue?
Hi, calm down :)

> Acceptable solutions would be:
> Ideally. completely remove the current 'All Address Books' and make it a
> proper search facility available under Search - you do not need to see all
> search items before searching. It is completely illogical.
> This is not how a search should work. 
Who said it's just for search purposes? Initially the issue was search, yes. But there's been a lot of discussion over this and then this came up. Thomas has very elaborately tried to explain the benefits of having All ABs. And please, don't forget the other users: bug 1236553 (I see you as the reporter on someon's behalf).
> 
> Could you imagine seeing every email in every folder in every account - The
> Global Database, ("Gloda" for short), the indexing system that enables
> Thunderbird to search messages. What would be the purpose of showing the
> entire contents of the Global database prior to asking search/filter
> criteria because that is the logic being applied to the Address Book at the
> moment and it needs some serious rethinking.
Please excuse my limited knowledge, isn't that the case with gmail's "All email"?

We are gonna try and fix this asap bear with us :)
Assignee: nobody → syshagarwal
Flags: needinfo?(syshagarwal)

Comment 20

2 years ago
(In reply to Thomas D. (currently busy elsewhere; needinfo?me) from comment #2)
> Anje, before TB 38, did TB Address book window remember *any* last selected
> AB or it just always defaulted to the first AB which happened to be
> "Personal Address Book"?
> 
> I think there might be different types of users. Some users will prefer
> remembering the last used AB, while others might prefer a clean start each
> time with the default AB, and get annoyed if TB starts off deep down
> somewhere where they happened to look around yesterday. Which leads to the
> question if we could just allow the user to chose the preferred behaviour
> himself:
> 
> When opening Address book, show:
> [All Address Books | v]
> |Last used address book |
> |Personal AB            |
> |Custom AB              |
> |Collected Addresses    |
> 
> That's a single option (low-cost UI) providing maximum efficiency for all
> types of users. Problem solved once and for all. For comparison: Would
> everyone want Windows Explorer to always start off in the same folder you
> last used in the previous session?
> 
> Imho, TB exists to excel in workflow efficiency, but different users have
> different needs, so we should be more generous to allow customization in
> such important and efficiency-relevant areas.
> 
> Comments welcome.

That is a great option, if that could be implemented.

"JP"
(Reporter)

Comment 21

2 years ago
I would be happy to leave things as they are in the Directory Pane showing 'All Address Books' as default so users are not subjected to another change, but with the ability to set my preferred default address book.
This could be added as an option:
Either via 'Tools' > 'Options'> 'Composition' > 'Addressing' tab which has space to be able to choose 'Default address book' from a drop down list.
OR via right click on an address book, select 'Properties'
currently it just says the address book name, but it could also have the option to set as default.

So the options are leave as is where  'All address books ' is default or have the option to select one as default.

If you feel it really is necessary to have another option to open on last selected, then that could also be added in the 'Tools' > 'Options'> 'Composition' > 'Addressing' tab.

Thoughts on this ?

Updated

2 years ago
See Also: → bug 1236553
(Reporter)

Comment 22

a year ago
Just to update. Version 45.2.0 still has same issue.

Comment 23

a year ago
I think would be ideal!


(In reply to Anje from comment #21)
> I would be happy to leave things as they are in the Directory Pane showing
> 'All Address Books' as default so users are not subjected to another change,
> but with the ability to set my preferred default address book.
> This could be added as an option:
> Either via 'Tools' > 'Options'> 'Composition' > 'Addressing' tab which has
> space to be able to choose 'Default address book' from a drop down list.
> OR via right click on an address book, select 'Properties'
> currently it just says the address book name, but it could also have the
> option to set as default.
> 
> So the options are leave as is where  'All address books ' is default or
> have the option to select one as default.
> 
> If you feel it really is necessary to have another option to open on last
> selected, then that could also be added in the 'Tools' > 'Options'>
> 'Composition' > 'Addressing' tab.
> 
> Thoughts on this ?
Clarifying Summary - main UX problem is that there's no way to change the current initial default view of "All Address Books" to any other specific AB. Then there are different solutions to that issue, as Anje, myself and others have pointed out:

Possible Solutions

1) Allow user to set "All Address Books" or any other other specific AB for initial default view
2) Upon closing of AB window, remember the last selected AB and show the same next time
3) Make "Personal AB" the initial default AB for viewing (as before bug 170270 which introduced "All Addresses), with or without allowing other defaults

Details and Evaluation of possible solutions

1) Allowing users to freely set their personally preferred initial default view is obviously the most versatile and sustainable solution. Possible implementations (not mutually exclusive):
- A checkbox in AB properties dialogue (right-click on AB > Properties): E.g.
[ ] Initially show this address book   OR   [ ] Initial default view   OR   [ ] Show as initial default
(minimal implementation, and imo pretty good!)
- A context menu entry (tempting, but imo not very good as it's rarely used, hence clutter)
- A dropdown listbox option in Tools > Options (> Composition > Addressing) (Full implementation, most versatile)

2) Remembering the last used AB is a useful option which will solve the problem for some, but not all users and scenarios. As a standalone solution, this would not require any UI. This would be a nice complement to 1), but imo not useful as a standalone solution, where we'd get complaints again why we don't allow always starting out with user's favorite AB, regardless of last used AB or view which might be totally irrelevant for next use (or totally wanted, depending on users and scenarios).

3) Merely changing the current default from "All Address Books" back to "Personal AB" is a stop-gap solution at best, again catering only for certain subsets of users and scenarios. Otherwise the question of factory default is somewhat outside the scope of this bug, and becomes pretty much irrelevant if we implement a discoverable solution for 1).
Summary: Address book window does not remember the last selected address book, defaults to "All Address Books" → Address book window: Initial view defaults to "All Address Books", need way of defaulting to specific AB (let user define initial default AB and/or remember last selected AB)
No longer blocks: 1308776
Depends on: 1308776
Thanks everyone for reporting and advocating this.

Following my initiative and full pioneer patch in bug 1308776, this has now been collaboratively fixed:
On the context menu of ABs and mailing lists, there'll be an entry to make the selected directory the default for startup. Removing the current default checkmark (so there's no default any more), will remember the last used directory. In addition, an explicit pref UI was implemented in Tools > Options > Composition > Addressing.

Unfortunately, this has missed the extended string freeze for upcoming release of TB52, so this will only land with the following release version.
Status: REOPENED → RESOLVED
Last Resolved: 2 years agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1308776
Depends on: 1343617
No longer depends on: 1343617
No longer depends on: 1142705
You need to log in before you can comment on or make changes to this bug.