Closed Bug 1178837 Opened 6 years ago Closed 6 years ago

browser.newtab.url broken in Nightly

Categories

(Firefox :: New Tab Page, defect)

42 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: dave, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150630030204

Steps to reproduce:

Get 42.0a1 (2015-06-30) automatically.

ctrl+t to open a new tab.  Observe fancy new tab page.

Go into about:config to restore your d:\src\navi\navi.html page for new tabs.

Find that browser.newtab.url is already set to file:///d:/projects/navi/navi.html.

Try setting browser.newtabpage.enabled=false.

Try ctrl+t again.


Actual results:

New tab is empty.


Expected results:

I expect the browser to open the html file specified in browser.newtab.url.
There is a typo in my previous message.  "d:\src\navi" should say "d:\projects\navi".  The typo is in the bugreport only, not my configuration...
Component: Untriaged → New Tab Page
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
That is the consequence of this bug:

Bug 1118285 - The browser.newtab.url preference is abused and should be removed

You can check this mozillaZine thread.
http://forums.mozillazine.org/viewtopic.php?f=23&t=2944193
No longer blocks: 1118285
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Duplicate of this bug: 1210251
Duplicate of this bug: 1211785
Duplicate of this bug: 1212449
Duplicate of this bug: 1211601
Duplicate of this bug: 1207463
You need to log in before you can comment on or make changes to this bug.