Alias -webkit-border-image longhand CSS properties (later backed out in bug 1230426)

RESOLVED FIXED in Firefox 45

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: miketaylr, Assigned: dholbert)

Tracking

(Blocks 1 bug)

unspecified
mozilla45
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
We should alias the following -webkit- prefixed CSS border properties to their standards equivalents (either via CSS Unprefixing or otherwise) in Gecko.

-webkit-border-bottom-left-radius
-webkit-border-bottom-right-radius
-webkit-border-image
-webkit-border-image-outset
-webkit-border-image-repeat
-webkit-border-image-slice
-webkit-border-image-source
-webkit-border-image-width
-webkit-border-radius
-webkit-border-top-left-radius
-webkit-border-top-right-radius

Source <https://docs.google.com/spreadsheets/d/173d1p3LkW_LWk-VMnrxGPhTobtKSpED30Fys5ZJLttA/edit?pli=1#gid=51341101>
Reporter

Updated

4 years ago
Blocks: 1170789
Reporter

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 837211
Reporter

Comment 2

4 years ago
This was added in Bug 837211, but I'll put links to the spec additions here.
Reporter

Comment 3

4 years ago
(In reply to Mike Taylor [:miketaylr] from comment #2)
> This was added in Bug 837211, but I'll put links to the spec additions here.

Looking a little more closely here...as for the border-image related props, we've only aliased the shorthand -webkit-border-image. These aren't:

-webkit-border-image-outset
-webkit-border-image-repeat
-webkit-border-image-slice
-webkit-border-image-source
-webkit-border-image-width

These props were unprefixed in https://bug713643.bmoattachments.org/attachment.cgi?id=628587 (from Bug 713643).

dholbert, do you think we should add -webkit- aliases for these longhand props?

In http://dbaron.org/log/20120612-border-image, dbaron wrote:

> However, since we have never shipped a release with -moz-border-image-source or any of the other subproperties, we will not be adding prefixed support for them, since there's no compatibility reason to do so.

(But he was referring to compatibility with already existing -moz-border-image-* props, I think.)
Flags: needinfo?(dholbert)
Assignee

Comment 5

4 years ago
(In reply to Mike Taylor [:miketaylr] from comment #3)
> dholbert, do you think we should add -webkit- aliases for these longhand
> props?

I suppose so, given that they're in the Edge list linked in comment 0. (& it sounds like MS has data showing that the web depends on them, as noted in bug 1179444 comment 3)

> In http://dbaron.org/log/20120612-border-image, dbaron wrote: [...]
> 
> (But he was referring to compatibility with already existing
> -moz-border-image-* props, I think.)

Agreed -- I don't think that post has any bearing on this bug.

I'll reopen this bug to cover adding these longhand APIs.
Assignee

Updated

4 years ago
Assignee: nobody → dholbert
Status: RESOLVED → REOPENED
Depends on: 837211
Flags: needinfo?(dholbert)
Resolution: DUPLICATE → ---
Reporter

Comment 6

4 years ago
Thanks Daniel.
Assignee

Comment 7

4 years ago
Posted patch fix v1Splinter Review
This patch adds support for the webkit-prefixed border properties mentioned in comment 3.
Attachment #8682714 - Flags: review?(cam)
Comment on attachment 8682714 [details] [diff] [review]
fix v1

Review of attachment 8682714 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/style/nsCSSPropAliasList.h
@@ +295,5 @@
>  CSS_PROP_ALIAS(-webkit-background-size,
>                 background_size,
>                 WebkitBackgroundSize,
>                 WEBKIT_PREFIX_PREF)
> +

Nit: if we're including a blank line before the -webkit-border-image* properties, then we probably want one after them (i.e. just before -webkit-box-shadow) too?
Attachment #8682714 - Flags: review?(cam) → review+
Assignee

Comment 10

4 years ago
Sounds good, I'll add that -- thanks!

Comment 12

4 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/55d1d2b35a93
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
Reporter

Updated

4 years ago
See Also: → 1230426
Assignee

Comment 13

4 years ago
(In reply to Daniel Holbert [:dholbert] from comment #5)
> (In reply to Mike Taylor [:miketaylr] from comment #3)
> > dholbert, do you think we should add -webkit- aliases for these longhand
> > props?
> 
> I suppose so, given that they're in the Edge list linked in comment 0. (& it
> sounds like MS has data showing that the web depends on them

Turns out Edge removed support for these, so we're doing so too (effectively backing out this bug), in bug 1230426.
Depends on: 1230426
No longer depends on: 837211
See Also: 1230426
Summary: Alias -webkit-border* CSS properties → Alias -webkit-border-image longhand CSS properties (later backed out in bug 1230426)
You need to log in before you can comment on or make changes to this bug.