Closed Bug 1182509 Opened 4 years ago Closed 4 years ago

[Contacts][NGA] Open contacts_matching with window.open

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-master fixed)

RESOLVED FIXED
FxOS-S4 (07Aug)
Tracking Status
b2g-master --- fixed

People

(Reporter: jorgep, Assigned: jorgep)

References

Details

(Whiteboard: [NG Gaia Contacts][patch])

Attachments

(2 files)

In orden to obtain a more webby behavior and reduce problems with history, we are going to load contacts_matching tool with window.open instead of an iframe.
Assignee: nobody → jpruden92
Blocks: 1169191
Whiteboard: [NG Gaia Contacts][patch]
Target Milestone: --- → FxOS-S2 (10Jul)
Status: NEW → ASSIGNED
Target Milestone: FxOS-S2 (10Jul) → FxOS-S3 (24Jul)
Whiteboard: [NG Gaia Contacts][patch] → [NG Gaia Contacts]
Depends on: 1182484
Depends on: 1181996
Whiteboard: [NG Gaia Contacts] → [NG Gaia Contacts][patch]
Attachment #8635975 - Flags: feedback?(borja.bugzilla)
Comment on attachment 8635975 [details] [review]
[gaia] jpruden92:bug_iframe-vs-wopen > mozilla-b2g:master

Great job Jorge! Some comments to address and one test, and we are ready to review this! :)
Attachment #8635975 - Flags: feedback?(borja.bugzilla) → feedback+
Attachment #8635975 - Flags: review?(borja.bugzilla)
Attachment #8635975 - Flags: review?(francisco)
Comment on attachment 8635975 [details] [review]
[gaia] jpruden92:bug_iframe-vs-wopen > mozilla-b2g:master

Left some comments on gh, but overall is looking pretty good.

Could not see the title changing, just saw the url instead of the window title. I saw we have code for changing the window title, perhaps we should talk with a wm peer to check if that works.
Attachment #8635975 - Flags: review?(francisco)
Once we land this bug, we should check if bug 1177357 is still happening
Target Milestone: FxOS-S3 (24Jul) → FxOS-S4 (07Aug)
Attachment #8639367 - Flags: review?(francisco)
Attachment #8635975 - Flags: review?(borja.bugzilla)
Attachment #8639367 - Flags: review?(francisco) → review+
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1177357
See Also: → 1190775
Depends on: 1208669
You need to log in before you can comment on or make changes to this bug.