Closed Bug 1190775 Opened 5 years ago Closed 5 years ago

[System] If an activity perform a window.open, the popup will be unresponsive

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S4 (07Aug)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: yue.xia, Assigned: etienne)

References

Details

(Keywords: regression, Whiteboard: [2.5-aries-test-run-1])

Attachments

(4 files)

Attached video Aries_2.5_video.3gp
[1.Description]:
[Aries v2.5][Flame v2.5][Contacts]Launch messages app and send a SMS which contains a same email address with contact A. Save this mail address from SMS thread view on test device to an existing contact, then merge with contact dialog screen pops up, but the "x" icon and "Merge with 1 contact" button doesn't work.

See attachment: logcat_Aries_2.5.txt & Aries_2.5_video.3gp
Found time: 11:10

[2.Testing Steps]: 
Precondition: There are at least two contacts in test device, contact A has an email address, contact B has a phone number.
1. Launch Messages app
2. Send a sms from test device to other device, and sms contains a same email address with contact A.
3. Open the thread view on test device.
4. Tap the email address and select "Add to an existing contact".
5. Select contact B and tap "Update".
6. Observe the "Merge with 1 contact" dialog screen.

[3.Expected Result]: 
6. The "x" icon and "Merge with 1 contact" button could work normally.

[4.Actual Result]: 
6. The "x" icon and "Merge with 1 contact" button doesn't work, user only can exit this screen by killing the Messages task from task manager.

[5.Reproduction build]: 
Device: Aries KK 2.5(Affected)
Build ID               20150801110932
Gaia Revision          2ca27bbdd84526c6a3b198d9cf10f2caff1dadde
Gaia Date              2015-07-31 08:23:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/32712cd01159
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150801.105449
Firmware Date          Sat Aug  1 10:54:56 UTC 2015
Bootloader             s1

Device: Flame KK 2.2(Unaffected)
Build ID               20150803032504
Gaia Revision          f8b119ac30e97df991c97682ac4d4f9ca22e1793
Gaia Date              2015-07-31 13:20:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/429b9d2d4566
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150803.072845
Firmware Date          Mon Aug  3 07:28:58 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device:Flame KK 2.5(Affected)
Build ID               20150803150205
Gaia Revision          dbacf8364f4505d021b7d8fb9cabea325004dbcc
Gaia Date              2015-08-03 16:38:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/abc56d57f6e1
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150803.183149
Firmware Date          Mon Aug  3 18:32:00 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8. Note]:
This problem can't be reproduced when user creates a contact who contains the same email address with another contact in Contact app.
Attached file logcat_Aries_2.5.txt
I am also able to reproduce the issue tapping on "Create new contact" (step 4) so changing the title according to it.
Summary: [Contacts]Save a mail address from SMS to an existing contact, then merge with contact dialog screen pops up, but the "x" icon and "Merge with 1 contact" button doesn't work. → [Contacts]Save a mail address from SMS to an existing contact or a new one, then merge with contact dialog screen pops up, but the "x" icon and "Merge with 1 contact" button doesn't work.
This bug can also be reproduced with this STR:
Pre-requisite: Have an entry in the Call log of a Contact that is already in the Agenda
1. Launch Dialer application and tap on Call log tab
2. Long press on the Contact entry and select "Call information"
3. Press on "Contact details" button at the end of the screen
4. Press on "Find duplicated contacts" 

Actual Result:
Matching screen when "No duplicate contacts found" message is shown but if you press "OK" or try to close the screen, it does not work. You can only exit that screen by killing the Dialer application.

Expected Result: Matching screen when "No duplicate contacts found" message is shown but if you press "OK" or try to close the screen, the matching screen should be skipped. 

I think this is a regression introduced when landing Bug 1182509 - [Contacts][NGA] Open contacts_matching with window.open. 

The window.open is not working properly when it's launched from an activity. I am not sure but it seems that this behaviour should be taken into account by System app.
See Also: → 1182509
It seems to be a bug in System, due to the window.open works within the app, but not in the Activity contacts (actually it's not responsive).
Gregor, could you take a look?
Flags: needinfo?(anygregor)
*but not in the Activity _context_ :)
Flags: needinfo?(anygregor)
Keywords: regression
QA Contact: pcheng
b2g-inbound regression window:

Last Working
Device: Flame 2.5
BuildID: 20150728075544
Gaia: ba33139c251108308cf882c152d9a7fff001bb83
Gecko: 37b209a43f65
Version: 42.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken
Device: Flame 2.5
BuildID: 20150728092745
Gaia: 862f0895f3f5a97200601542d99a152a46385a0b
Gecko: abf601a06c59
Version: 42.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working Gaia First Broken Gecko - no repro
Gaia: ba33139c251108308cf882c152d9a7fff001bb83
Gecko: abf601a06c59

Last Working Gecko First Broken Gaia - repro
Gaia: 862f0895f3f5a97200601542d99a152a46385a0b
Gecko: 37b209a43f65

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/ba33139c251108308cf882c152d9a7fff001bb83...862f0895f3f5a97200601542d99a152a46385a0b

Confirmed what comment 3 suspected, this issue is caused by changes made in bug 1182509.
Blocks: 1182509
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Jorge, can you take a look at this please? This might have been caused by the landing for bug 1182509.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(jpruden92)
Etienne, can you have a look at it, please?
This is the issue we commented in the Gaia meeting yesterday, thanks a lot!
Flags: needinfo?(jpruden92) → needinfo?(etienne)
Component: Gaia::Contacts → Gaia::System::Window Mgmt
Flags: needinfo?(etienne)
Summary: [Contacts]Save a mail address from SMS to an existing contact or a new one, then merge with contact dialog screen pops up, but the "x" icon and "Merge with 1 contact" button doesn't work. → [System] If an activity perform a window.open, the popup will be unresponsive
[Blocking Requested - why for this release]: Functional regression from 2.2.
blocking-b2g: --- → 2.5?
Assignee: nobody → etienne
Status: NEW → ASSIGNED
blocking-b2g: 2.5? → 2.5+
This looks like a regresstion for bug 1179040 and bug 1179040
blocking-b2g: 2.5+ → 2.5?
Depends on: 1188797, 1179040
Comment on attachment 8645023 [details] [review]
[gaia] etiennesegonzac:bug-1190775 > mozilla-b2g:master

quick r? :)
Attachment #8645023 - Flags: review?(apastor)
Comment on attachment 8645023 [details] [review]
[gaia] etiennesegonzac:bug-1190775 > mozilla-b2g:master

LGTM. Thanks!
Attachment #8645023 - Flags: review?(apastor) → review+
https://github.com/mozilla-b2g/gaia/commit/0afa6429bf6a772289801600a84438cd7aa27b11
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S4 (07Aug)
Downgrading the blocker flag to the nom seems like a mid-air collision in comment 10. Putting back the blocker status.
blocking-b2g: 2.5? → 2.5+
This bug has been verified as pass on latest build of Aries kk v2.5 & Flame kk v2.5 by the STR in Comment 0.
Actual results: The "x" icon and "Merge with 1 contact" button could work normally.
See attachments: Verified_Aries-kk_v2.5.3gp
Reproduce rate: 0/5
Device: Aries KK 2.5(Pass)
Build ID               20150825220518
Gaia Revision          a8a462ab783a5bbab508d3c29483cff260672e3c
Gaia Date              2015-08-25 04:21:06
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c46370eea81a9860ae77d1f0c7776c24e816138e
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150825.212416
Firmware Date          Tue Aug 25 21:24:24 UTC 2015
Bootloader             s1

Device: Flame KK 2.5(Pass)
Build ID               20150825150204
Gaia Revision          a8a462ab783a5bbab508d3c29483cff260672e3c
Gaia Date              2015-08-25 04:21:06
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c46370eea81a9860ae77d1f0c7776c24e816138e
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150825.204529
Firmware Date          Tue Aug 25 20:45:45 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Note: Because of bug 1191729,the "Merge with 1 contact" button at bottom can not display completely but it is available.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
(In reply to Annabelle from comment #16)

> 
> Note: Because of bug 1191729,the "Merge with 1 contact" button at bottom can
> not display completely but it is available.

Thanks a lot, Annabelle!
Just adding that this issue is reported in bug 1191288.
You need to log in before you can comment on or make changes to this bug.