Closed Bug 1278957 (skia-linux) Opened 3 years ago Closed 3 years ago

Make Skia the default content backend on Linux

Categories

(Core :: Graphics, defect)

All
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: mchang, Assigned: lsalzman)

References

Details

(Whiteboard: gfx-noted)

Attachments

(1 file)

No description provided.
OS: Android → Linux
Hardware: ARM → All
Whiteboard: gfx-noted
Enables Skia content for both Linux and Android since they are currently controlled by the same init code in libpref, and we intended to enable them both together anyway.
Attachment #8779001 - Flags: review?(mchang)
Blocks: skia-android
Comment on attachment 8779001 [details] [diff] [review]
enable Skia content for Linux and Android

Review of attachment 8779001 [details] [diff] [review]:
-----------------------------------------------------------------

Awesomeness.
Attachment #8779001 - Flags: review?(mchang) → review+
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/33b8617a7233
enable Skia content for Linux and Android. r=mchang
backed out for likely causing reftest failures like https://treeherder.mozilla.org/logviewer.html#?job_id=33535207&repo=mozilla-inbound , sorry Lee
Flags: needinfo?(lsalzman)
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7bbd0953ab0b
Backed out changeset 33b8617a7233 for linux pgo reftest failures
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/05bc24cabedf
enable Skia content for Linux and Android. r=mchang
Did this cause gfx/skia/skia/src/ports/SkFontHost_FreeType_common.cpp:116: fatal error: ""3 * mask.fBounds.width() == static_cast<int>(bitmap.width)"" ?
-pref("gfx.content.azure.backends", "skia");
+pref("gfx.content.azure.backends", "cairo");
lets me start debug build again, so yes.
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cc88b920a387
enable Skia content for Linux and Android. r=mchang
(In reply to Pulsebot from comment #10)
> Pushed by lsalzman@mozilla.com:
> https://hg.mozilla.org/integration/mozilla-inbound/rev/cc88b920a387
> enable Skia content for Linux and Android. r=mchang

Due to the optimization flags supplied to Linux 32-bit PGO builds (-O3) and the unfortunate combination of x87 and SSE2 code, some tests just have to be disabled because they're always going to be a bit fuzzy under Skia until we start forcing SSE2 at compile-time on Linux 32 builds as well...
https://hg.mozilla.org/mozilla-central/rev/cc88b920a387
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
(In reply to Olli Pettay [:smaug] from comment #7)
> Did this cause gfx/skia/skia/src/ports/SkFontHost_FreeType_common.cpp:116:
> fatal error: ""3 * mask.fBounds.width() == static_cast<int>(bitmap.width)"" ?

Stuff I need to help reproduce this:
The recursive contents of /etc/fonts (with symlinks dereferenced) so I can run locally with your fontconfig setup.
The Graphics section of about:support
The full stack trace leading up to the assertion if possible 

But otherwise, this problem should be present in Skia canvas as well. So Skia content did not cause it, it just makes it easier to trigger. It would be nice if we can find a way to reproduce and fix this.
Flags: needinfo?(lsalzman) → needinfo?(bugs)
Looks like the UI issue at least does happen in pdf.js, which is using canvas.
Flags: needinfo?(bugs)
but let me send you the fonts
Depends on: 1294207
This very near permafailing test started failing when this landed: https://treeherder.mozilla.org/logviewer.html#?job_id=33673428&repo=mozilla-inbound

Backed out in https://hg.mozilla.org/mozilla-central/rev/ec2f0fc180b7
Status: RESOLVED → REOPENED
Flags: needinfo?(lsalzman)
Resolution: FIXED → ---
This also appears to have coincided with 32-bit linux debug mochitest(3) very frequently timing out like https://treeherder.mozilla.org/logviewer.html#?job_id=33610663&repo=mozilla-inbound

https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&fromchange=aa4472559aa9a67310e5be2f697252c5db07bd14&bugfiler&group_state=expanded&noautoclassify&filter-searchStr=5f73dda72103e08f354253656a6c4d9cc9209929&selectedJob=33550126


Now, prior to this landing, the debug m(3) runtimes were up around 117 minutes, and this patch seems to have pushed it up over the 7200second (120minute) limit imposed on the chunk.
Depends on: 1294337
Depends on: 1294455
Given recent developments in bug 1281241 regarding ec2 instances and fixes made for bug 1294337, things look better on the intermittent timeout front.

As well, bug 594876 also makes us less sensitive to Cairo vs. Skia performance differences in our unit tests.

So going to do another try at pushing Skia content...
Depends on: 1281241
Flags: needinfo?(lsalzman)
See Also: → ogl-linux-beta
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d0910ce4cff8
enable Skia content for Linux and Android. r=mchang
https://hg.mozilla.org/mozilla-central/rev/d0910ce4cff8
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Duplicate of this bug: skia-android
Depends on: 1299089
Duplicate of this bug: 1281993
Blocks: 1350783
Depends on: 1465992
You need to log in before you can comment on or make changes to this bug.