OSX: Windows Media Plug-in fails on initialize

VERIFIED FIXED in Future

Status

()

P3
normal
VERIFIED FIXED
17 years ago
15 years ago

People

(Reporter: chrispetersen, Assigned: peterl-bugs)

Tracking

({topembed-})

Trunk
Future
PowerPC
macOS
topembed-
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT2 RTM][MS WMP ISSUE, NOT A MOZILLA ISSUE], URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Build: 2002-01-08-08
Platform: OS X
Expected Results: Windows media content should be played
What I got: Missing plugin icon is displayed on page

Steps to reproduce:

1) Install Windows Media Player for OS X (from microsoft's mactopia.com site)
2) Windows Media plugin installs in the Library/Internet Plugins folder
3) Launch Mozilla
4) Go to About Plugins under Help menu.
5) Notice Windows Media Plug-in is identified in window.
6) Go to a site like CNN to watch to windows media content.
7) Instead of content being play by the plug-in, the missing plug-in appears.

Comment 1

17 years ago
confirmed on 0108 trunk , OS X

Comment 2

17 years ago
-->peterl
Assignee: av → peterl
Summary: OSX: Windows Media Plug-in not recognized in browser → OSX: Windows Media Plug-in fails on initilize

Comment 3

17 years ago
Here's the problem. We load the new "Windows Media Player" plugin 
using the CFBundle APIs in our implementation of PR_FindSymbol(). 
However, the plugin is not a mach-o binary but a CFM/PEF binary, and it 
isn't exporting a |main| symbol. There are a couple of workarounds for 
this:

1. Microsoft changes the plugin and exports main for us.
2. We load the plugin using CFM calls, rather than CFBundle calls, and 
we'll likely be able to get the main entry point from our call to 
GetSharedLibrary().

This throws us a real curve. Apple's Quicktime plugin has the courtesy to 
export its |main| symbol.

There is one other possibility, the media player plugin does export  its 
plugin entry points:

       ------ Loader Export Symbol Table ------
            Section    Address       Class     [Hashword]    Export Name
003858 [ 0]    1       00005F34     TVector    [000EE0E5]    NPP_Initialize
003862 [ 1]    1       00005F0C     TVector    [000DF0F7]    NPP_NewStream
00386C [ 2]    1       00005EDC     TVector    [000FD76C]    
NPP_HandleEvent
003876 [ 3]    1       00005F24     TVector    [00071FFD]    NPP_New
003880 [ 4]    1       00005F14     TVector    [000DECBD]    NPP_SetWindow
00388A [ 5]    1       00005F04     TVector    [000EC23D]    NPP_WriteReady
003894 [ 6]    1       00005EF4     TVector    [0011F98B]    
NPP_DestroyStream
00389E [ 7]    1       00005F2C     TVector    [000CF77C]    NPP_Shutdown
0038A8 [ 8]    1       00005EE4     TVector    [00097E7C]    NPP_Print
0038B2 [ 9]    1       00005EFC     TVector    [00097E29]    NPP_Write
0038BC [10]    1       00005F1C     TVector    [000BFFDE]    NPP_Destroy
0038C6 [11]    1       00005ED4     TVector    [000DFC85]    NPP_URLNotify
0038D0 [12]    1       00005ECC     TVector    [0010D961]    
NPP_GetJavaClass
0038DA [13]    1       00005EEC     TVector    [00101E39]    
NPP_StreamAsFile

We could conceivably work around this problem by manually looking up 
these exported entry points, and filling NPPluginFuncs callbacks with the 
results.

Comment 4

17 years ago
Unbundling the plugin does allow it to load. Loading the CFM library to get 
the main entry point is starting to sound attractive.

Comment 5

17 years ago
Created attachment 64307 [details] [diff] [review]
Attempt to load entry points directly

This patch is an attempt to load the entry points directly if they are exported
from the plugin. However, it doesn't seem to work, because NPP_New() crashes. I
think their main routine is doing some initialization that isn't happening
otherwise.

Comment 6

17 years ago
Created attachment 64322 [details] [diff] [review]
Patch to prlink.c to load a bundle's main entry point using GetDiskFragment.

With this patch to NSPR in place, the "Windows Media Plugin" does load. The
patch loads a CFBundle's underlying CFM executable using GetDiskFragment. This
is a hack, but I know of no other way to do this.

Comment 7

17 years ago
Now that the plugin loads, it exposes another bug. If I attempt to load the 
following URL:

http://www.kqed.org/streamingfiles/kqed_wmp.asx

for some reason the plugin keeps attempting to launch the "Windows 
Media Player" application over and over. I have a feeling that we are 
handling some error condition the plugin is generating in an incorrect 
way.

Comment 8

17 years ago
-->beard 

That full-page problem could be related to:
http://bugscape.netscape.com/show_bug.cgi?id=11600

There is a patch in that bug that checks for the error that WMP (at least on
windows) returns. 
Assignee: peterl → beard
*** Bug 119582 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

17 years ago
Nominating for nsbeta1
Keywords: nsbeta1

Comment 11

17 years ago
nsbeta1+ as per adt triage, especially since it's for mac osX.  patrick, where
are you with this patch?
Keywords: nsbeta1 → mozilla1.0, nsbeta1+, patch
Target Milestone: --- → mozilla1.0

Comment 12

17 years ago
adding adt1 to status whiteboard as per discussion with beppe.  
Whiteboard: [ADT1]

Comment 13

17 years ago
*** Bug 133562 has been marked as a duplicate of this bug. ***
Nomiante topembed, and Mozilla1.0
Keywords: topembed

Comment 15

17 years ago
Created attachment 77989 [details]
Mozilla Crash Log

With patch in place, I get this crash when I attempt to load a video from this
URL:

http://www.cnn.com/SPECIALS/2001/trade.center/retal.video.11.html#1st

Updated

17 years ago
Keywords: topembed → topembed+
Changing to ADT1 RTM.
Summary: OSX: Windows Media Plug-in fails on initilize → OSX: Windows Media Plug-in fails on initialize
Whiteboard: [ADT1] → [ADT1 RTM]

Comment 17

17 years ago
*** Bug 140764 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
*** Bug 132107 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 143047

Comment 19

17 years ago
*** Bug 145919 has been marked as a duplicate of this bug. ***

Comment 20

17 years ago
I have confirmed that this bug is still active in the Mozilla 1.0.0+
Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0+) Gecko/20020522
release ... Windows Media player does not work, but Quicktime works fine

Comment 21

17 years ago
yeah , this has been added to the release notes.

Comment 22

17 years ago
*** Bug 147361 has been marked as a duplicate of this bug. ***

Comment 23

17 years ago
Has anyone verified whether this bug also occurs in Netscape 7.0?
I usually avoid sites which use the mediaPlayer, but will try Netscape.
Yes, I try with Netscape 7 and it is the same problem. Windows Media 
Player Plugin was not recognized and not work.
Blocks: 147782

Updated

17 years ago
Blocks: 145919

Comment 25

17 years ago
What's the current status of this bug?  Will we have a final patch before it's
too late?

Comment 26

17 years ago
The bug is due to Microsoft's implementation of the WMP plugin.  Since I have no
idea how one goes about directly evangelising M$ we've asked our Apple liason to
forward this bug to his counterpart that deals with M$.  No progress to report
there yet.

Updated

17 years ago
No longer blocks: 143047
Whiteboard: [ADT1 RTM] → [ADT2 RTM]

Comment 27

17 years ago
lowering the impact per discussion in the adt.

Comment 28

17 years ago
*** Bug 151421 has been marked as a duplicate of this bug. ***

Comment 29

17 years ago
*** Bug 152196 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Keywords: mozilla1.0

Comment 30

17 years ago
Brian, would you take a look at this?
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla1.0.1

Updated

17 years ago
Blocks: 164423

Updated

17 years ago
No longer blocks: 164423
*** Bug 164423 has been marked as a duplicate of this bug. ***
Plugin WMP still not work. There is no solution ? because Plugin WMP was necessary on 
many URL (I know that Microsoft's products are often very special !!!) ;-((

Comment 33

17 years ago
*** Bug 176071 has been marked as a duplicate of this bug. ***

Comment 34

17 years ago
--> peterl
Assignee: beard → peterl
Status: ASSIGNED → NEW

Comment 35

17 years ago
Just to reiterate for folks that didn't see beard's comment for the patch he
posted to try and load the WMP plugin - it still doesn't work right.  WMP works
in _no_ OS X browser but IE.  If you want that changed lobby M$ to fix their
plugin as us trying to hack around their non-standard plugin implementation for
WMP isn't the 'right' solution.
Keywords: patch

Comment 36

17 years ago
--->reassign to beppe
Microsoft needs evangelizism help to follow the NPAPI on OSX like all other plugins.
Assignee: peterl → beppe
Target Milestone: mozilla1.0.1 → ---

Comment 37

17 years ago
Is there any feedback Mozilla can provide to the user in these circumstances to
make it apparent that it's MS's fault, and not Mozilla's?

Updated

17 years ago
Priority: -- → P3
Whiteboard: [ADT2 RTM] → [ADT2 RTM][MS WMP ISSUE, NOT A MOZILLA ISSUE]
Target Milestone: --- → Future

Comment 38

17 years ago
http://wwwa.accuweather.com/adcbin/flavideo/video.asp?video=763126

Plugin doesn't load.  Windows Mediaplayer under build 2002101612.  It loads in
Explorer for X.   

Comment 39

17 years ago
Pardon my vernacular but no shit!  Do you think this bug would still be open if
it worked?

Comment 40

16 years ago
We are working with WMP folks to get it to work with NPAPI

This is not a mozilla bug, removing nsbeta1+ and topembed+
Keywords: nsbeta1+, topembed+ → nsbeta1-, topembed-

Comment 41

16 years ago
reassign
Assignee: beppe → peterl

Comment 42

16 years ago
*** Bug 186740 has been marked as a duplicate of this bug. ***

Comment 43

16 years ago
*** Bug 169745 has been marked as a duplicate of this bug. ***

Comment 44

16 years ago
I just noticed with Safari that it redirects the content to the Windows Media
Player application.  To test, go to News.com and click on one of those videos. 
You will notice that Safari notifies you that the plugin is not supported and
asks  you if you would like to play it externally.  Pretty interesting...

Comment 45

16 years ago
*** Bug 217947 has been marked as a duplicate of this bug. ***
*** Bug 160715 has been marked as a duplicate of this bug. ***

Comment 47

16 years ago
Good news; plugins now work with Windows Media Player version 9 for OS X.  A
quick test at http://www.msnbc.com/ confirms this with Mozilla 1.5 for Mac.

http://www.microsoft.com/windows/windowsmedia/software/macintosh/osx/default.aspx

Comment 48

15 years ago
Now that Microsoft released a Mozilla compatible version of the WMP plug-in this
bug is no longer valid.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Verified for plugindoc for OSX update
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.