Closed Bug 1202361 Opened 4 years ago Closed 4 years ago

[Stingray][fling-player][TV][2.5] (TV side) TV to receive video casted from Fennec

Categories

(Firefox OS Graveyard :: Gaia::TV::Fling, defect, P1)

defect

Tracking

(feature-b2g:2.5+)

RESOLVED FIXED
FxOS-S8 (02Oct)
feature-b2g 2.5+

People

(Reporter: rexboy, Assigned: Fischer)

References

Details

(Whiteboard: [ft:conndevices][partner-cherry-picked<2015/11/10>])

Attachments

(3 files)

We need to revise the fling player such that it works on our new presentation API use case. The working items includes:
1. Add spatial navigator.
2. Add control box which is able to play/stop the video.
3. The control box should sync its playing/stopping status with its remote sender.
Summary: [Stingray]Presentation API - Fling player → [Stingray]Presentation API - Video player
Summary: [Stingray]Presentation API - Video player → [Stingray]Cast video to TV
Summary: [Stingray]Cast video to TV → [Stingray]Cast video to TV (receiver side)
Assignee: nobody → fliu
Blocks: 1187844
feature-b2g: --- → 2.5+
Attached file PR #31905
Attachment #8662802 - Flags: review?(rexboy)
Duplicate of this bug: 1205990
Summary: [Stingray]Cast video to TV (receiver side) → [TV][2.5] (TV side) TV to receive video casted from Fennec
Target Milestone: --- → FxOS-S8 (02Oct)
Comment on attachment 8662802 [details] [review]
PR #31905

Overall it looks good to me, just with some style and typo errors.
But since the interface of Presentation API in Gecko has moved to newer version, we need to align to it before landing.
I'm still trying to make the updated Gecko build works :-/
I'll ping you once it's ready.

Thanks for your work!
Attachment #8662802 - Flags: review?(rexboy) → feedback+
Status: NEW → ASSIGNED
(In reply to KM Lee [:rexboy] from comment #4)
> Comment on attachment 8662802 [details] [review]
> PR #31905
> 
> Overall it looks good to me, just with some style and typo errors.
> But since the interface of Presentation API in Gecko has moved to newer
> version, we need to align to it before landing.
> I'm still trying to make the updated Gecko build works :-/
> I'll ping you once it's ready.
> 
> Thanks for your work!

Hi Rex,
Can you give us an update for the current status of the updated Gecko build? Can we get this done before Oct/2?
Flags: needinfo?(rexboy)
Flags: needinfo?(fliu)
Attached file PR #32120
Flags: needinfo?(fliu)
Attachment #8667689 - Flags: review?(rexboy)
Let's try to finish reviewing it this week.
Flags: needinfo?(rexboy)
Comment on attachment 8667689 [details] [review]
PR #32120

Looks good to me overall, most of them are just coding style issue. But since several places need to be changed, and I'm a little bit concerned about adding in-code behavior test in the main code. Please come to me if you need discussion. Please set r? to me again after you finished changes. 

Thank you!
Attachment #8667689 - Flags: review?(rexboy)
Attachment #8667689 - Flags: review?(rexboy)
Comment on attachment 8667689 [details] [review]
PR #32120

Looks good to me. Thank you!
Attachment #8667689 - Flags: review?(rexboy) → review+
There's a one jshint error, please be sure to fix it before merging.
Summary: [TV][2.5] (TV side) TV to receive video casted from Fennec → [Stingray][fling-player][TV][2.5] (TV side) TV to receive video casted from Fennec
Blocks: 1210694
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
Blocks: 1210700
Blocks: 1210702
Component: Gaia::TV → Gaia::TV::Fling
Blocks: 1215004
Blocks: 1216058
Blocks: 1217287
Blocks: 1217288
Blocks: 1219542
Blocks: 1220058
Blocks: 1222364
Whiteboard: [ft:conndevices][partner-cherry-pick] → [ft:conndevices][partner-cherry-picked<2015/11/10>]
Blocks: 1237532
No longer blocks: 1237532
Blocks: 1240493
No longer blocks: 1240493
You need to log in before you can comment on or make changes to this bug.