Closed Bug 1222364 Opened 9 years ago Closed 9 years ago

[Stingray][fling-player][TV][2.5] UI polish, behaviour updates and skip error message

Categories

(Firefox OS Graveyard :: Gaia::TV::Fling, defect, P1)

defect

Tracking

(blocking-b2g:2.5+, b2g-v2.5 fixed)

RESOLVED FIXED
blocking-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed

People

(Reporter: Fischer, Assigned: Fischer)

References

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick][partner-blocker])

Attachments

(2 files)

Implement the specs
* Show the controlling device's display name on the initial loading
* Keep the control panel showing when paused
Assignee: nobody → fliu
Update the specs
* Show the controlling device's display name on the initial loading
* Keep the control panel showing when paused
* Move focus back to the play button after the control panel is hidden for 60 secs
Attached file PR #33068
Attachment #8684861 - Flags: review?(rexboy)
No longer blocks: 1205999
Update the implemented:
* Show the controlling device's display name on the initial loading
* Keep the control panel showing when paused
* Move focus back to the play button after the control panel is hidden for 60 secs
* Go back to the very 1st video frame when video is ended

Other:
* Ignore invalid or unknown messages casted so the player still can work for valid messages
Comment on attachment 8684861 [details] [review]
PR #33068

It's overall good but a few questions. See my Github comment.
Attachment #8684861 - Flags: review?(rexboy)
Status: NEW → ASSIGNED
Flags: needinfo?(fliu)
Flags: needinfo?(fliu)
Summary: [Stingray][fling-player][TV][2.5] Implement for the specs updates → [Stingray][fling-player][TV][2.5] UI polish, behaviour updates and skip error message
Comment on attachment 8684861 [details] [review]
PR #33068

Please notice that the bu title has been changed: 
from Bug 1222364 - [Stingray][fling-player][TV][2.5] Implement for the specs updates
to Bug 1222364 - [Stingray][fling-player][TV][2.5] UI polish, behaviour updates and skip error message
Attachment #8684861 - Flags: review?(rexboy)
QA Whiteboard: COM=TV
blocking-b2g: --- → 2.5+
QA Whiteboard: COM=TV → [COM=TV Seamless Experience]
Comment on attachment 8684861 [details] [review]
PR #33068

r=me

Some changes needed. Please see my comments.
Attachment #8684861 - Flags: review?(rexboy) → review+
Hi Josh, this patch should be uplifted for TV 2.5. Thank you
Flags: needinfo?(jocheng)
Whiteboard: [ft:conndevices][partner-cherry-pick] → [ft:conndevices][partner-cherry-pick][partner-blocker]
Comment on attachment 8684851 [details] [review]
[gaia] Fischer-L:bug_1222364-ft-presentation-cast-video > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):1222364
[User impact] if declined: 
  1. The feature doesn't stay with the latest specs
  2. The app custom message protocol is not aligned with the Gecko side
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: Yes
Attachment #8684851 - Flags: approval-gaia-v2.5?
Comment on attachment 8684851 [details] [review]
[gaia] Fischer-L:bug_1222364-ft-presentation-cast-video > mozilla-b2g:master

Approve for TV 2.5 fling app
Flags: needinfo?(jocheng)
Attachment #8684851 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Blocks: 1237532
No longer blocks: 1237532
Blocks: 1240493
No longer blocks: 1240493
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: