Closed Bug 1212187 Opened 7 years ago Closed 7 years ago

Update browser IndexedDB to adapt synced data from bookmarks datastores

Categories

(Firefox OS Graveyard :: Gaia::TV::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
FxOS-S9 (16Oct)

People

(Reporter: yifan, Assigned: selee)

References

Details

(Whiteboard: [partner-cherry-picked<2015/11/10>])

Attachments

(1 file)

Ensure that the data from bookmarks and places datastores can be seamlessly merged into browser IndexedDB.
Assignee: nobody → yliao
Assignee: yliao → selee
Status: NEW → ASSIGNED
Summary: Update browser IndexedDB to adapt synced data from bookmarks and places datastores → Update browser IndexedDB to adapt synced data from bookmarks datastores
Blocks: fxos-sync
Target Milestone: --- → FxOS-S9 (16Oct)
Blocks: 1212716
Comment on attachment 8671980 [details] [review]
[gaia] weilonge:seanlee/TVBrowser/master/Bug1212187 > mozilla-b2g:master

Hey Yifan,

Could you help to review my patch? Thank you!
Attachment #8671980 - Flags: review?(yliao)
Comment on attachment 8671980 [details] [review]
[gaia] weilonge:seanlee/TVBrowser/master/Bug1212187 > mozilla-b2g:master

Clear yifan's review to refine the schema.
Attachment #8671980 - Flags: review?(yliao)
Comment on attachment 8671980 [details] [review]
[gaia] weilonge:seanlee/TVBrowser/master/Bug1212187 > mozilla-b2g:master

Hey Yifan, Could you help to review the patch? Thank you!
Attachment #8671980 - Flags: review?(yliao)
Comment on attachment 8671980 [details] [review]
[gaia] weilonge:seanlee/TVBrowser/master/Bug1212187 > mozilla-b2g:master

Thanks a lot for the effort! Please refer to the comments on Github.
Attachment #8671980 - Flags: review?(yliao)
Comment on attachment 8671980 [details] [review]
[gaia] weilonge:seanlee/TVBrowser/master/Bug1212187 > mozilla-b2g:master

Thanks Yifan! Let's do it one more round!
Attachment #8671980 - Flags: review?(yliao)
Attachment #8671980 - Flags: review?(yliao) → review+
Sorry folks, but we need unit tests for this code.

Could you file a follow up for that and prioritize it, please? We are likely going to be touching this code next week and we cannot afford any regressions due to the time constrains that we have right now.

There are already some that can be taken as a start at [1].

[1] https://github.com/mozilla-b2g/gaia/blob/master/tv_apps/browser/test/unit/browser_db_test.js
Flags: needinfo?(selee)
Blocks: 1215436
Let's do the test in this bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=1215436
Flags: needinfo?(selee)
Blocks: 1217349
Blocks: 1217352
Blocks: 1218303
Blocks: 1219108
Whiteboard: [partner-cherry-pick] → [partner-cherry-picked<2015/11/10>]
You need to log in before you can comment on or make changes to this bug.