Closed Bug 1194091 Opened 5 years ago Closed 4 years ago

[browser] Firefox Account sync bookmark

Categories

(Firefox OS Graveyard :: Gaia::TV, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.5+)

RESOLVED FIXED
FxOS-S10 (30Oct)
feature-b2g 2.5+

People

(Reporter: yifan, Assigned: danhuang)

References

Details

(Whiteboard: [ft:conndevices][partner-blocker][partner-cherry-pick])

Attachments

(7 files, 1 obsolete file)

Implement Firefox Account default syncing in TV browser.
Depends on: 1194092
No longer depends on: 1194092
Summary: [browser] Firefox Account sync default → [browser] Firefox Account sync bookmark
Depends on: 1194094
No longer depends on: 1194094
Depends on: 1194096
No longer depends on: 1194096
Depends on: 1194097
Depends on: 1194098
No longer depends on: 1194098
Depends on: TV_FxAccount
Blocks: TV_FxAccount
No longer depends on: TV_FxAccount
No longer blocks: 1187830
No longer blocks: 1187840
No longer blocks: 1187838
Blocks: TV_Pocket
No longer blocks: TV_Pocket
feature-b2g: --- → 2.5+
Whiteboard: [ft:conndevices][partner-blocker]
Blocks: 1202376
Depends on: 1203898
No longer depends on: 1203898
Depends on: 1207481
No longer depends on: 1207481
Depends on: 1207483
No longer depends on: 1207483
Depends on: 1207488
No longer depends on: 1207488
Depends on: 1207521
Depends on: 1210697
Depends on: 1212187
Target Milestone: --- → FxOS-S10 (30Oct)
Depends on: 1212716
Hi YiFan,
Will you or Dan take this bug? Thanks
Flags: needinfo?(yliao)
Assignee: nobody → yliao
Flags: needinfo?(yliao)
Depends on: 1215436
No longer depends on: 1212716
No longer depends on: 1194097
Priority: -- → P1
Assignee: yliao → dhuang
Depends on: 1194096
Depends on: 1215482
Blocks: 1216878
Depends on: 1217349
Comment on attachment 8677325 [details] [review]
[gaia] danhuang1202:1194091_Firefox_Account_sync_bookmark > mozilla-b2g:master

Hi Yi-fan, please help me to review. This patch shows bookmark data from firefox account. Thanks.
Attachment #8677325 - Flags: review?(yliao)
Comment on attachment 8677325 [details] [review]
[gaia] danhuang1202:1194091_Firefox_Account_sync_bookmark > mozilla-b2g:master

Thanks for the effort! Please see the comments.
Attachment #8677325 - Flags: review?(yliao) → review-
Comment on attachment 8677325 [details] [review]
[gaia] danhuang1202:1194091_Firefox_Account_sync_bookmark > mozilla-b2g:master

Thanks for the review. I just fix the comments you suggested. Please help to review again, thanks.
Attachment #8677325 - Flags: review- → review?(yliao)
Comment on attachment 8677325 [details] [review]
[gaia] danhuang1202:1194091_Firefox_Account_sync_bookmark > mozilla-b2g:master

Just a small nit. Good job! Thank you very much. Please squash the commits before merge.
Attachment #8677325 - Flags: review?(yliao) → review+
Thanks for the review on Saturday!
Merge in master: 
https://github.com/mozilla-b2g/gaia/commit/75cc4d96c05bf865c5f2b78a75edb8b9f437c58e
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Dan, the issue I reported you this morning has been resolved by bug 1218211, sorry for the false alarm.
Depends on: 1218701
Duplicate of this bug: 1207063
Whiteboard: [ft:conndevices][partner-blocker] → [ft:conndevices][partner-blocker][partner-cherry-pick]
You need to log in before you can comment on or make changes to this bug.