Closed Bug 1220588 Opened 6 years ago Closed 6 years ago

[TV] FTE for usage matrics

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, feature-b2g:2.5+, b2g-v2.5 fixed)

RESOLVED FIXED
blocking-b2g 2.5+
feature-b2g 2.5+
Tracking Status
b2g-v2.5 --- fixed

People

(Reporter: rexboy, Assigned: Fischer)

References

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick][partner-blocker])

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1220584 +++

This bug should implement FTE for usage matrics.

UX spec is currently on-going in bug 1199313.
Blocks: TV_FTE
No longer blocks: 1205944
Blocks: 1223346
No longer blocks: 1223346
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
Assignee: nobody → fliu
No longer blocks: 1225847
Attached file PR #33286
Attachment #8689869 - Flags: review?(rexboy)
Comment on attachment 8689869 [details] [review]
PR #33286

See my comments.
Attachment #8689869 - Flags: review?(rexboy)
Status: NEW → ASSIGNED
feature-b2g: --- → 2.5+
Comment on attachment 8689869 [details] [review]
PR #33286

The updates:
* Focus on the terms section on load
* Add one downward arrow icon to guide user scroll down the terms
* Show the default scroll bar when scrolling the terms and no frame or outline effect when focusing on the terms
* Hide the downward arrow icon when scrolling down to the end of the terms
* Use Simple Navigation to resolve the navigation issue on the small screen
Attachment #8689869 - Flags: review?(rexboy)
Comment on attachment 8689869 [details] [review]
PR #33286

r+ but see my comments. Please correct them before landing.
I would suggest you to scan your patch by yourself once before sending review, if you didn't do that before. Also take care of your variable naming, avoid misleading names.
Attachment #8689869 - Flags: review?(rexboy) → review+
Whiteboard: [ft:conndevices][partner-cherry-pick] → [ft:conndevices][partner-cherry-pick][partner-blocker]
Comment on attachment 8689868 [details] [review]
[gaia] Fischer-L:bug_1220588-FTE-for-usage-metrics > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1220588
[User impact] if declined: The user will not be able to chose whether to send data to Firefox or not.
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: No
Attachment #8689868 - Flags: approval-gaia-v2.5?
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
Comment on attachment 8689868 [details] [review]
[gaia] Fischer-L:bug_1220588-FTE-for-usage-metrics > mozilla-b2g:master

Approve for TV FTE
Attachment #8689868 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
blocking-b2g: 2.5? → 2.5+
Blocks: 1232584
You need to log in before you can comment on or make changes to this bug.