remove no-undef from .eslintrc.xpcshell

RESOLVED FIXED in Firefox 62

Status

defect
P3
normal
RESOLVED FIXED
4 years ago
11 months ago

People

(Reporter: tromey, Assigned: standard8)

Tracking

(Blocks 1 bug)

unspecified
Firefox 62
Dependency tree / graph

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
Now that the head.js importer has landed, it seems like it should
be possible to remove the "no-undef" rule from devtools/.eslintrc.xpcshell
Note that the head.js global importer is broken for some versions of eslint. I'm fixing it here: bug 1230093.
I agree that we need to remove the no-undef: 0 from this config file.
Reporter

Updated

3 years ago
Depends on: 1240163
Priority: -- → P3
Assignee

Updated

a year ago
Depends on: 1443661
Assignee

Updated

a year ago
Depends on: 1447944
Assignee

Updated

a year ago
Depends on: 1451378
Assignee

Comment 2

a year ago
After bug 1451378, there's just two more test directories to do. I'm hoping to take them on soon.
Assignee: nobody → standard8
Assignee

Updated

a year ago
Depends on: 1455581
Assignee

Updated

a year ago
Blocks: 1456634
Assignee

Updated

a year ago
Depends on: 1456755

Updated

11 months ago
Product: Firefox → DevTools
Assignee

Comment 3

11 months ago
The final part of this depends on bug 1456762, for which I've got a patch in the review queue.
Depends on: 1456762
Comment hidden (mozreview-request)
Duplicate of this bug: 1467770

Comment 6

11 months ago
mozreview-review
Comment on attachment 8985909 [details]
Bug 1230193 - Finish enabling ESLint rule no-undef for devtools/.

https://reviewboard.mozilla.org/r/251398/#review257860

Looks good, thanks! 

For info, I logged a few devtools/eslint bugs to remove the remaining overrides: https://bugzilla.mozilla.org/show_bug.cgi?id=1467767 
If there are other existing bugs that might be duplicates of those, could you point me to them?
Attachment #8985909 - Flags: review?(jdescottes) → review+

Comment 7

11 months ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ef2cc1caddb
Finish enabling ESLint rule no-undef for devtools/. r=jdescottes

Comment 8

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4ef2cc1caddb
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
You need to log in before you can comment on or make changes to this bug.