Status

SeaMonkey
UI Design
P3
enhancement
RESOLVED WONTFIX
19 years ago
7 years ago

People

(Reporter: CodeMachine, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

({helpwanted})

Trunk
Future
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
This is a request to be able to annotate web pages.  It is similar to "digital
graffiti" programs like "Third Voice", but solely on a _personal_ basis.

I suggest this should take the form of a popup, and not allow changes to the
page, although I have read suggestions about allowing presentational changes
like underlining.

Updated

19 years ago
Summary: Page annotations. → [RFE] Page annotations
Target Milestone: M14

Comment 1

19 years ago
Move to M20.

Comment 2

18 years ago
Move to "Future" milestone.
Target Milestone: M20 → Future
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 4

18 years ago
nav triage team:

Neat, but a minus, marking nsbeta1-
Keywords: nsbeta1-

Updated

18 years ago
QA Contact: don → sairuh

Comment 5

18 years ago
-> aaron, cc evaughan
Assignee: vishy → aaronl

Comment 6

18 years ago
Just to point out the W3C Annotation project at http://www.w3.org/2001/Annotea/ .
The W3C Amaya browser allows annotations to be stored either locally or on an
appropriate server.
This kind of thing can be done quite easily with XLink and XPointer (for XML
documents, at least). Adding dependencies.
Depends on: 32832, 61664

Comment 8

17 years ago
Annotea client for Mozilla under development at http://annozilla.mozdev.org
Matthew, I had a look at the Annonzilla space at mozdev. I did not look at the
code, though. Could you give me (us?) a little explanation of the technology? A
little overall architecture would be nice, and I would be insterested to learn
how you actually attach the annotation markers to the document.

I suspect you attach the markers via DOM (i.e. change the DOM), which can lead
to problems with stylesheets and scripts. But please let me know...

Comment 10

17 years ago
-> Assigning back to reporter.
Assignee: aaronl → matty
(Reporter)

Comment 11

17 years ago
This is not for me - I do Bugzilla work not Mozilla work.
Assignee: matty → nobody
Keywords: helpwanted
Who's in charge of the Mozilla Annotation project? I'll move this to my future
list for now...
Assignee: nobody → heikki

Comment 13

17 years ago
>I suspect you attach the markers via DOM (i.e. change the DOM), which can lead
>to problems with stylesheets and scripts. But please let me know...

That's right - I couldn't see any other way of displaying the markers. As you
point out, this has serious disadvantages, so it can be switched off.

Comment 14

16 years ago
*** Bug 153910 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: [RFE] Page annotations → Page annotations

Comment 15

16 years ago
*** Bug 178741 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
*** Bug 218193 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
IMHO those "duplicates" are not actually duplicates. 
They have different suggestions (please read).

But I agree there should be Add-on for them instead of mozilla-base extending.

Comment 18

14 years ago
*** Bug 257049 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite

Comment 19

13 years ago
I got an email 29 December saying that Bug 61664 (which this bug depends on) has been marked WONTFIX.

How does that affect this bug?

Comment 20

7 years ago
> Bug 61664 (which this bug depends on) has been marked WONTFIX.

This is extension Fodder. In fact there have been several extensions over the years usually as part of some social network site. EXTENSION FODDER=>WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.