Dragging element leaves traces

RESOLVED FIXED in Firefox 47

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Oriol, Assigned: mattwoodrow)

Tracking

({regression, testcase})

47 Branch
mozilla47
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 unaffected, firefox46 unaffected, firefox47+ fixed)

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8712709 [details]
screenshot

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160126030244

Steps to reproduce:

1. Go to http://live.yworks.com/yfiles-for-html/1.3/demos/complete/demo.yfiles.graph.bpmneditor/index.html
2. Mousedown some blue area of the diagram
3. Move the mouse to drag the diagram



Actual results:

The diagram leaves traces.


Expected results:

It shouldn't leave traces.

Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c525c516&tochange=c99e8abb

So the cause is bug 1231538 or bug 1221842. I suspect it's the later.
(Reporter)

Updated

3 years ago
Blocks: 1221842
Keywords: regression
Flags: needinfo?(matt.woodrow)
(Assignee)

Comment 1

3 years ago
Created attachment 8712957 [details] [diff] [review]
Always compare geometries

Previously we skipped comparing geometry objects for item types that created layers as they would be handled by the layer tree comparison and there was no need to invalidate twice.

With the caching however it means that we think we can reuse the old geometry object even though it might be out of date.

When we come to an invalidation that does require the geometry object (removing the item from the layer), the bounds are out of date and we invalidate incorrectly.
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Attachment #8712957 - Flags: review?(roc)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1243181
Duplicate of this bug: 1243447
Comment on attachment 8712957 [details] [diff] [review]
Always compare geometries

Review of attachment 8712957 [details] [diff] [review]:
-----------------------------------------------------------------

Testcase?
Attachment #8712957 - Flags: review?(roc) → review+

Updated

3 years ago
status-firefox47: --- → affected
tracking-firefox47: --- → ?
Version: unspecified → 47 Branch
(Reporter)

Comment 5

3 years ago
Created attachment 8715108 [details]
testcase
Matt is 46 impacted by this bug?
Flags: needinfo?(matt.woodrow)
[Tracking Requested - why for this release]:
status-firefox46: --- → ?
tracking-firefox47: ? → +

Comment 8

3 years ago
Only FF47 is affected.

Updated

3 years ago
Status: UNCONFIRMED → NEW
status-firefox45: --- → unaffected
status-firefox46: ? → unaffected
Ever confirmed: true
Keywords: testcase
(Reporter)

Comment 9

3 years ago
The patch has review+ and fixes my testcase. Why has it not been implemented already?

Comment 10

3 years ago
(In reply to Oriol from comment #9)
> The patch has review+ and fixes my testcase. Why has it not been implemented
> already?

https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/How_to_Submit_a_Patch#Getting_the_patch_checked_into_the_tree
(In reply to Oriol from comment #9)
> The patch has review+ and fixes my testcase. Why has it not been implemented already?

Right, Matt hasn't landed the patch yet -- my guess is that's because he's working on making an automated testcase, in response to comment 4 (which our infrastructure can use to verify whether the bug is fixed, and make sure it doesn't break again). (and he's got other stuff on his plate, too)

This bug is already tagged as needinfo=matt.woodrow, so it's on his queue of things to do. Hopefully he'll be able to get to it soon! :)

(In reply to YF (Yang) from comment #10)
> https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/How_to_Submit_a_Patch#Getting_the_patch_checked_into_the_tree

(This MDN link mostly describes the "checkin-needed" keyword, which isn't appropriate here, until/unless Matt says his patch is ready to land.)
(Your testcase in comment 5 may provide most of what's needed for an automated testcase; I'm not sure. Anyway, Matt can comment more.)
(Assignee)

Comment 13

3 years ago
Created attachment 8717286 [details] [diff] [review]
Always compare geometries

The previous version was failing existing automated tests and couldn't be landed.

This new version passes all existing tests, and adds a new one (using the provided testcase).
Attachment #8712957 - Attachment is obsolete: true
Flags: needinfo?(matt.woodrow)
Attachment #8717286 - Flags: review?(roc)

Comment 15

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ea6fa3f97f98
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox47: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
You need to log in before you can comment on or make changes to this bug.