Last Comment Bug 125168 - Plugins need ability to be disabled on a per window basis
: Plugins need ability to be disabled on a per window basis
Status: RESOLVED WORKSFORME
[PL:BRANCH][Plug-in Mgr]
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
: P4 enhancement with 23 votes (vote)
: mozilla1.4beta
Assigned To: av (gone)
:
Mentors:
: 151563 156708 179897 248534 (view as bug list)
Depends on: 144263
Blocks: 88956
  Show dependency treegraph
 
Reported: 2002-02-12 23:28 PST by Judson Valeski
Modified: 2013-09-25 11:49 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Judson Valeski 2002-02-12 23:28:04 PST
There are various windows that want to disable the use of plugins within their
context. An example of this is Composer windows (see
http://bugzilla.mozilla.org/show_bug.cgi?id=88956 ).

We currently provide per window functionality toggling via nsIWebBrowserSetup.
We then use nsIContentPolicy at callsites to determine whether or not a "load"
should proceed. What should probably happen here is that the plugin code queries
the content policy via ::ShouldLoad() before loading a plugin. If yes, continue
w/ the load, if no, "stop" loading (presumably though not much "loading" has
occurred already though and this happens at init time).
Comment 1 rubydoo123 2002-06-13 11:41:51 PDT
*** Bug 151563 has been marked as a duplicate of this bug. ***
Comment 2 alanjstr 2002-06-27 10:04:47 PDT
Does this mean I would be able to have a preference to temporarily turn off
certain plugins, such as Flash?  For example, say I wanted to disable Flash for
a while so that I'm not bombarded with ads.  But then I want to visit a Flash
enabled site.  

Perhaps the placeholder could say "Get this plugin" or "Enable this plugin"
depending.

Or should I do an RFE for that?
Comment 3 Alfonso Martinez 2002-07-10 11:17:42 PDT
*** Bug 156708 has been marked as a duplicate of this bug. ***
Comment 4 rubydoo123 2002-07-10 14:58:33 PDT
The plug-ins triage team (av, beppe, peterl, serge and shrir) have reviewed this
issue and have made the following determination:

This is dependent upon the Plug-in Mgr work, marking dependency
Comment 5 Brant Gurganus 2002-10-13 11:23:02 PDT
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Comment 6 Leston Buell 2002-10-19 17:45:48 PDT
Could we please change "platform" and "OS" to "all"? 
Comment 7 Tom Jac 2002-11-05 12:02:44 PST
Comment: in future it could be important to disable some plugins for safety:
I mean the WINE based windows plugins (Crossover) f.i. Quicktime.
It should be possible to disable most of the plugins and somtimes to enable
someone on secure sites.
Comment 8 R.K.Aa. 2002-11-13 03:57:37 PST
*** Bug 179897 has been marked as a duplicate of this bug. ***
Comment 9 Damian Yerrick 2002-11-24 21:50:57 PST
"RFE" in summary is deprecated in favor of severity: enhancement
Comment 10 rubydoo123 2002-12-06 15:16:26 PST
moving to 1.4 beta, plug-in branch work
Comment 11 Albert Tumanov 2002-12-07 00:13:58 PST
It would be best if the user could enable/disable running of Flush plugins
just like it's possible for images (on per site basis).
Comment 12 Pavel Roskin 2003-06-05 12:49:50 PDT
I believe it's a duplicate of bug 94035, which has 320 votes and 138 comments as
I'm writing this.
Comment 13 Damian Yerrick 2003-06-05 13:12:21 PDT
Bug 94035 concerns blocking plug-ins by site; this is about turning
off plug-ins by window.  It's probably not a dupe, but it could be a
WONTFIX if the powers that be decide to approach blocking plug-ins
by fixing 94035 instead of this.
Comment 14 Moiz Dohadwala 2003-09-08 09:16:16 PDT
A feature to disable plug-ins on a per-site basis would be greatly appreciated,
this would save me from being bombarded by Flash ads and also allow me to watch
Flash-enabled sites.
Comment 15 R.K.Aa. 2004-06-24 13:53:15 PDT
*** Bug 248534 has been marked as a duplicate of this bug. ***
Comment 16 Philip walden 2004-10-14 09:22:27 PDT
Actually, my interest in this capability is completely eliminated with the
adblock extension. I would suggest directing folks to try adblock and closing
this bug.
Comment 17 Albert Tumanov 2004-10-14 21:39:42 PDT
Same here.
Comment 18 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2013-02-12 14:50:02 PST
You can disable plugin per-docshell.

Note You need to log in before you can comment on or make changes to this bug.