Closed Bug 12808 Opened 20 years ago Closed 20 years ago

[BLOCKER] [PP] Clicking in gfx text field crashes

Categories

(Core :: Editor, defect, P2, critical)

x86
Linux
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: akkzilla, Assigned: mjudge)

References

()

Details

With gfx text widgets on ( user_pref("nglayout.compatibility.mode", 1); ),
whenever I click in any text field, I get an immediate crash, in

#0  0x40e21f08 in nsBlockFrame::HandleEvent (this=0x8684680,
    aPresContext=@0x8653a50, aEvent=0xbffff3cc, aEventStatus=@0xbffff340)
    at nsBlockFrame.cpp:5493

This is:
5493          returnFrame->GetOffsetFromView(offsetPoint, &view);

returnFrame and view seem to be valid pointers.  offsetPoint is {x = 141021720,
y = 1088506184} -- are those numbers unusually high?
Blocks: 12679
Priority: P3 → P1
gfx text widgets is "nglayout.compatibility.mode", 2
There's a pref UI for this in apprunner now, in addition
to the menu item that viewer has.

raising priority, this is a big gfx widget problem.
I've been running with gfx text controls all day today with code from 8:30am
this morning, no crashes clicking on them.  Looks like it's linux only.
offsetPoint is in twips, but the numbers are ridiculous.  I would guess an
uninitialized variable?  Akkana, could you dig a little deeper into this?  Maybe
get Mike involved, I think it's his code.
Assignee: buster → akkana
Summary: Clicking in gfx text field crashes → [BLOCKER] [PP] Clicking in gfx text field crashes
Target Milestone: M10
hmmm...I think the value of offsetPoint is irrelevant, it's an out param that
should get filled during the call to GetOffsetFromView.  The second param is an
out param as well.  I'd check out nsFrame::GetOffsetFromView.  It doesn't seem
that any of the other frame classes override this method.
Priority: P1 → P2
Assignee: akkana → mjudge
Mike and I looked at it, and he's comparing on Windows now to see what the
values should be.  Reassigning (but he and I will work on finding a solution).
Blocks: 6262
Blocks: 12902
http://bugzilla.mozilla.org/show_bug.cgi?id=12899
says that this crashes Win32.
*** Bug 12899 has been marked as a duplicate of this bug. ***
This is workingforme, marking so.
Reopen if this is still a problem.
I works today, but no cursor shows up.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
worksforme.

simon's got another bug on the cursor problem.
Status: RESOLVED → VERIFIED
verified in 9/8 build.
You need to log in before you can comment on or make changes to this bug.