Closed Bug 1287255 Opened 3 years ago Closed 3 years ago

Drag and Drop Bookmark from Location bar to Bookmarks Toolbar or sidebar Bookmark Panel fails

Categories

(SeaMonkey :: Bookmarks & History, defect, major)

SeaMonkey 2.45 Branch
Unspecified
All
defect
Not set
major

Tracking

(seamonkey2.45 affected)

RESOLVED DUPLICATE of bug 1272401
Tracking Status
seamonkey2.45 --- affected

People

(Reporter: RainerBielefeldNG, Unassigned)

Details

(Whiteboard: [easyconfirm])

Steps how to reproduce with  English SeaMonkey 2.45  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160710233343  (Default Classic Theme)  on German WIN7 64bit:

1. Launch Browser (new session) → Open some TABs from Bookmarks in Sidebar
2. Click on Icon left  from URL in Location bar (suspicious: grey default
   icon instead of favicon icon, mouse pointer will not change to "hand")
    → drag and drop to Sidebar Bookmarks Panel or Bookmarks Toolbar
   Expected: Bookmark will be added
   Actual: Bookmark not added

Additional information
a) Also reproducible when I reopen old 2.45 Browser session with
   English SeaMonkey 2.47a1  (NT 6.1; Win64; x64; rv:50.0)  
   Gecko/20100101 Firefox/50.0 Build 20160712001326  
   (Default Classic Theme)  on German WIN7 64bit:
   Suspicious grey icon and drag and drop fails
a1) after click on /Reload/-Icon favicon icon appears in location 
    toolbar and drag and drop will be possible
b) I doubt that this one is related to "Bug 1261685 - 
   All Bookmarks functionality broken due to Toolkit Bug 1257599 
   which renamed 'Unsorted Bookmarks' into 'Other Bookmarks"
c) Related to "Bug 1287078 - Location Bar contents not updated when 
   opening new page in the same TAB by link, History or bookmark "?
d) This one looks like a 2.45 blocker?
(In reply to Rainer Bielefeld from comment #0)
> 1. Launch Browser (new session) → Open some TABs from Bookmarks in Sidebar
> 2. Click on Icon left  from URL in Location bar (suspicious: grey default
>    icon instead of favicon icon, mouse pointer will not change to "hand")
>     → drag and drop to Sidebar Bookmarks Panel or Bookmarks Toolbar
>    Expected: Bookmark will be added
>    Actual: Bookmark not added

I can confirm that with my Linux 64 bit build 20160619142420.

> d) This one looks like a 2.45 blocker?

Nope - it's not a nice bug, but there is an easy workaround: just drop the tab from the tab-bar

BTW. Bug 1287078 *is* a real release blocker.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Works for me. Please try the 2.45 I provided and see if this one works. It's a 99% probability that it is bug 1272401.

User agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0 SeaMonkey/2.45
Build identifier: 20160716000033
(In reply to Rainer Bielefeld from comment #0)
> Nope - it's not a nice bug, but there is an easy workaround

the bug is embarrassing, I would not proceed publishing due to Bug 1234116 with this ein it, especially because it seems improbable that we can get a hint into the official release notes additionally to the unofficial ones. But I hope that we will get a fix into 2.45, see (f).

e) Was still ok with  English SeaMonkey 2.45a1
   (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 
   Firefox/48.0 Build 20160308001946  (Default Classic Theme) 
   on German WIN7 64bit
f) Due to  Frank-Rainer Grahl in Bug 1286373 comment #11 This one is related to / 
   DUP of Bug 1272401 - Port Firefox Bug 1241085 Parts 2 and 3, and maybe 4 
   This should fix SeaMonkey Bug 1270848 - Back and Forward buttons unavailable 
   See also  1272401 for now(In reply to Adrian Kalla [:adriank] from comment #1)
See Also: → 1272401
(In reply to Frank-Rainer Grahl from comment #2)
> Please try the 2.45 I provided and see if this one works. 

Download from where?
>> Download from where?

There was a 2.45 in the last zip. I can provide a new one today if you like. Just send me an email then. 

2.44 is not affected so no problem for a release right now.
> There was a 2.45 in the last zip. 
I will test that one, wait a minute!
(In reply to Frank-Rainer Grahl from comment #5)
Yes, your 
  SM Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0   
  SeaMonkey/2.45 Build-Identifikator: 20160628141709
works fine. 

But Build ID is before 20160710233343, so that proves nothing for me, could mean that the problem appeared after Build 20160710233343
Summary: Drag and Dop Bookmark from Location bar to Bookmarks Toolbar or sidebar Bookmark Panel fails → Drag and Drop Bookmark from Location bar to Bookmarks Toolbar or sidebar Bookmark Panel fails
>> But Build ID is before 20160710233343, so that proves nothing for me, could mean that the 
>> problem appeared after Build 20160710233343

Yeah if you are the suspicious type :) I will send you the link to an updated zip later via email.

FRG
Work fine for me with  English SeaMonkey 2.45a1   (unofficial by frg)   (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160716124751  (Default Classic Theme)  on German WIN7 64bit.

That underpins frg's suspect concerning DUP.

I will do tests after fix for Bug 1272401 will have been integrated.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
See Also: 1272401
Duplicate of bug: 1272401
>> English SeaMonkey 2.45a1 

It's no longer 2.45a1 just 2.45 :) Current a1 is 2.47a1.
You need to log in before you can comment on or make changes to this bug.