Closed Bug 1297198 Opened 4 years ago Closed 3 years ago

platform.ini incorrectly points at c-c revisions not m-c revisions

Categories

(Thunderbird :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1298719

People

(Reporter: aleth, Unassigned)

References

Details

Fallout from Bug 1247162. See bug 1267270 comment 24 and following.

While this is obviously wrong, it's currently unclear if it actually breaks anything.
(In reply to aleth [:aleth] from comment #0)
> Fallout from Bug 1247162. See bug 1267270 comment 24 and following.
> 
> While this is obviously wrong, it's currently unclear if it actually breaks
> anything.

IIUC, the app works just the same with or without this bug, _except_ that if a bug is found that comes from Core or Toolkit the user or even the developer, no matter how experienced, will be unable to find out the m-c CSID range from a regression window, which will be expressed exclusively as Build IDs and/or c-c CSIDs — unless maybe the build logs for the "last good" and  "first bad" can be found, and I don't expect build logs to be kept long enough for that.
Duplicate of this bug: 1300030
I suspect it also breaks source packaging.
(In reply to aleth [:aleth] from comment #0)
> Fallout from Bug 1247162. See bug 1267270 comment 24 and following.
> 
> While this is obviously wrong, it's currently unclear if it actually breaks
> anything.

Sure, it breaks the l10n nightly builds since it now expects to update
the mozilla-central source to the comm-central cset.  (re: bug 1304285
for SeaMonkey)
Blocks: 1304285
sorry for the confirmation of what you know already... my head's just
spinning on the number of bustages for l10n alone..
(In reply to Edmund Wong (:ewong) from comment #5)
> sorry for the confirmation of what you know already... my head's just
> spinning on the number of bustages for l10n alone..

Thanks, it's good to collect all known instances where this makes problems here (that's what this bug is for), since fixing it will probably require making an argument for m-c changes that are not required for Fx.

Re l10n, definitely... c-c and c-a are still running into the tooltool issue in bug 1267523 on Linux/Win, despite the disable-compile-environment.
would anyone object if I duped this bug against bug 1298719 and
changed that bug to MailNews::BuildConfig?
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1298719
Blocks: 1267523
You need to log in before you can comment on or make changes to this bug.