Closed Bug 1306555 Opened 5 years ago Closed 5 years ago

Confirm we can remove MOZ_WIDGET_GONK from Mozilla Central and do so if possible

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1306391

People

(Reporter: emceeaich, Unassigned)

References

(Blocks 1 open bug, )

Details

MOZ_WIDGET_GONK is referenced 761 times in mozilla_central, https://dxr.mozilla.org/mozilla-central/search?q=MOZ_WIDGET_GONK&redirect=false 

Since we are removing the B2G code from that repo, please confirm that it is safe to remove this and if so, do it.
I would like to know what the status is for the widget/gonk/ code.
Jet, can we remove widget/gonk/ and all #ifdef MOZ_WIDGET_GONK code from the repo now?
Can you escalate if you don't know?  Thanks.

(I assumed it was still supported, so I added new #ifdef MOZ_WIDGET_GONK in bug 605985,
but dholbert's review comment suggests it's not supported.)
Flags: needinfo?(bugs)
(nevermind, I landed bug 605985 including #ifdef MOZ_WIDGET_GONK)
Flags: needinfo?(bugs)
(In reply to Mats Palmgren (:mats) from comment #2)
> can we remove widget/gonk/ and all #ifdef MOZ_WIDGET_GONK code from the repo now?

Bug 1355752 is removing the #ifdefs in layout, it seems.
See Also: → 1355752
Removing gonk would fix bug 1334543 too.
Bug 1355752 comment 25 confirms that we can remove MOZ_WIDGET_GONK, and bug 1357323 removed support for it from the build system as well as a number of gonk-only directories.

So the only question now is whether this bug is worth leaving open as a tracking bug. Other bugs removing Gonk widget support have been made to block the nukeb2g bug, though (bug 1306391). So perhaps we should just close this. Emma, what do you think?
Flags: needinfo?(ehumphries)
If it's being tracked elsewhere, this is okay to close.
Flags: needinfo?(ehumphries)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: nukeb2g
No longer blocks: 1369194
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.