Site identity icon is almost invisible on dark DevEdition theme in private browsing

VERIFIED FIXED in Firefox 53

Status

()

P3
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: cornel_ionce, Unassigned)

Tracking

({regression})

Trunk
Firefox 53
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 wontfix, firefox52 wontfix, firefox53 verified)

Details

(Whiteboard: fixed by bug 854126)

[Affected versions]:
- latest 52.0a1 Nightly
- latest 51.0a2 Aurora

[Affected platforms]:
- Windows 10 x64
- Mac OS X 10.11
- Ubuntu 14.04 x86

[Steps to reproduce]:
1. Open Firefox.
2. Set Dark DevEdition theme (if not set already).
3. Enter PB mode and navigate to any site.
4. Observe the site identity icon.

[Expected result]:
The site identity icon is properly displayed.

[Actual result]:
The site identity icon is barely visible.

[Regression range]:
See bug 1301945#c2 for the regression range.

[Additional notes]:
In bug 1301945 this was fixed only for normal browsing.

Updated

2 years ago
Duplicate of this bug: 1309822
Keywords: regression
Priority: -- → P3
Panos, are we OK shipping with this?
Flags: needinfo?(past)
This seems more serious than P3 to me, but I wonder what Dao had in mind when he marked it as P3. Do we have a plan for what needs to be done here? Perhaps use var(--chrome-color) for the icons?
Flags: needinfo?(past) → needinfo?(dao+bmo)
P3 because release isn't affected and devedition x private browsing is probably a fairly small population.

Also, the underlying problem seems to be older: Private browsing disables lightweight themes but we're somehow still applying the devedition theme -- without it being exposed as a lightweight theme to theme code, i.e. the :-moz-lwtheme selector stops working.
Flags: needinfo?(dao+bmo)
See Also: → bug 1229694, bug 1310421

Comment 6

2 years ago
We could avoid including the devedition stylesheet for private windows, but then you'd just get the default theme in private windows, which I'm not sure is really the desired behaviour here either.
Thanks, marking as fix-optional since it is a problem we have lived with for a while now.
status-firefox51: affected → fix-optional
status-firefox52: affected → fix-optional
Depends on: 854126

Updated

2 years ago
status-firefox53: --- → affected
status-firefox51: fix-optional → wontfix
status-firefox52: fix-optional → wontfix
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: affected → fixed
Resolution: --- → FIXED
Whiteboard: fixed by bug 854126
Target Milestone: --- → Firefox 53

Updated

2 years ago
status-firefox53: fixed → verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.