need to figure out why the cursor isn't showing up in text fields with gtk2

RESOLVED DUPLICATE of bug 153805

Status

()

RESOLVED DUPLICATE of bug 153805
17 years ago
16 years ago

People

(Reporter: blizzard, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
There's something funky going on with activate events.  Cursors aren't showing
up with gtk2 anymore.  You have to take focus away from the toplevel and put it
back to get the cursor.
(Assignee)

Updated

17 years ago
Blocks: 92033

Comment 1

17 years ago
this sounds like bug 130418 or bug 130542; is this really  platform specific?
(Assignee)

Comment 2

17 years ago
Might be, I'm not sure.

Comment 3

17 years ago
I think I'm seeing this as well - it could be the same as (or related to) bug
143777.

The problem shows up on Win2K with build 2002051006 (1.0rc2).

Load the Bugzilla helper page
http://www.mozilla.org/quality/help/bugzilla-helper.html

Tab into a multiline text entry block - the cursor will disappear until you move
the cursor over a scroll bar.  Actually, just the "grabber" in the scroll bar. 
If you mouse over any other part of the scroll bar, the cursor does not appear.

Comment 4

17 years ago
I have noticed this too in 1.0rc2 and 1.0rc3 on windows XP and windows 2000. I
can't reproduce it reliably but sometimes after I open a new window, I'm unable
to get a cursor in textfields such as the address bar or the googlebar (from
mozdev.org). I click in the text area but no cursor appears. In addition when
typing no text appears (maybe its a focus issue?).

Comment 5

17 years ago
Jilles, maybe you're experiencing bug 145567. A workaround for that is to paste
a URL into the address bar and press enter; after that, functionality returns.

Comment 6

16 years ago
Is it a dup of bug 153805?
(Assignee)

Comment 7

16 years ago
Yeah, I think so.

*** This bug has been marked as a duplicate of 153805 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.