Decouple Firefox Puppeteer from Firefox UI harness

RESOLVED FIXED

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

(Blocks 1 bug)

Version 3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

We would like to remove the strict dependency for Puppeteer from the Firefox UI harness. To achieve that a couple of steps would have to be done:

1. Move most useful APIs and helpers to Marionette client or server

2. Make usage of Puppeteer optional in the BaseFirefoxTestCase and update all tests according to that.

Before we can get started on 2) all dependencies for 1) have to be fixed. I will file appropriate bugs and mark them blocking this bug.
Depends on: 1311676
Duplicate of this bug: 1271804
Depends on: 1313312
Depends on: 1316851
All dependencies have been fixed and I do not see anything else upcoming. Also the package dependencies for firefox-ui-harness is gone and the package only depends on marionette-client. As such I want to get the puppeteer code moved from testing/puppeteer to testing/marionette/puppeteer over on bug 1319705 now.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.