Stop updating Nightly 53 on Windows XP, Windows 2003, Windows Vista, and Windows 2008 without R2

RESOLVED FIXED

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jimm, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Fx 53 no long officially supports XP/Vista, so we should stop shipping updates to these users for Nightly 53, Aurora 53, and (maybe, tbd) Beta 53.
Do we have a web page we can point to that explains the desupport of XP & Vista ? Maybe like https://support.mozilla.org/en-US/kb/firefox-no-longer-works-some-versions-windows-xp but expanded, at least for Nightly and Aurora. May want something on www.mozilla.org for beta/release.
(In reply to Nick Thomas [:nthomas] from comment #1)
> Do we have a web page we can point to that explains the desupport of XP &
> Vista ? Maybe like
> https://support.mozilla.org/en-US/kb/firefox-no-longer-works-some-versions-
> windows-xp but expanded, at least for Nightly and Aurora. May want something
> on www.mozilla.org for beta/release.

This is covered by bug 1315153.
Depends on: 1315153
Looks like bug 1315153 that is shown in-product, correct? It would be great to have a special page, similar to https://support.mozilla.org/kb/firefox-osx - this is what we show to mac users on old OSX versions.
Looks like AVRT.dll which isn't available on XP is now required on Nightly. :(

At the very least Nightly updates should be disabled for XP.
Bug 1318619 is the offending change, by the way.
Duplicate of this bug: 1318906
Don't forget to flag Windows Server 2003 as unsupported OS too.
Summary: Stop updating Nightly 53, Aurora 53, and Beta 53 on XP/Vista → Stop updating Nightly 53, Aurora 53, and Beta 53 on XP/2003/Vista
(In reply to Rail Aliiev [:rail] ⌚️ET from comment #3)
> Looks like bug 1315153 that is shown in-product, correct? It would be great
> to have a special page, similar to
> https://support.mozilla.org/kb/firefox-osx - this is what we show to mac
> users on old OSX versions.

We should not wait until the info page is ready because the latest Nightly no longer even start on WinXP/2003/Vista. Even "Nightly is up to date" is much better than non-working builds.
nthomas just created a rule to serve 20161118030222 to XP/Vista users.
I've added a rule in the update server (id 467) which sends requests from those three OS and buildid < 20161118030222 to 20161118030222. It matches on OS_VERSION containing "Windows_NT 5.1", "Windows_NT 5.2", or "Windows_NT 6.0", per https://en.wikipedia.org/wiki/Windows_NT#Releases. The 6.0 entry also affects Windows Server 2008 without R2 also. A second rule (id 468) blocks updates from the last good build at 20161118030222.

Please note that bug 1305453 hasn't landed yet, so attempts to reinstall (eg via nightly.m.o) won't be blocked and the install will still be busted.

Bug 1318619 looks like accidental desupport, which is unfortunate given all the work that has gone into handling this desupport properly.
See Also: → 1318920
See Also: → 1318921
See Also: → 1318922
I filed  bug 1318920, bug 1318921, bug 1318922 to track aurora, beta and release separately so we don't forget. Also there is bug 1315083 to switch XP users to esr.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Summary: Stop updating Nightly 53, Aurora 53, and Beta 53 on XP/2003/Vista → Stop updating Nightly 53 on XP/2003/Vista
See Also: → 1315083
Summary: Stop updating Nightly 53 on XP/2003/Vista → Stop updating Nightly 53 on Windows XP, Windows 2003, Windows Vista, and Windows 2008 without R2
(In reply to Nick Thomas [:nthomas] from comment #11)

> A second rule (id 468) blocks updates from the last good build at 20161118030222.

According to 

https://bugzilla.mozilla.org/show_bug.cgi?id=1318619#c9

and 

https://bugzilla.mozilla.org/show_bug.cgi?id=1318619#c11

libcubeb was updated to 

https://github.com/kinetiknz/cubeb/commit/13f167c23954527d693508d11dd7706b2b774729

That commit reverts the hard requirement for avrt.dll to be present in the system, 
so Nightly 53.0a1 buildID >=20161122030216 (which has cs=c788e6d landed in) should 
again load and run correctly on WinXP/2003 Server; or have I misunderstood things?

(In reply to Masatoshi Kimura [:emk] from comment #9)

> because the latest Nightly no longer even start on WinXP/2003/Vista

... Not true for Vista SP2; as I (and others) have commented in Vista related bugs, 
Mozilla were very quick to dismiss this (my) OS; actually, system file avrt.dll 
v6.0.6001.18000 is part of my OS, so I (unlike XP users) wasn't affected by https://bugzilla.mozilla.org/show_bug.cgi?id=1318870

I am aware you are determined to end Fx 53.0a1 support on Vista but that cubeb thing, 
inadvertent as it might have been, wasn't a death nail :-)
I see your point about the backout, but I doubt it'll be long before something else deliberately drops support. Leaving the block in place unless jimm requests otherwise.
(In reply to Nick Thomas [:nthomas] from comment #14)
> I see your point about the backout, but I doubt it'll be long before
> something else deliberately drops support. Leaving the block in place unless
> jimm requests otherwise.

We're not changing the decision here.
You need to log in before you can comment on or make changes to this bug.