Traditional Chinese is detected as Simplified Chinese

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: pplwong, Assigned: shanjian)

Tracking

({intl})

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2] verified on trunk)

Attachments

(3 attachments, 1 obsolete attachment)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020318
BuildID:    20020318

Traditional Chinese is detected as Simplified Chinese

Reproducible: Always
Steps to Reproduce:
1.Go to http://pub16.ezboard.com/funionvillegeneralforum (for example)

Actual Results:  Mozilla selected Simplified Chiense Font

Expected Results:  Mozilla selected Traditional Chinese Font

Netscape 6.2.1 does select Traditional Chinese Font correctly.
and if I didn't remember wrongly, the early builds of 0.9.8 works correctly also.
Confirming on Linux 2002031721. Autodetection displays simplified Chinese.
Status: UNCONFIRMED → NEW
Component: Browser-General → Internationalization
Ever confirmed: true
OS: Windows 98 → All
Arthur : Please select "Reassign bug to owner and QA contact of selected component"
if you cange the component...
Assignee: asa → yokoyama
QA Contact: doronr → ruixu
Keywords: intl
QA Contact: ruixu → ylong
This particular page http://pub16.ezboard.com/funionvillegeneralforum
can be detect as big5 when select Auto-Detect Traditional Chinese, all other
auto-detect options will failed.
On N6.2.1, this page is detected as big for auto-detect east asian, chinese but
auto-detect all still failed.

For auto-detect east asian and chinese, it's a regression.
-> shanjian
Assignee: yokoyama → shanjian
Posted patch patchSplinter Review
frank, this is a obvious mistake and it will cause regression to charset detector. 
Since this is a simple change, we might want to get this into branch. 
Status: NEW → ASSIGNED
Keywords: nsbeta1
nsbeta1-

We don't need to fix the Chinese detector for beta1.
Keywords: nsbeta1nsbeta1-
This will cause regression to other detectors. Please reconsider. 
Keywords: nsbeta1-nsbeta1
Comment on attachment 78753 [details] [diff] [review]
patch

r=ftang
Attachment #78753 - Flags: review+
let's seek sr= and land into trunk first. 
Mike, could you sr?
fix checked into trunk. Keep this open for branch. 
There is only one trunk (Mac) build availible today so far.

And I checked it on Mac10.1.3, it still shows only auto-detect TradChinese will
detect the page fine, all other modules will detect this page as iso-8859-2.
Linux 04-17 trunk build has very similar result:
Detect as iso-8859-1 when auto-detect All, Chinese, East Asian.
Detect as big5 when auto-detect TradChinese.
The problem is that gb18030 covers all code points in big5. For big5 web pages, 
if there is more than one verifiers left, PSM detector will not make any
decision and default will be latin1. That raise a problem. I think what we
should do is to remove gb18030 if there is only 2 verifiers left. 
Posted patch additional patch (obsolete) — Splinter Review
ftang/mike, could you r/sr my additional patch? 
It's necessary in order to make other charset verifiers (include japanese and
korean ones) work. Gb18030 covers too many code points. 
Posted file test case
the original URL contains many single byte latin1 characters, such as 0xa0,
0xb7. It is an invalid test page. 
Comment on attachment 79704 [details] [diff] [review]
additional patch

r=ftang
shanjian explained to me about this patch on phone. shanjian, please add
comment before the change line	to descript the reason as you said in the
phone.
Attachment #79704 - Flags: review+
Attachment #79704 - Attachment is obsolete: true
Attachment #79855 - Flags: review+
msanz and bobj all think this is an important issue to fix. let's nsbeta1+ it. 
this will impact the following detector
"East Asian" , "Chinese", "Simplified Chinese" detectors only.
RISK: Low risk. only local to those those users use these three detectors. 
[adt2], impact users- 
mainly chinese users- potential users- 55M (9.8% of total internet users)
also j and k users too (if they choose "East Asian" detector)

add additional 52.1 (9.2% ) and 25.2M (4.4%) users
sum of cjk are 131.8 M users ( 23.4% of total internet users)

Keywords: nsbeta1nsbeta1+
Whiteboard: [adt2]
*** Bug 138584 has been marked as a duplicate of this bug. ***
Comment on attachment 79855 [details] [diff] [review]
added comment to additional patch

sr=scc
Attachment #79855 - Flags: superreview+
fix checked into trunk.
*** Bug 131998 has been marked as a duplicate of this bug. ***
Veified fixed on 04-25 trunk build.
Comment on attachment 79855 [details] [diff] [review]
added comment to additional patch

a=asa (on behalf of drivers) for checkin to the 1.0 branch
Attachment #79855 - Flags: approval+
Blocks: 141008
seems that the problem still occurs in the 1.0 branch (build 2002050209).
since this is fixed on trunk and verify on trunk, mark this bug as fixed. ylong,
plase mark this as verify on trunk.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Add "verified on trunk" in status whiteboard.
Status: RESOLVED → VERIFIED
Whiteboard: [adt2] → [adt2]. verified on trunk
*** Bug 143538 has been marked as a duplicate of this bug. ***
a= was given on 04/25, so we may need a refresh from drivers to get on the 1.0
branch.
Blocks: 143047
Keywords: adt1.0.0, approval
Whiteboard: [adt2]. verified on trunk → [adt2] verified on trunk
adding adt1.0.0+ for checkin to the 1.0 branch.  Please ask for drivers approval
again since their last approval was more than 3 days ago and afterwards check
into the 1.0 branch.
Keywords: adt1.0.0adt1.0.0+
*** Bug 144540 has been marked as a duplicate of this bug. ***
*** Bug 144090 has been marked as a duplicate of this bug. ***
*** Bug 145218 has been marked as a duplicate of this bug. ***
*** Bug 145199 has been marked as a duplicate of this bug. ***
Comment on attachment 79855 [details] [diff] [review]
added comment to additional patch

a=chofmann,etc.

renewing approval from yesterday's driver meeting.

please check this in by midnight.
fix checked in to branch. 
Keywords: fixed1.0.0
Blocks: 146292
No longer blocks: 141008
Verified fixed on 05-24 branch build on WinXP-SC and Mac OS 10.1.4.
You need to log in before you can comment on or make changes to this bug.