The reload icon looks off-center

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
2 years ago
a year ago

People

(Reporter: mstange, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8867828 [details]
screenshot

See the screenshot. It looks to me like the refresh icon is a little too far to the right.
So it seems that the icon itself is a little offset (navigate to chrome://browser/skin/reload.svg). I think it's not worth fixing this in Nightly until we do bug 1355455.

Thanks :)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Better keep this open to make sure we actually end up fixing this.
Blocks: 1325171
Status: RESOLVED → REOPENED
Depends on: 1355455
OS: Mac OS X → All
Resolution: WONTFIX → ---
Summary: The refresh button looks off-center → The reload button looks off-center
Whiteboard: [photon-visual][p1][57]
Flags: qe-verify+
Priority: -- → P2
Summary: The reload button looks off-center → The reload icon looks off-center
Status: REOPENED → NEW
QA Contact: brindusa.tot
Blocks: 1365003
I think the icon is still leaning a bit to the right. Markus, can you confirm?

Stephen, what do you think?
Flags: needinfo?(shorlander)
Flags: needinfo?(mstange)
Alas, if we want to do anything about this, we'll have to change not only reload.svg but also reload-to-stop.svg and stop-to-reload.svg. Not sure if UX uses tools to make that easy.
(Reporter)

Comment 5

a year ago
Slightly, yes. It's less noticeable now, especially because the toolbar button no longer has a border on hover.
Flags: needinfo?(mstange)
Whiteboard: [photon-visual][p1][57] → [reserve-photon-visual][p1]
Whiteboard: [reserve-photon-visual][p1] → [reserve-photon-visual][p3]
Priority: P2 → P3
The new icon isn't as visually off-center.

Checking with Amy and Eric on how hard it is to move it 1px to the left :)
(In reply to Stephen Horlander [:shorlander] from comment #6)
> The new icon isn't as visually off-center.
> 
> Checking with Amy and Eric on how hard it is to move it 1px to the left :)

I think 1px is already too and makes it look unbalanced again. Maybe the arrow should become shorter.
(In reply to Dão Gottwald [::dao] from comment #7)
> (In reply to Stephen Horlander [:shorlander] from comment #6)
> > The new icon isn't as visually off-center.
> > 
> > Checking with Amy and Eric on how hard it is to move it 1px to the left :)
> 
> I think 1px is already too and makes it look unbalanced again. Maybe the
> arrow should become shorter.

Stephen, is there an update on what we want to do here based on Dão's comment?

Jared, is moving the icon 1px to the left something we can do in code or do I need to update the svg-sprite?
Flags: needinfo?(jaws)
Eric, do you think 1px might be too much (as Dao says in comment 7)?

If we do this we would want to make the change in the SVG-sprite as well as the static icon. Also, would the stop button might need to shift too since they should be in the same position?
Flags: needinfo?(jaws)
I'm moving this to photon-animation since photon-visual folks aren't equipped to to deal with the SVG sprite.
Priority: P3 → --
Whiteboard: [reserve-photon-visual][p3] → [photon-animation][triage]
QA Contact: brindusa.tot
Priority: -- → P4
QA Contact: stefan.georgiev
Whiteboard: [photon-animation][triage] → [reserve-photon-animation]
Looking at this in more detail I don't think it's worth the effort. Moving the icon by a pixel will cause the same problem as Dao mentioned in comment 7.  With the updated icon, visually it looks pretty centered anyway.

Comment 12

a year ago
To me, this is a textbook example of bikeshedding.
Closing per comment #11.
Status: NEW → RESOLVED
Last Resolved: 2 years agoa year ago
Flags: needinfo?(shorlander)
Resolution: --- → WONTFIX
Flags: qe-verify+
Priority: P4 → --
QA Contact: stefan.georgiev
Whiteboard: [reserve-photon-animation]
Duplicate of this bug: 1397647
You need to log in before you can comment on or make changes to this bug.