Closed Bug 136527 Opened 22 years ago Closed 20 years ago

IFRAME covered by DIV causes mouseouts on DIV

Categories

(Core :: DOM: Events, defect, P2)

x86
Windows 2000
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: bc, Assigned: saari)

References

()

Details

(Keywords: testcase, topembed-)

Attachments

(1 file)

Steps to reproduce:

1. load url
2. mouseover menu which overlaps the iframe containing the ad
3. move mouse until it is over portion of menu overlapping the iframe

Expected result:

menu does not close

Actual result:

menu closes

To see that the menu actually works when there is no iframe, visit
http://www.bayarea.com/mld/bayarea/.
Attached file testcase
This test case contains an iframe obscured by an absolutely positioned div.
Move the mouse over the DIV and see the mouseout fire whenever you move over
the iframe.
Nominating for nsbeta1,topembed since this will cause problems on any page which
uses dhtml menus which overlap iframes.
this occured in trunk build 2002 04 08 03/win2k
topembed- (not blocking)
Keywords: topembedtopembed-
Blocks: 138798
See discussion in bug 123700; apparently the fact that the iframe is a native
window makes us get an OS-level mouseout event when we move over an iframe....
Blocks: 159912
*** Bug 164778 has been marked as a duplicate of this bug. ***
I'm curious as to where this bug is going?  We see the same issues and have had
to implement functionality changes to work around it.
Keywords: mozilla1.2
This bug does appear to be the same as bug 125386.  It seems to be effecting any
scrollable element.
Priority: -- → P2
Keywords: mozilla1.2mozilla1.3
Depends on: 125386
I worked around the problem by doing something like

li-object.onmouseout = function (e) { 
  var tmp = e.originalTarget.nodeName;
  
  // js-code to hide div
}

I have no idea why that makes a difference, tmp is never used again...
The complete js can be found at http://test.studenternet.auc.dk/scripts/cssjsmenu.js
adt: nsbeta1-
Keywords: nsbeta1nsbeta1-
*** Bug 214098 has been marked as a duplicate of this bug. ***
.
Assignee: joki → saari
QA Contact: vladimire → desale
I tried to use the workaround Joakim Recht described, but without any results. I
find it strange that this bug is over a year old, and still no progress is in
sight; I think that the moz developers should redirect their attention from
creating new features to fixing bugs!
Keywords: mozilla1.3
Blocks: 228487
*** Bug 243843 has been marked as a duplicate of this bug. ***
*** Bug 208107 has been marked as a duplicate of this bug. ***
See the below URL for example and (cross browser) explanation:
http://www.hiermenuscentral.com/issues/safiframe/iframeover.html
Blocks: 164302
Blocks: 194984
Blocks: 247401
Blocks: 265251
Blocks: 155276
Blocks: 262194
Blocks: 276059
This works fine now that 125386 has been fixed, can anyone verify? Using trunk
build 20050224.
with trunk FF 20050225, attached testcase works as expected. Behaviour on
testcase of comment 16 has changed but is still not correct.
Please file a new bug with a new reduced testcase and explanation if there are
remaining issues.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: