Closed Bug 1386265 Opened 2 years ago Closed 2 years ago

Exclude tippy top images directory from browser_all_files_referenced.js

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: Mardak, Assigned: Mardak)

References

Details

Attachments

(1 file)

This is in preparation for those images being packaged but not all directly referenced during tests as each image urls are dynamically calculated/used when top sites would be shown.
Try without tippytop exported https://treeherder.mozilla.org/#/jobs?repo=try&revision=de328569512b

Sorry for the wonky failures. I forgot that the "static" directory is only run on non-debug non-linux32 builds.
Comment on attachment 8892457 [details]
Bug 1386265 - Exclude tippy top images directory from browser_all_files_referenced.js.

https://reviewboard.mozilla.org/r/163430/#review168836

looks good, thanks!
Attachment #8892457 - Flags: review?(usarracini) → review+
Pushed by edilee@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c4d89120f88d
Exclude tippy top images directory from browser_all_files_referenced.js. r=ursula
Blocks: 1386785
https://hg.mozilla.org/mozilla-central/rev/c4d89120f88d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8892457 [details]
Bug 1386265 - Exclude tippy top images directory from browser_all_files_referenced.js.

Approval Request Comment (part 2 of 6 Mardak will uplift)
[Feature/Bug causing the regression]: Activity Stream preffed off in 56 to be enabled in Shield study
[User impact if declined]: Unable to uplift the rest of Activity Stream 56 changes due to test failures
[Is this code covered by automated tests?]: Yes this is the test
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: Bug 1385716 Bug 1386350 Bug 1385090 Bug 1386314 Bug 1386737
[Is the change risky?]: No
[Why is the change risky/not risky?]: This is making the test not fail when other changes land
[String changes made/needed]: No
Attachment #8892457 - Flags: approval-mozilla-beta?
Comment on attachment 8892457 [details]
Bug 1386265 - Exclude tippy top images directory from browser_all_files_referenced.js.

Needed for Activity Stream testing in 56. This should make it into 56 beta 1.
Attachment #8892457 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Ed Lee :Mardak from comment #7)
> [Is this code covered by automated tests?]: Yes this is the test
> [Has the fix been verified in Nightly?]: Yes
> [Needs manual test from QE? If yes, steps to reproduce]: No

Setting qe-verify- based on Ed Lee's assessment on manual testing needs and the fact that this fix has automated coverage.
Flags: qe-verify-
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.