Closed Bug 1386350 Opened 2 years ago Closed 2 years ago

Turn off snippets in activity stream for tests

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: k88hudson, Assigned: k88hudson)

References

Details

Attachments

(1 file)

As we are about to pref on snippets on activity stream, we need to turn them off in tests to prevent network calls
Attachment #8892558 - Flags: review?(dmose)
Assignee: nobody → khudson
Comment on attachment 8892558 [details]
Bug 1386350 - Turn off snippets in activity stream for tests

https://reviewboard.mozilla.org/r/163564/#review168918

Looks good, r=dmose
Attachment #8892558 - Flags: review?(dmose) → review+
Pushed by edilee@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/877a7dc33e3d
Turn off snippets in activity stream for tests r=dmose
We're sorry - something has gone wrong while rewriting or rebasing your commits. The commits being pushed no longer match what was requested. Please file a bug.
We're sorry - something has gone wrong while rewriting or rebasing your commits. The commits being pushed no longer match what was requested. Please file a bug.
I think multiple people tried to autoland multiple times. It actually landed in comment 4.
Duplicate of this bug: 1386426
Blocks: 1386785
https://hg.mozilla.org/mozilla-central/rev/877a7dc33e3d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8892558 [details]
Bug 1386350 - Turn off snippets in activity stream for tests

Approval Request Comment (part 3 of 6 Mardak will uplift)
[Feature/Bug causing the regression]: Activity Stream preffed off in 56 to be enabled in Shield study
[User impact if declined]: Unable to uplift the rest of Activity Stream 56 changes due to test failures
[Is this code covered by automated tests?]: Yes, many tests are negatively impacted without this
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: Bug 1385716 Bug 1386265  Bug 1385090 Bug 1386314 Bug 1386737
[Is the change risky?]: No
[Why is the change risky/not risky?]: This is pre-preffing off functionality that doesn't exist
[String changes made/needed]: No
Attachment #8892558 - Flags: approval-mozilla-beta?
Comment on attachment 8892558 [details]
Bug 1386350 - Turn off snippets in activity stream for tests

Test fix in order to get some other Activity Stream uplifts to beta 56.
Attachment #8892558 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Ed Lee :Mardak from comment #10)
> [Is this code covered by automated tests?]: Yes, many tests are negatively
> impacted without this
> [Has the fix been verified in Nightly?]: Yes
> [Needs manual test from QE? If yes, steps to reproduce]: No

Setting qe-verify- based on Ed Lee's assessment on manual testing needs and the fact that this fix has automated coverage.
Flags: qe-verify-
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.