Closed Bug 1394517 Opened 2 years ago Closed 2 years ago

URL bar drop-down arrow shows in strange situations

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox57 --- verified

People

(Reporter: mossop, Assigned: florian)

References

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(1 file)

The down arrow in the url bar that you click to open the popup shows and hides in some strange cases making it appear and disappear while you mouse around the window.

It is shown when the mouse is over:

The URL bar
Other toolbar buttons
The bottom border of the toolbars

It is not shown when the mouse is over:

Tab bar
Flexible spacers
The content area
Whiteboard: [photon-visual] → [photon-visual] [triage]
(In reply to Dave Townsend [:mossop] from comment #0)
> It is not shown when the mouse is over:
> 
> Tab bar
> Flexible spacers

We're not seeing this bug on Linux or Mac. Can you reproduce in a new profile?

> The content area

This is expected behavior (bug 1203494).
Flags: needinfo?(dtownsend)
I tested in a clean profile on Windows.

(In reply to Dave Townsend [:mossop] from comment #0)
> The down arrow in the url bar that you click to open the popup shows and
> hides in some strange cases making it appear and disappear while you mouse
> around the window.
> 
> It is shown when the mouse is over:
> 
> The URL bar
> Other toolbar buttons
> The bottom border of the toolbars
> 
> It is not shown when the mouse is over:
> 
> Tab bar

This is slightly false, over tabs the drop-down shows, over the rest of the titlebar it doesn't.

> Flexible spacers

This only occurs when a lightweight theme is applied.
Flags: needinfo?(dtownsend)
The dropmarker also disappears while the hamburger menu is animating open.
Duplicate of this bug: 1394205
The problem here is that we're basically setting the dropdown to appear when the toolbox is hovered, so:

- menus that drop down from those buttons don't count
- items that get no mouse events because they get treated as native titlebar bits (like the empty space in the tabstrip) don't count

Fixing this is not trivial, because this is currently set up using CSS with a :hover style on the toolbox.

TBH, I think we should just get rid of the dropmarker, that's what people have been saying for months, and there's a separate bug on file for doing that. Stephen?
Flags: needinfo?(shorlander)
See Also: → 1398529
Priority: -- → P3
Depends on: 1401507
No longer depends on: 1401507
Duplicate of this bug: 1401507
Duplicate of this bug: 1220486
From the duplicate bug 1401507 - URL bar dropmarker appears when hovering tabs or toolbar buttons

> The urlbar dropmarker appears whenever I hover the searchbar, a random
> toolbar button, or a tab. This is distracting (especially with the css
> transition) as it causes something to move in a place that is unrelated to
> where my mouse cursor is.
> 
> I did some bugzilla and hg archeology and was surprised to see this behavior
> was intentionally introduced in bug 1211217.
> 
> Jared, I assume you wanted this to appear when the mouse is around the
> urlbar, not when it's over anything in the top of the browser window.
> 
> Before your patch we were checking for :not(:hover) on #urlbar which was
> indeed a small target. Currently (after your patch) we do it on
> #navigator-toolbox which is a giant target. I think #urlbar-container is a
> good compromise. Do you agree?

Stephen, the options that have been proposed here are:

1. just get rid of the dropmarker (what Gijs is proposing here in comment 5). It may already be late to introduce this change in 57.

2. show the dropmarker only when hovering the urlbar (ie. revert to the situation before bug 1211217)

3. show the dropmarker when hovering the urlbar container (ie. the urlbar + a few pixels immediately around it). This is what the patch I'm attaching does.

4. Keep the current distracting and inconsistent behavior.

What would you like us to do?
Assignee: nobody → florian
Attachment #8910275 - Flags: ui-review?(shorlander)
Attachment #8910275 - Flags: review?(jaws)
See Also: 1398529
Duplicate of this bug: 1398529
Comment on attachment 8910275 [details] [diff] [review]
Patch from bug 1401507

Review of attachment 8910275 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, the goal of this is to show the dropmarker as the user begins to mouse towards it. I'm fine with this change.
Attachment #8910275 - Flags: review?(jaws) → review+
Status: NEW → ASSIGNED
Flags: qe-verify+
Priority: P3 → P1
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual]
QA Contact: ovidiu.boca
(In reply to Florian Quèze [:florian] [:flo] from comment #8)
> 1. just get rid of the dropmarker (what Gijs is proposing here in comment
> 5). It may already be late to introduce this change in 57.

I think we should consider removing it (we've discussed it for years) I filed bug 1389594 to get some data on usage for after 57.

> 3. show the dropmarker when hovering the urlbar container (ie. the urlbar +
> a few pixels immediately around it). This is what the patch I'm attaching
> does.

This sounds fine to me in the short-term. Thanks!
Flags: needinfo?(shorlander)
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d375b8dad67e
URL bar drop-down arrow should only be shown when hovering the urlbar container, r=jaws, ui-r=shorlander.
https://hg.mozilla.org/mozilla-central/rev/d375b8dad67e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Iteration: --- → 57.3 - Sep 19
I have reproduced the issue on an affected build 57.0a1 (20170828100127)on Windows10 64bit

This is verified fixed on Windows 10 and Windows 7 64bit - Build 57.0b3(20170925150345)

The URL bar drop-down arrow is shown only when hovering the urlbar container.
Status: RESOLVED → VERIFIED
Based on comment 14 I will mark firefox57 flag	-- verified
You need to log in before you can comment on or make changes to this bug.