All react component files in DevTools should use camelCase/PascalCase naming convention. This is the standard in React community and many of the DevTools component files already follow this rule. See also https://github.com/devtools-html/rfcs/issues/17 This is meta report covering the refactoring goal. Please file follow up bugs as necessary. Honza
(In reply to Jan Honza Odvarko [:Honza] from comment #0) > This is meta report covering the refactoring goal. Please file follow up > bugs as necessary. I think I filed all of them, but feel free to add more if I missed some components. I set them all as good-first-bugs and set myself as mentor because I think they're all pretty straightforward changes for people who want to learn about putting the dev environment in place. Feel free to steal mentorships if you want.
I would like to start contributing to the new Devtools (I worked with previous non-react tools). May I start with this issue?
(In reply to migueluseche from comment #3) > I would like to start contributing to the new Devtools (I worked with > previous non-react tools). May I start with this issue? Sure, thank you for your interest. This particular bug is what we call a "meta" bug. That means it's a sort of parent bug that we use only for grouping children bugs. If you look at the top, in the "depends on" list, you will see the actual children bugs where work needs to happen. I suggest you look at bug 1402386 or bug 1402387 or bug 1402390 or bug 1402391. Those are not being worked on by anyone yet.
All children bugs are now fixed. Thanks everyone who contributed. Let's close this meta bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Found a few more folders that have not been migrated, reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I found that there are multiple components that should be renamed and updated at /devtools/client/framework/ I don't see an bug for this folder.
(In reply to migueluseche from comment #7) > I found that there are multiple components that should be renamed and > updated at /devtools/client/framework/ I don't see an bug for this folder. I think that was handled by https://bugzilla.mozilla.org/show_bug.cgi?id=1452060, feel free to file another bug blocking this one if we missed something!
My mistake, I tough I saw components inside that /framework folder, everything is ok.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago → 9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.