Closed Bug 1402594 Opened 4 years ago Closed 4 years ago

Progress bar animation on loading scrolled website page is visible in wrong place

Categories

(Firefox for Android Graveyard :: Theme and Visual Design, defect, P1)

58 Branch
All
Android

Tracking

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 unaffected, firefox58 verified)

VERIFIED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- verified

People

(Reporter: Virtual, Assigned: rbarker)

References

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

STR:
1. Open some long website page
2. When this website page will be loading, scroll it
and see that progress bar animation is visible in "old" wrong place,
it looks like whole address bar goes hidden and progress bar animation stays on unchanged position, while it should gone under mobile phone notification bar

Tested with Mozilla Firefox Nightly Mobile 58.0a1 (2017-09-23) on Android 6.0.1.
Flags: qe-verify+
Blocks: 1396951
No longer blocks: fennec-photon
Has Regression Range: --- → yes
Flags: needinfo?(nchen)
Hardware: ARM → All
Reproducing starting from Nightly 58 build 2017-09-23.
Duplicate of this bug: 1402819
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
Assignee: nchen → rbarker
Comment on attachment 8911955 [details]
Bug 1402594 - Fix regression where toolbar does not become visible when link is pressed

https://reviewboard.mozilla.org/r/183364/#review188484
Attachment #8911955 - Flags: review?(nchen) → review+
Pushed by rbarker@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4ac94fd29b5a
Fix regression where toolbar does not become visible when link is pressed r=jchen
https://hg.mozilla.org/mozilla-central/rev/4ac94fd29b5a
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Priority: -- → P1
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual]
Whiteboard: [reserve-photon-visual]
Duplicate of this bug: 1403126
Verified as fixed on Nightly 58 (2017-09-26).
Devices:
Asus ZenPad 8.0 Z380KL (Android 6.0.1)
Huawei MediaPad M2 (Android 5.1.1)
LG G4 (Android 6.0)
Status: RESOLVED → VERIFIED
As OP, I'm also confirming that bug is fixed, starting in Mozilla Firefox Nightly 58.0a1 (2017-09-26).
Thank you very much! \o/
tracking-fennec: ? → ---
Duplicate of this bug: 1402636
Based on comment 8 I will remove the qe-verify flag, thanks.
Flags: qe-verify+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.