Closed Bug 1423203 Opened 2 years ago Closed 2 years ago

Update webrender to 22f472f0adb02bd71c472e426e47182f2b218f6d

Categories

(Core :: Graphics: WebRender, defect, P1)

59 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1422317 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
Blocks: 1423304
WR @ 23d1358c8f94a436d8e591ed001a44a6f51795a1

https://treeherder.mozilla.org/#/jobs?repo=try&revision=bc7626f1cf2d606e834e317882bf3fd3a8baeabb
https://treeherder.mozilla.org/#/jobs?repo=try&revision=65f40312756769211591f4594524f5af45b7088a

Green

WR @ f6d91e0a6b7d41add1bf49230101b4f6637c4512

https://treeherder.mozilla.org/#/jobs?repo=try&revision=da24854162a0016f6315a58c045582586c80d2df
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e8e3aa1935ef5f654fe298aa779ab2fbb907a73d

OS X build failure, regression range:

* f6d91e0a Auto merge of #2122 - jrmuizel:font-data, r=glennw
* 7bd05c06 Write out font files for CGFonts
* ed7feb0f Split out ResourceGenerator from the other state in YamlFrameWriter

so that's definitely servo/webrender#2122
Blocks: 1422408
talos-g1 failure seems persistent, I'll bisect.
This is the backtrace from the log:

thread 'WRRenderBackend#2' panicked at 'index out of bounds: the len is 15 but the index is 52', /checkout/src/liballoc/vec.rs:1552:10
stack backtrace:
   0:     0x7f3eb5dda253 - std::sys::imp::backtrace::tracing::imp::unwind_backtrace::h8ed7485deb8ab958
   1:     0x7f3eb5dd88ec - std::panicking::default_hook::{{closure}}::h0088fe51b67c687c
   2:     0x7f3eb5dd831d - std::panicking::default_hook::hf425c768c5ffbbad
   3:     0x7f3eb5dd7e30 - std::panicking::rust_panic_with_hook::h25b934bb4484e9e0
   4:     0x7f3eb5dd7cdb - std::panicking::begin_panic::h59483e27e93d7bc6
   5:     0x7f3eb5dd7c69 - std::panicking::begin_panic_fmt::h5f221297e8a3dbdb
   6:     0x7f3eb5de7ac2 - core::panicking::panic_fmt::h4d1ab9bae1f32475
   7:     0x7f3eb5de7638 - core::panicking::panic_bounds_check::h00738207f5476c9a
   8:     0x7f3eb5d22cb0 - webrender::tiling::add_to_batch::h74669da3189bb8bb
   9:     0x7f3eb5d1e912 - webrender::tiling::<impl webrender::picture::PicturePrimitive>::add_to_batch::h5da34e2c7ef4112e
  10:     0x7f3eb5d20c39 - webrender::tiling::add_to_batch::h74669da3189bb8bb
  11:     0x7f3eb5d1e912 - webrender::tiling::<impl webrender::picture::PicturePrimitive>::add_to_batch::h5da34e2c7ef4112e
  12:     0x7f3eb5d20c39 - webrender::tiling::add_to_batch::h74669da3189bb8bb
  13:     0x7f3eb5d1e912 - webrender::tiling::<impl webrender::picture::PicturePrimitive>::add_to_batch::h5da34e2c7ef4112e
  14:     0x7f3eb5d20c39 - webrender::tiling::add_to_batch::h74669da3189bb8bb
  15:     0x7f3eb5d1e912 - webrender::tiling::<impl webrender::picture::PicturePrimitive>::add_to_batch::h5da34e2c7ef4112e
  16:     0x7f3eb5d20c39 - webrender::tiling::add_to_batch::h74669da3189bb8bb
  17:     0x7f3eb5d1e912 - webrender::tiling::<impl webrender::picture::PicturePrimitive>::add_to_batch::h5da34e2c7ef4112e
  18:     0x7f3eb5d1aa3b - <webrender::tiling::ColorRenderTarget as webrender::tiling::RenderTarget>::build::h75702909112d52ab
  19:     0x7f3eb5d0daee - webrender::render_backend::Document::render::h089ba5314e356c2a
  20:     0x7f3eb5d00010 - webrender::render_backend::RenderBackend::process_document::h693fce1a0c85d7b1
  21:     0x7f3eb5cf12d2 - webrender::render_backend::RenderBackend::run::hf7a1dc471353a036
  22:     0x7f3eb5cef8e7 - std::sys_common::backtrace::__rust_begin_short_backtrace::h93ca2084bea4b688
  23:     0x7f3eb5ceeef6 - <F as alloc::boxed::FnBox<A>>::call_box::h80d55dfc4829e645
  24:     0x7f3eb5de4f33 - std::sys::imp::thread::Thread::new::thread_start::hbaf1b5aa1ca8e3ea
  25:     0x7f3ebfbc0e99 - start_thread
  26:     0x7f3ebecd038c - clone
Redirecting call to abort() to mozalloc_abort

And this is the WR regression range:

*   b281bd2b Auto merge of #2194 - jrmuizel:blob-update-test, r=glennw
|\
| * 55b09865 Add test to make sure that updating blob images updates them
*   983e8fcf Auto merge of #2193 - mbrubeck:deps, r=glennw
|\
| * ae3969ad Update to smallvec 0.6
*   f38bf981 Auto merge of #2189 - mrobinson:updated-2177, r=glennw
|\
| * 6b4ddfb2 Add a test for non-axis-aligned clipping
| * 47a70ddc Proper inner rectangle for the clips
* 22f472f0 Merge pull request #2188 from lsalzman/clip-font-transform
* 9c2d2818 fix local clipping of transformed glyphs

WR @ 983e8fcf: https://treeherder.mozilla.org/#/jobs?repo=try&revision=869dbdc392422bab7cde2ec09ff0b09a15576a0f
WR @ f38bf981: https://treeherder.mozilla.org/#/jobs?repo=try&revision=cca0d21990a81a4997276fbfef4a5621159eddcc
WR @ 22f472f0: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6e281a859fd216da8d3333eee9bb5552b56dd353
Narrowed to:

*   f38bf981 Auto merge of #2189 - mrobinson:updated-2177, r=glennw
|\
| * 6b4ddfb2 Add a test for non-axis-aligned clipping
| * 47a70ddc Proper inner rectangle for the clips
* 22f472f0 Merge pull request #2188 from lsalzman/clip-font-transform
* 9c2d2818 fix local clipping of transformed glyphs

Just waiting on the last push to finish.
Given that the g1 job for WR @ 22f472f0 hasn't failed yet (the others failed in < 5 minutes) I'm assuming it's going to be green, which isolates the regression to servo/webrender#2189.

Will prepare the update to 22f472f0 since that's the last green changeset. Try pushes for that cset to confirm:

WR @ 22f472f0adb02bd71c472e426e47182f2b218f6d

https://treeherder.mozilla.org/#/jobs?repo=try&revision=05b03ab035373f3b2283f626a0525275a4485a22
https://treeherder.mozilla.org/#/jobs?repo=try&revision=6f8f1a472ea36773601961a9cc44252174d0c8f8
Alias: wr-future-update
Assignee: nobody → bugmail
No longer blocks: 1422300, 1422408, 1423104
No longer depends on: 1421097
Summary: Future webrender update bug → Update webrender to 22f472f0adb02bd71c472e426e47182f2b218f6d
Version: unspecified → 59 Branch
Status: NEW → ASSIGNED
Priority: P2 → P1
Comment on attachment 8935804 [details]
Bug 1423203 - Update webrender to commit 22f472f0adb02bd71c472e426e47182f2b218f6d.

https://reviewboard.mozilla.org/r/206672/#review212464
Attachment #8935804 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8935805 [details]
Bug 1423203 - Update Cargo lockfiles and revendor rust dependencies.

https://reviewboard.mozilla.org/r/206674/#review212468
Attachment #8935805 - Flags: review?(jmuizelaar) → review+
^ rebased onto autoland tip to get past mbrubeck's big cleanup.
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/09af0af978a0
Update webrender to commit 22f472f0adb02bd71c472e426e47182f2b218f6d. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/bdc16b1eab50
Update Cargo lockfiles and revendor rust dependencies. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/09af0af978a0
https://hg.mozilla.org/mozilla-central/rev/bdc16b1eab50
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.