Closed Bug 1458530 Opened 4 years ago Closed 3 years ago

After unhiding an audio tab, the audio icon will disappear

Categories

(WebExtensions :: Frontend, defect)

61 Branch
defect
Not set
normal

Tracking

(firefox-esr52 unaffected, firefox-esr60 disabled, firefox59 disabled, firefox60 disabled, firefox61+ verified)

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- disabled
firefox59 --- disabled
firefox60 --- disabled
firefox61 + verified

People

(Reporter: cbadescu, Assigned: mstriemer)

References

Details

Attachments

(3 files)

Attached image NoAudio.gif
[Affected versions]:
- Firefox 61.0a1 (20180501220047)

[Affected platforms]:
- Win 7 64-bit
- Mac OS 10.13.2

[Steps to reproduce]:
1.Flip “extensions.webextensions.tabhide.enabled” to true.
2.Open multiple audio tabs.
3.Hide some tabs.
4.Click on the all tabs menu.
5.Click on one audio hidden tab.
6.Observe the “v” button.

[Expected results]:
- The audio icon is still displayed, since other audio tabs are still hidden.

[Actual results]:
- The audio icon is not visible after you unhide an audio tab.
Assignee: nobody → mstriemer
Comment on attachment 8972765 [details]
Bug 1458530 - Fix hidden audio indicator hiding early

https://reviewboard.mozilla.org/r/241330/#review247162

::: browser/base/content/tabbrowser.xml:929
(Diff revision 1)
>          <parameter name="tab"/>
>          <parameter name="opts"/>
>          <body><![CDATA[
>            let closed = opts && opts.closed;
>            if (!closed && tab.soundPlaying && tab.hidden) {
> -            this._hiddenSoundPlayingTabs.add(tab.id);
> +            this._hiddenSoundPlayingTabs.add(tab);

`tab.id` is always an empty string here. When I first wrote this code I was using the tab itself in the set, then decided that it was better to just use the id (which doesn't appear to be a thing).

If there's something else to key off of I can use that. I'm not sure if there are any other cases I need to handle here to avoid leaking this tab object. I'd imagine if we're missing a case here we could get some buggy results too.
Comment on attachment 8972765 [details]
Bug 1458530 - Fix hidden audio indicator hiding early

https://reviewboard.mozilla.org/r/241332/#review247198
Attachment #8972765 - Flags: review?(dao+bmo) → review+
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ca2a1a6d39b
Fix hidden audio indicator hiding early r=dao
https://hg.mozilla.org/mozilla-central/rev/0ca2a1a6d39b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Attached image Bug1458530.gif
This issue is verified as fixed on Firefox 61.0a1 (20180503220110) under Win 7 64-bit and Mac OS X 10.13.3.

Please have a look at the attached video.
Status: RESOLVED → VERIFIED
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.