Remove cookie options from Scripts & Windows prefs

VERIFIED DUPLICATE of bug 223782

Status

SeaMonkey
Preferences
VERIFIED DUPLICATE of bug 223782
16 years ago
14 years ago

People

(Reporter: Jesse Ruderman, Assigned: Doron Rosenberg (IBM))

Tracking

Trunk
mozilla1.4alpha

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
We should remove "Create or change cookies" and "Read cookies" from the Scripts
& Windows prefs panel.

We already have options for disabling cookies and for disabling scripts, and
there isn't anything special or evil about the combination of cookies and
scripts.  Also, unlike most of the options in the Scripts & Windows panel, the
script-cookie prefs only make sense to someone very familiar with the Web.

Comment 1

16 years ago
Fair enough. -->Doron.
Assignee: mpt → doron
Component: User Interface Design → Preferences
OS: Windows 98 → All
QA Contact: zach → sairuh
Hardware: PC → All
(Assignee)

Comment 2

16 years ago
hmm, what if you want js to not set cookies, but allow servers to do so?

Comment 3

16 years ago
Doron: you can always manually set the pref. This just removes the UI.

Personally I do want just that. Generally, sites that use JS to set cookies are
hacked together by kids, where I don't need to allow cookies anyway.
Professional sites where cookies are required (and where I actually am using the
cookie for a purpose, ie, bugzilla login) use HTTP headers.

As long as cookie manager blocking and 'ask me' affects JS-set cookies too, we
probably shouldn't expose JS cookie prefs to mortal users.
I don't quite get why we need that pref at all, isn't the cookie manager enough?

Comment 5

16 years ago
If this pref UI is removed, won't it be impossible for the average user to
easily block cookie scripts in HTML E-mail without denying themselves access to
the website itself?
(Reporter)

Comment 6

16 years ago
CT: if scripts in mail can set or read cookies, that's a bug and keeping this 
pref is a really bad way to work around it.
(Reporter)

Comment 7

16 years ago
See also bug 172097, "Site falsely claims cookies are disabled".  The reporter
marked it as WFM after realizing the problem was due to his script-cookie settings.
(Reporter)

Comment 8

16 years ago
Increasing severity from enh to maj because bug 177426 (Yahoo Mail gets caught
in a reload loop when its scripts can't access cookies) has 15 dups.
Severity: enhancement → major
(Assignee)

Comment 9

16 years ago
-> 1.4a
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.4alpha
fwiw, phoenix has removed these options from its analogous JavaScript pref panel.
(Assignee)

Updated

16 years ago
Severity: major → normal

Comment 11

16 years ago
*** Bug 177426 has been marked as a duplicate of this bug. ***
nominating nsbeta1 -- too easy to get into unexplainable trouble using these
settings, even if you think you're smart enough to mess with the Advanced panel.
It makes little sense to allow cookies and allow scripts, but not allow scripts
to do cookies.
Keywords: nsbeta1
(Assignee)

Comment 13

16 years ago
Created attachment 113359 [details] [diff] [review]
remove the code

trivial patch - remove the code

Comment 14

16 years ago
*** Bug 191760 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
*** Bug 183242 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
*** Bug 193210 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
*** Bug 193207 has been marked as a duplicate of this bug. ***

Comment 18

15 years ago
doron, can you get r=/sr= for this patch? samir/dveditz might be some quick
available choices.
I don't think you need to remove the underlying pref implementation, See comment
3 saying this bug is just about the UI for the prefs.

Comment 20

15 years ago
*** Bug 194936 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 21

15 years ago
Created attachment 116340 [details] [diff] [review]
patch, only ui removal

OK, this one removes only the UI

Comment 22

15 years ago
*** Bug 191652 has been marked as a duplicate of this bug. ***

Comment 23

15 years ago
*** Bug 197377 has been marked as a duplicate of this bug. ***

Comment 24

15 years ago
*** Bug 197454 has been marked as a duplicate of this bug. ***
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
(Reporter)

Comment 26

15 years ago
Bug 223782 has an up-to-date patch.

*** This bug has been marked as a duplicate of 223782 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 27

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.